aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2010-04-06 18:46:38 +0800
committerdinoex <dinoex@FreeBSD.org>2010-04-06 18:46:38 +0800
commit7e7bd3890405eda832eab984cd4d9f8340ae44f3 (patch)
treeb67dba98b344d4c3b610ebf1291aa06e2f9845ab /security
parentaaa76fb2d27a950e3d69ec97344441e3f4fff8f1 (diff)
downloadfreebsd-ports-gnome-7e7bd3890405eda832eab984cd4d9f8340ae44f3.tar.gz
freebsd-ports-gnome-7e7bd3890405eda832eab984cd4d9f8340ae44f3.tar.zst
freebsd-ports-gnome-7e7bd3890405eda832eab984cd4d9f8340ae44f3.zip
- chase updated patches for sctp-17 and dtls
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile13
-rw-r--r--security/openssl/distinfo28
2 files changed, 28 insertions, 13 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 5e4113c11286..3790d2d48ddb 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -32,6 +32,7 @@ OPTIONS= I386 "Use optimized assembler for 80386" off \
MD2 "Build with MD2 hash (obsolete)" off \
RC5 "Build with RC5 chipher (patented)" off \
RFC3779 "Build with RFC3779 support" off \
+ DTLS_BUGS "Build with DTLS bugfixes" off \
DTLS_RENEGOTIATION "Build with DTLS Abbr. renegotiations" off \
DTLS_HEARTBEAT "Build with DTLS Heartbeat Extension" off \
TLS_EXTRACTOR "Build with TLS key material extractor" off \
@@ -1099,14 +1100,22 @@ EXTRACONFIGURE+= no-rfc3779
.endif
.if defined(WITH_SCTP)
-WITH_DTLS_RENEGOTIATION?= yes
+WITH_DTLS_BUGS=yes
WITH_TLS_EXTRACTOR?= yes
EXTRACONFIGURE+= sctp
.if defined(WITH_DTLS_HEARTBEAT)
BROKEN= Patches do not merge, please change options
.endif
+.if defined(WITH_DTLS_RENEGOTIATION)
+BROKEN= Patches do not merge, please change options
+.endif
.endif
# order of PATCHFILES is important
+.if defined(WITH_DTLS_BUGS) || make(makesum)
+PATCHFILES+= dtls-replay-bug-1.0.0.patch
+PATCHFILES+= dtls-buffer-bug-1.0.0.patch
+PATCHFILES+= dtls-timeout-bug-1.0.0.patch
+.endif
.if defined(WITH_DTLS_RENEGOTIATION) || make(makesum)
PATCHFILES+= abbreviated-renegotiation.patch
.endif
@@ -1114,7 +1123,7 @@ PATCHFILES+= abbreviated-renegotiation.patch
PATCHFILES+= tls-extractor.patch
.endif
.if defined(WITH_SCTP) || make(makesum)
-PATCHFILES+= dtls-sctp-16.patch
+PATCHFILES+= dtls-sctp-17.patch
.endif
.if defined(WITH_DTLS_HEARTBEAT) || make(makesum)
PATCHFILES+= dtls-heartbeats.patch
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index e736a82f4d57..33b5fac96a44 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,18 +1,24 @@
MD5 (openssl-1.0.0/openssl-1.0.0.tar.gz) = 89eaa86e25b2845f920ec00ae4c864ed
SHA256 (openssl-1.0.0/openssl-1.0.0.tar.gz) = 1bbf9afc5a6215121ac094147d0a84178294fe4c3d0a231731038fd3717ba7ca
SIZE (openssl-1.0.0/openssl-1.0.0.tar.gz) = 4010166
-MD5 (openssl-1.0.0/dtls-sctp-16.patch) = d2d9e318dcf297df05ccb00ac7197676
-SHA256 (openssl-1.0.0/dtls-sctp-16.patch) = 8e6b5aa8430203801f86bb08e3d7813fade0a75f0afe260277184666fb61d20b
-SIZE (openssl-1.0.0/dtls-sctp-16.patch) = 50055
-MD5 (openssl-1.0.0/dtls-bugs-1.0.0.patch) = 70e19be97bf375005132b2b764f0fb11
-SHA256 (openssl-1.0.0/dtls-bugs-1.0.0.patch) = 638141568f155ff64dbc2545863783d3723e811ff3c3bd02881c5ede58beb11c
-SIZE (openssl-1.0.0/dtls-bugs-1.0.0.patch) = 1333
-MD5 (openssl-1.0.0/abbreviated-renegotiation.patch) = ede88c89aa5278d65308f0609009a136
-SHA256 (openssl-1.0.0/abbreviated-renegotiation.patch) = e4e2a4d8a352f606658f175ba603fe2355feb96eeef679decf3e10792e4e5725
-SIZE (openssl-1.0.0/abbreviated-renegotiation.patch) = 6577
+MD5 (openssl-1.0.0/dtls-replay-bug-1.0.0.patch) = 965624f870068b228ae549697769a9ea
+SHA256 (openssl-1.0.0/dtls-replay-bug-1.0.0.patch) = ecd22b870600187648bbd6bcaf7752fc72e79f350386c090c3e77ea29a8e7439
+SIZE (openssl-1.0.0/dtls-replay-bug-1.0.0.patch) = 860
+MD5 (openssl-1.0.0/dtls-buffer-bug-1.0.0.patch) = 6c1c7b62369f0992b3cd8a3874190d71
+SHA256 (openssl-1.0.0/dtls-buffer-bug-1.0.0.patch) = 3794abdf31a206b9f909b4250bbd5ead2dd7a24628add38e09f0ed67b13013ec
+SIZE (openssl-1.0.0/dtls-buffer-bug-1.0.0.patch) = 388
+MD5 (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 4ea76473161328ac84e17606b80ef202
+SHA256 (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 069ba0e8b4137f7754b50e173d50a9f7748f424b003690fc9c7d34b46ac17403
+SIZE (openssl-1.0.0/dtls-timeout-bug-1.0.0.patch) = 442
+MD5 (openssl-1.0.0/abbreviated-renegotiation.patch) = 2409eb80e65effb928032ee18f690dd7
+SHA256 (openssl-1.0.0/abbreviated-renegotiation.patch) = ddbc0683461d364af25b3cd7481d73c6476bfcfb945b3b3c9883f72eabb6367f
+SIZE (openssl-1.0.0/abbreviated-renegotiation.patch) = 6578
MD5 (openssl-1.0.0/tls-extractor.patch) = 23a88cd05cdb3f2040b0866b87586460
SHA256 (openssl-1.0.0/tls-extractor.patch) = bb1aa486327fd96f9d6b870f0a1ad2c83dd4c06a96284eb64dde3f833ba5e0d0
SIZE (openssl-1.0.0/tls-extractor.patch) = 1234
-MD5 (openssl-1.0.0/dtls-heartbeats.patch) = 446c4632a49ab1293e203891a0fc3317
-SHA256 (openssl-1.0.0/dtls-heartbeats.patch) = 4da57a6e9cd779a3f8f1f2055919cbea09eb09b281337b2108f952cb77764355
+MD5 (openssl-1.0.0/dtls-sctp-17.patch) = 9037f54f0d851daa8b35fc5ad5f903c0
+SHA256 (openssl-1.0.0/dtls-sctp-17.patch) = b8968a1a01f459033c40fe15e1b77e8941db301a10bb7668baa3961632c23b4c
+SIZE (openssl-1.0.0/dtls-sctp-17.patch) = 51558
+MD5 (openssl-1.0.0/dtls-heartbeats.patch) = a9ad6a0d30f0b8c1dbbcb084a86d719a
+SHA256 (openssl-1.0.0/dtls-heartbeats.patch) = 173bbddfc1812461b5abfc26a27a57a172a4b33acc8c1307307c4f78f97a0ab4
SIZE (openssl-1.0.0/dtls-heartbeats.patch) = 14113