aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-20 22:53:50 +0800
committerMartin Wilke <miwi@FreeBSD.org>2010-03-20 22:53:50 +0800
commit80b7e09305fa6af89949027155c61a50256c76bc (patch)
treeb0c703eeb3b76b176174e4aebb375ceb87a215cb /security
parentf29016bb0c2ecf3fcc4fb0da9e3769b81e731635 (diff)
downloadfreebsd-ports-gnome-80b7e09305fa6af89949027155c61a50256c76bc.tar.gz
freebsd-ports-gnome-80b7e09305fa6af89949027155c61a50256c76bc.tar.zst
freebsd-ports-gnome-80b7e09305fa6af89949027155c61a50256c76bc.zip
- Mark BROKEN on HEAD: fails to build with new utmpx
Reported by: pointyhat
Diffstat (limited to 'security')
-rw-r--r--security/srp/Makefile4
-rw-r--r--security/sud/Makefile8
-rw-r--r--security/termlog/Makefile8
3 files changed, 18 insertions, 2 deletions
diff --git a/security/srp/Makefile b/security/srp/Makefile
index 75ccf6252b5f..32761a6bb9f7 100644
--- a/security/srp/Makefile
+++ b/security/srp/Makefile
@@ -23,6 +23,10 @@ CONFIGURE_ARGS= --with-openssl=/usr \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
@${GREP} -slR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib\.h|g'
diff --git a/security/sud/Makefile b/security/sud/Makefile
index adaefb0546d5..64153e5fbc09 100644
--- a/security/sud/Makefile
+++ b/security/sud/Makefile
@@ -17,6 +17,12 @@ COMMENT= Execute processes with special privileges in a nosuid environment
GNU_CONFIGURE= yes
MAN1= sud.1 suz.1 ilogin.1
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' \
${WRKSRC}/ilogin.1 ${WRKSRC}/sud.1 ${WRKSRC}/login/login.c ${WRKSRC}/sud/main.c
@@ -35,4 +41,4 @@ post-install:
${CP} -p ${PREFIX}/etc/sud.conf.sample ${PREFIX}/etc/sud.conf ; \
fi
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/termlog/Makefile b/security/termlog/Makefile
index 495f227d9594..9b0c64d2b8de 100644
--- a/security/termlog/Makefile
+++ b/security/termlog/Makefile
@@ -21,8 +21,14 @@ USE_RC_SUBR= ${PORTNAME}
MAN1= termlog.1
PLIST_FILES= bin/termlog
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} > 900007
+BROKEN= fails to build with new utmpx
+.endif
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/termlog ${PREFIX}/bin/termlog
${INSTALL_MAN} ${WRKSRC}/termlog.1 ${MANPREFIX}/man/man1/termlog.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>