aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbillf <billf@FreeBSD.org>2002-07-08 04:11:57 +0800
committerbillf <billf@FreeBSD.org>2002-07-08 04:11:57 +0800
commit812129683c17c7895fb3037704a5a8479aa8b8d2 (patch)
tree24af2d9a9dac4820b733310a58433e67a0951542 /security
parent10d1da5785f94695fa915c90b8d5151cde145692 (diff)
downloadfreebsd-ports-gnome-812129683c17c7895fb3037704a5a8479aa8b8d2.tar.gz
freebsd-ports-gnome-812129683c17c7895fb3037704a5a8479aa8b8d2.tar.zst
freebsd-ports-gnome-812129683c17c7895fb3037704a5a8479aa8b8d2.zip
upgrade from 1.0 to 1.2
Submitted by: fenner's distfile survey
Diffstat (limited to 'security')
-rw-r--r--security/portscanner/Makefile12
-rw-r--r--security/portscanner/distinfo2
-rw-r--r--security/portscanner/files/patch-aa35
-rw-r--r--security/portscanner/files/patch-ab29
4 files changed, 33 insertions, 45 deletions
diff --git a/security/portscanner/Makefile b/security/portscanner/Makefile
index 5ca80b28efca..12b7ec12ce57 100644
--- a/security/portscanner/Makefile
+++ b/security/portscanner/Makefile
@@ -6,23 +6,17 @@
#
PORTNAME= portscanner
-PORTVERSION= 1.0
+PORTVERSION= 1.2
CATEGORIES= security
-MASTER_SITES= http://www.ameth.org/~veilleux/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= billf
-DISTNAME= PortScanner-1.0
+MASTER_SITES= http://www.ameth.org/~veilleux/PortScan/
+DISTNAME= PortScanner-${PORTVERSION}
MAINTAINER= billf@FreeBSD.org
-NO_WRKSUBDIR= yes
-
do-build:
-
@ ${CC} -o ${WRKSRC}/portscanner ${CFLAGS} ${WRKSRC}/portscanner.c
do-install:
-
@ ${INSTALL_PROGRAM} ${WRKSRC}/portscanner ${PREFIX}/bin
.include <bsd.port.mk>
diff --git a/security/portscanner/distinfo b/security/portscanner/distinfo
index 40b23dbaf9ea..ed9a1940bf60 100644
--- a/security/portscanner/distinfo
+++ b/security/portscanner/distinfo
@@ -1 +1 @@
-MD5 (PortScanner-1.0.tar.gz) = 633e77b3cd66872d7baef0b14bbbf13e
+MD5 (PortScanner-1.2.tar.gz) = e03b613ad7bc102d041d1e4b4442b99a
diff --git a/security/portscanner/files/patch-aa b/security/portscanner/files/patch-aa
deleted file mode 100644
index 7a0100be070a..000000000000
--- a/security/portscanner/files/patch-aa
+++ /dev/null
@@ -1,35 +0,0 @@
---- portscanner.c.orig Sun Aug 9 14:50:35 1998
-+++ portscanner.c Thu Dec 3 11:15:05 1998
-@@ -24,18 +24,21 @@
- /***********************************************************/
-
- #include <stdio.h>
-+#include <stdlib.h>
-+#include <unistd.h>
- #include <sys/socket.h>
- #include <sys/types.h>
- #include <netinet/in.h>
--#include <unistd.h>
-+#include <arpa/inet.h>
- #include <netdb.h>
- #include <sys/time.h>
- #include <fcntl.h>
-+#include <string.h>
-
- int sock = -1;
- struct sockaddr_in address;
- int result;
--extern char *sys_errlist[];
-+/* extern char *sys_errlist[]; */
- extern int errno;
- int current_port = 0;
- u_short base_port = 0;
-@@ -83,7 +86,7 @@
- } else if (verbose == 2) printf(" address valid\n");
-
- if ((base_port > end_port) || ((short)base_port < 0)) {
-- fprintf(stderr,"Bad port range : start=%d end=%d !\n");
-+ fprintf(stderr,"Bad port range : start=%d end=%d !\n",base_port,end_port);
- exit(1);
- } else if (verbose == 2) {
- printf("Port range: %d to %d\n",base_port,end_port);
diff --git a/security/portscanner/files/patch-ab b/security/portscanner/files/patch-ab
new file mode 100644
index 000000000000..b92c4258e856
--- /dev/null
+++ b/security/portscanner/files/patch-ab
@@ -0,0 +1,29 @@
+--- portscanner.c.orig Wed Aug 19 10:37:44 1998
++++ portscanner.c Sun Jul 7 13:16:39 2002
+@@ -25,8 +25,8 @@
+ /***********************************************************/
+
+ #include <stdio.h>
+-#include <sys/socket.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <unistd.h>
+ #include <netdb.h>
+@@ -268,7 +268,7 @@
+ goodproto = 0;
+ } else address2.sin_port = htons(base_port+current_port);
+
+- if (!finished)
++ if (!finished) {
+ if (connect(sock, (struct sockaddr *)&address2, sizeof(address2)) == 0) {
+ switch (verbose) {
+ case 0: if (strobe)
+@@ -312,6 +312,7 @@
+ finished = 1;
+ }
+ /* fprintf(stderr,"current_port: %d,b: %d,e:%d,b+c:%d\n", current_port, base_port,end_port,base_port+current_port); */
++ }
+ }
+
+ if (verbose == 2) printf("Port scan finished !\n");