aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-16 05:00:20 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-16 05:00:20 +0800
commit817d3c3fdbbb303f6a7b573ba42e2caa077d2fe2 (patch)
tree6ebcdd00ff072c03873cf21cd6f25cec7181277e /security
parent9c9d678e38fd8ab2769c6378e690cd318f03143c (diff)
downloadfreebsd-ports-gnome-817d3c3fdbbb303f6a7b573ba42e2caa077d2fe2.tar.gz
freebsd-ports-gnome-817d3c3fdbbb303f6a7b573ba42e2caa077d2fe2.tar.zst
freebsd-ports-gnome-817d3c3fdbbb303f6a7b573ba42e2caa077d2fe2.zip
- Handle permissions in plist
- Unsilence install Approved by: portmgr blanket
Diffstat (limited to 'security')
-rw-r--r--security/pwauth/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/pwauth/Makefile b/security/pwauth/Makefile
index 1775da6f119f..cbcd5414d80e 100644
--- a/security/pwauth/Makefile
+++ b/security/pwauth/Makefile
@@ -12,7 +12,8 @@ COMMENT= Unix Web Authenticator
LICENSE= BSD3CLAUSE
-PLIST_FILES= bin/pwauth bin/checkfaillog
+PLIST_FILES= "@(,,4555) bin/pwauth" \
+ bin/checkfaillog
ALL_TARGET= pwauth checkfaillog
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}" LIB="-lcrypt -lpam"
@@ -25,8 +26,7 @@ post-patch:
s/%%MINUID%%/${MINUID}/" ${WRKSRC}/config.h
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/pwauth ${STAGEDIR}${PREFIX}/bin
- @${INSTALL_PROGRAM} ${WRKSRC}/checkfaillog ${STAGEDIR}${PREFIX}/bin
- @${CHMOD} u=rxs ${STAGEDIR}${PREFIX}/bin/pwauth
+ ${INSTALL_PROGRAM} ${WRKSRC}/pwauth ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/checkfaillog ${STAGEDIR}${PREFIX}/bin
.include <bsd.port.mk>