aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-09-26 11:11:57 +0800
committerKris Kennaway <kris@FreeBSD.org>2004-09-26 11:11:57 +0800
commit82f9e5ad5571ce54362c74935980b39d71601aeb (patch)
tree2f71c6551b79631fbd542b141c384e669000ca3e /security
parent954affa7791628821f7a44260c318fd8b30ae842 (diff)
downloadfreebsd-ports-gnome-82f9e5ad5571ce54362c74935980b39d71601aeb.tar.gz
freebsd-ports-gnome-82f9e5ad5571ce54362c74935980b39d71601aeb.tar.zst
freebsd-ports-gnome-82f9e5ad5571ce54362c74935980b39d71601aeb.zip
BROKEN on 5.x: Does not compile
Approved by: portmgr (self)
Diffstat (limited to 'security')
-rw-r--r--security/samhain/Makefile4
-rw-r--r--security/sfs/Makefile4
-rw-r--r--security/smtpmap/Makefile8
-rw-r--r--security/stegdetect/Makefile4
4 files changed, 19 insertions, 1 deletions
diff --git a/security/samhain/Makefile b/security/samhain/Makefile
index e9cf4b6382f5..72c26746f8f0 100644
--- a/security/samhain/Makefile
+++ b/security/samhain/Makefile
@@ -36,6 +36,10 @@ OPTIONS= KCHECK "Enable rogue KLD detection" on \
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not build on FreeBSD >= 5.x"
+.endif
+
.if defined(WITH_GPG)
BUILD_DEPENDS+= gpg:${PORTSDIR}/security/gnupg
.endif
diff --git a/security/sfs/Makefile b/security/sfs/Makefile
index e1f09b457a2c..8793b7ef6129 100644
--- a/security/sfs/Makefile
+++ b/security/sfs/Makefile
@@ -34,6 +34,10 @@ CONFIGURE_ARGS+=--with-sfsuser=sfs \
BROKEN= "Does not compile on !i386"
.endif
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
.if ${OSVERSION} > 500000
LIB_DEPENDS+= gmp.6:${PORTSDIR}/math/libgmp4
CONFIGURE_ARGS+=--with-gmp=${LOCALBASE}
diff --git a/security/smtpmap/Makefile b/security/smtpmap/Makefile
index 11632a19f264..940ab31dea81 100644
--- a/security/smtpmap/Makefile
+++ b/security/smtpmap/Makefile
@@ -25,6 +25,12 @@ USE_GMAKE= yes
MAKEFILE= makefile
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|g' \
-e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/makefile.conf
@@ -38,4 +44,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/share/${file} ${DATADIR}
.endfor
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index 5f4658cae025..c0bd5055159c 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -35,6 +35,10 @@ PLIST_SUB+= X11=""
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
${REINPLACE_CMD} 's/$$(JPEGLIB)/$$(JPEGLIB) -lcrypto/' \
${WRKSRC}/Makefile.in