aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2003-08-28 21:11:25 +0800
committerume <ume@FreeBSD.org>2003-08-28 21:11:25 +0800
commit8509f1672cea8ee5354b71ee33d8bd0dbdb8cd47 (patch)
tree5e1538156e30e8a93b9c0818f21ccdce5fe33ca7 /security
parente14b0c249fe9f1eed4ec3cf822243477c5638d82 (diff)
downloadfreebsd-ports-gnome-8509f1672cea8ee5354b71ee33d8bd0dbdb8cd47.tar.gz
freebsd-ports-gnome-8509f1672cea8ee5354b71ee33d8bd0dbdb8cd47.tar.zst
freebsd-ports-gnome-8509f1672cea8ee5354b71ee33d8bd0dbdb8cd47.zip
Use USE_OPENLDAP.
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 1517f0f56822..668ad956ce6d 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -59,14 +59,15 @@ CONFIGURE_ARGS+=--with-dblib=ndbm
.endif
.if defined(WITH_OPENLDAP_VER)
-.if ${WITH_OPENLDAP_VER} == 20 || ${WITH_OPENLDAP_VER} == 21 || \
- ${WITH_OPENLDAP_VER} == 22
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap${WITH_OPENLDAP_VER}-client
-LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap${WITH_OPENLDAP_VER}-client
-CONFIGURE_ARGS+=--with-ldap=${PREFIX}
-.else
-BROKEN= "WITH_OPENLDAP_VER must be 20, 21 or 22"
+WITH_OPENLDAP= yes
+WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
+.if defined(WITH_OPENLDAP)
+.if defined(WANT_OPENLDAP_VER) && ${WANT_OPENLDAP_VER} == 12
+BROKEN= "this port requires OpenLDAP >= 2.0"
+.endif
+USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-ldap=${PREFIX}
.endif
.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.a)