aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-09-29 02:43:30 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-09-29 02:43:30 +0800
commit85fd0fe2ef36b0439118b8f5c10968f70a1035b6 (patch)
treef1a7be028218c6172032a37def0bd744211e2716 /security
parentea2acd30ba926f2620def49168b82396764df7eb (diff)
downloadfreebsd-ports-gnome-85fd0fe2ef36b0439118b8f5c10968f70a1035b6.tar.gz
freebsd-ports-gnome-85fd0fe2ef36b0439118b8f5c10968f70a1035b6.tar.zst
freebsd-ports-gnome-85fd0fe2ef36b0439118b8f5c10968f70a1035b6.zip
- Update to 2.3-beta1 [1]
- Add LICENSE [1] - Convert to new options framework - Remove ABI versions from LIB_DEPENDS - Update to new header PR: ports/171738 [1] Submitted by: Eric F Crist <ecrist@secure-computing.net> (maintainer) [1]
Diffstat (limited to 'security')
-rw-r--r--security/openvpn-beta/Makefile75
-rw-r--r--security/openvpn-beta/distinfo4
-rw-r--r--security/openvpn-beta/files/patch-t_cltsrv.sh11
-rw-r--r--security/openvpn-beta/files/pkg-message.in12
-rw-r--r--security/openvpn-beta/files/pkg-req.in30
-rw-r--r--security/openvpn-beta/pkg-plist68
6 files changed, 68 insertions, 132 deletions
diff --git a/security/openvpn-beta/Makefile b/security/openvpn-beta/Makefile
index 2fc39596a330..f2ba9fca800e 100644
--- a/security/openvpn-beta/Makefile
+++ b/security/openvpn-beta/Makefile
@@ -1,11 +1,8 @@
-# New ports collection makefile for: openvpn
-# Date created: 2010-08-13
-# Whom: Eric F Crist <ecrist@secure-computing.net>
-#
+# Created By: Eric F Crist <ecrist@secure-computing.net>
# $FreeBSD$
PORTNAME= openvpn
-DISTVERSION= 2.2-RC2
+DISTVERSION= 2.3_beta1
CATEGORIES= security net
MASTER_SITES= http://swupdate.openvpn.net/community/releases/
PKGNAMESUFFIX= -beta
@@ -13,44 +10,50 @@ PKGNAMESUFFIX= -beta
MAINTAINER= ecrist@secure-computing.net
COMMENT= Secure IP/Ethernet tunnel daemon
-# ecrist will update the -beta port as soon as there are formal
-# upstream test releases derived from openvpn-devel; in the meanwhile,
-# move users to -devel.
-IGNORE= use openvpn-devel instead for now, there are currently no formal -betas.
+LICENSE= GPLv2
-CONFLICTS= openvpn-devel-[0-9]* openvpn-2.0*
+CONFLICTS_INSTALL= openvpn-[0-9]* openvpn-beta-[0-9]*
USE_XZ= yes
+
GNU_CONFIGURE= yes
-USE_OPENSSL= yes
-CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
- --with-lzo-headers=${LOCALBASE}/include \
- --disable-depr-random-resolv
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install mandir=${MANPREFIX}/man
+LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
+
MAN8= openvpn.8
-OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off \
- PKCS11 "Use security/pkcs11-helper" off
+OPTIONS_DEFINE= PW_SAVE PKCS11 POLARSSL
+PW_SAVE_DESC= Interactive passwords may be read from a file
+PKCS11_DESC= Use security/pkcs11-helper
+POLARSSL_DESC= Build with PolarSSL instead of OpenSSL
USE_RC_SUBR= openvpn
USE_LDCONFIG= ${PREFIX}/lib
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
-
-SUB_FILES= pkg-message pkg-req
+SUB_FILES= pkg-message
SUB_LIST+= OSVERSION=${OSVERSION}
.if defined(PACKAGE_BUILDING)
WITHOUT_CHECK= yes
.endif
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.ifdef (LOG_OPENVPN)
CFLAGS+= -DLOG_OPENVPN=${LOG_OPENVPN}
.endif
+.if ${PORT_OPTIONS:MPOLARSSL}
+LIB_DEPENDS+= polarssl:${PORTSDIR}/security/polarssl
+CONFIGURE_ARGS+= --with-crypto-library=polarssl
+WITHOUT_CHECK= yes
+.else
+USE_OPENSSL= yes
+.endif
+
pre-fetch:
.ifdef (LOG_OPENVPN)
@${ECHO} "Building with LOG_OPENVPN=${LOG_OPENVPN}"
@@ -63,12 +66,12 @@ pre-fetch:
@${ECHO} ""
.endif
-.if defined(WITH_PW_SAVE)
+.if ${PORT_OPTIONS:MPW_SAVE}
CONFIGURE_ARGS+= --enable-password-save
.endif
-.if defined(WITH_PKCS11)
-LIB_DEPENDS+= pkcs11-helper.1:${PORTSDIR}/security/pkcs11-helper
+.if ${PORT_OPTIONS:MPKCS11}
+LIB_DEPENDS+= pkcs11-helper:${PORTSDIR}/security/pkcs11-helper
.else
CONFIGURE_ARGS+= --disable-pkcs11
.endif
@@ -78,39 +81,31 @@ post-patch:
@${FIND} ${WRKSRC} -name \*.bak -delete
post-build:
- cd ${WRKSRC}/plugin/down-root && ${MAKE}
- cd ${WRKSRC}/plugin/auth-pam && ${CC} ${CPPFLAGS} -I../.. -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
+ cd ${WRKSRC}/src/plugins/down-root && ${MAKE}
+ cd ${WRKSRC}/src/plugins/auth-pam && ${CC} ${CPPFLAGS} -I../../../include -DDLOPEN_PAM=0 ${CFLAGS} -fPIC -shared -Wl,-soname,openvpn-auth-pam.so -o openvpn-auth-pam.so auth-pam.c pamdl.c -lc -lpam
@# self-tests here
.if !defined(WITHOUT_CHECK)
cd ${WRKSRC} && ${MAKE} check
.endif
-pre-install:
- PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
-
post-install:
${MKDIR} ${PREFIX}/lib
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/down-root/openvpn-down-root.so ${PREFIX}/lib/
- ${INSTALL_PROGRAM} ${WRKSRC}/plugin/auth-pam/openvpn-auth-pam.so ${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/
+ ${INSTALL_LIB} ${WRKSRC}/src/plugins/auth-pam/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/
+ ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-down-root.so ${PREFIX}/lib/openvpn-down-root.so
+ ${LN} -s ${WRKSRC}/src/plugins/down-root/.libs/openvpn-plugin-auth-pam.so ${PREFIX}/lib/openvpn-auth-pam.so
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/plugin/down-root/README ${DOCSDIR}/README.openvpn-down-root
- ${INSTALL_DATA} ${WRKSRC}/plugin/auth-pam/README ${DOCSDIR}/README.openvpn-auth-pam
.for docs in AUTHORS COPYING COPYRIGHT.GPL ChangeLog INSTALL \
PORTS README
${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}/
.endfor
-.for dir in easy-rsa easy-rsa/1.0 easy-rsa/2.0 sample-config-files
- ${MKDIR} ${DOCSDIR}/${dir}
- ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_DATA} \{\} ${DOCSDIR}/${dir} \;
-.endfor
-.for dir in sample-scripts
- ${MKDIR} ${DOCSDIR}/${dir}
- ${FIND} ${WRKSRC}/${dir}/ -maxdepth 1 -type f -exec ${INSTALL_SCRIPT} \{\} ${DOCSDIR}/${dir} \;
+.for sample in sample-config-files sample-scripts
+ (cd ${WRKSRC}/sample/${sample} && ${COPYTREE_SHARE} \* ${DOCSDIR}/${sample})
.endfor
.else
-@${RMDIR} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openvpn-beta/distinfo b/security/openvpn-beta/distinfo
index c5cf5dad037a..fd248e4f0944 100644
--- a/security/openvpn-beta/distinfo
+++ b/security/openvpn-beta/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openvpn-2.2-RC2.tar.xz) = 8fdfab6be1ba6d0101601966123cd108536ca08259503c131bf270132c7d15b4
-SIZE (openvpn-2.2-RC2.tar.xz) = 639196
+SHA256 (openvpn-2.3_beta1.tar.xz) = 885c332fe5527ecefd2b69f8f190877d477731b578c4c7283dc989a5ea686a25
+SIZE (openvpn-2.3_beta1.tar.xz) = 763628
diff --git a/security/openvpn-beta/files/patch-t_cltsrv.sh b/security/openvpn-beta/files/patch-t_cltsrv.sh
deleted file mode 100644
index c5deea6254de..000000000000
--- a/security/openvpn-beta/files/patch-t_cltsrv.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./t_cltsrv.sh.orig 2011-07-20 22:10:38.000000000 +0200
-+++ ./t_cltsrv.sh 2011-07-20 22:10:52.000000000 +0200
-@@ -33,7 +33,7 @@
- echo "###"
- echo "### To run the test in a FreeBSD jail, you MUST add an IP alias for the jail's IP."
- echo "###"
-- exit 1
-+ exit 77
- fi
- fi
- ;;
diff --git a/security/openvpn-beta/files/pkg-message.in b/security/openvpn-beta/files/pkg-message.in
index 44f3fa616845..5954b638883a 100644
--- a/security/openvpn-beta/files/pkg-message.in
+++ b/security/openvpn-beta/files/pkg-message.in
@@ -8,3 +8,15 @@
### NOTE THIS IS AN UNSTABLE BETA VERSION UNDER DEVELOPMENT!
### It may or may not be suitable for production. Use at your own risk.
### ------------------------------------------------------------------------
+###
+### PLUGIN LOCATION CHANGED!
+### The following plugin locations have changed. There is a symlink to the
+### new file for the duration of the 2.3 release. This will be removed in
+### OpenVPN 2.4+.
+### Old Location:
+### %%PREFIX%%/openvpn/plugins/openvpn-plugin-auth-pam.so
+### %%PREFIX%%/openvpn/plugins/openvpn-plugin-down-root.so
+###
+### New Location:
+### %%PREFIX%%/openvpn-plugin-auth-pam.so
+### %%PREFIX%%/openvpn-plugin-down-root.so
diff --git a/security/openvpn-beta/files/pkg-req.in b/security/openvpn-beta/files/pkg-req.in
deleted file mode 100644
index 7ecaaa576ff1..000000000000
--- a/security/openvpn-beta/files/pkg-req.in
+++ /dev/null
@@ -1,30 +0,0 @@
-set -e
-
-rcvers() {
- # determine if we have "old" or "new" (rcorder integration) scheme
- # for %%PREFIX%%/etc/rc.d/* files
- if test $1 -ge 700007 || test $1 -lt 700000 -a $1 -ge 600101 ; then
- echo 2
- else
- echo 1
- fi
-}
-
-if [ "$2" = INSTALL ] ; then
- # check if the base system is new enough for us,
- # which should only matter for package installs.
- buildrc=$(rcvers %%OSVERSION%%)
- execrc=$(rcvers $(sysctl -n kern.osreldate) )
- if test $buildrc -gt $execrc ; then
- cat <<EOF
-
-Error: this package, $1, was compiled for a newer FreeBSD
-====== version that uses different boot scripts.
- Therefore, the rc.d script WILL NOT WORK.
- Please update your ports tree and install security/openvpn-devel
- from there.
-
-EOF
- exit 1
- fi
-fi
diff --git a/security/openvpn-beta/pkg-plist b/security/openvpn-beta/pkg-plist
index c92c36c1a1de..b5335c50e32c 100644
--- a/security/openvpn-beta/pkg-plist
+++ b/security/openvpn-beta/pkg-plist
@@ -1,6 +1,13 @@
-sbin/openvpn
+lib/openvpn/plugins/openvpn-plugin-auth-pam.so
+lib/openvpn-plugin-auth-pam.so
+lib/openvpn/plugins/openvpn-plugin-auth-pam.la
+lib/openvpn/plugins/openvpn-plugin-down-root.so
+lib/openvpn-plugin-down-root.so
+lib/openvpn/plugins/openvpn-plugin-down-root.la
lib/openvpn-auth-pam.so
lib/openvpn-down-root.so
+include/openvpn-plugin.h
+sbin/openvpn
%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/COPYRIGHT.GPL
@@ -8,48 +15,11 @@ lib/openvpn-down-root.so
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/PORTS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-auth-pam
-%%PORTDOCS%%%%DOCSDIR%%/README.openvpn-down-root
+%%PORTDOCS%%%%DOCSDIR%%/README.auth-pam
+%%PORTDOCS%%%%DOCSDIR%%/README.down-root
+%%PORTDOCS%%%%DOCSDIR%%/README.IPv6
+%%PORTDOCS%%%%DOCSDIR%%/README.polarssl
%%PORTDOCS%%%%DOCSDIR%%/management-notes.txt
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/make-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/revoke-crt
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/1.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/Makefile
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/README
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-ca
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-dh
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-pkcs12
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-key-server
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/build-req-pass
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/clean-all
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/inherit-inter
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/list-crl
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl-0.9.6.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/openssl.cnf
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/pkitool
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/revoke-full
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/sign-req
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/vars
-%%PORTDOCS%%%%DOCSDIR%%/easy-rsa/2.0/whichopensslcnf
%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/README
%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/client.conf
%%PORTDOCS%%%%DOCSDIR%%/sample-config-files/firewall.sh
@@ -69,12 +39,12 @@ lib/openvpn-down-root.so
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/auth-pam.pl
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-start
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/bridge-stop
-%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/openvpn.init
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/ucn.pl
%%PORTDOCS%%%%DOCSDIR%%/sample-scripts/verify-cn
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-scripts
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/sample-config-files
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/2.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa/1.0
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/easy-rsa
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/openvpn
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample-config-files
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%/sample-scripts
+@dirrmtry %%PORTDOCS%%%%DOCSDIR%%
+@dirrmtry lib/openvpn/plugins
+@dirrmtry lib/openvpn