aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjgreco <jgreco@FreeBSD.org>1997-04-04 07:09:49 +0800
committerjgreco <jgreco@FreeBSD.org>1997-04-04 07:09:49 +0800
commit87cde24010b7cc0d653081cac841a29aa3fac5eb (patch)
tree3cdb394d89f4fe62d7a42065f4d10983e4793c29 /security
parentcb612546db3db1e0d61d12bcdcd69db35c36c253 (diff)
downloadfreebsd-ports-gnome-87cde24010b7cc0d653081cac841a29aa3fac5eb.tar.gz
freebsd-ports-gnome-87cde24010b7cc0d653081cac841a29aa3fac5eb.tar.zst
freebsd-ports-gnome-87cde24010b7cc0d653081cac841a29aa3fac5eb.zip
Minor correction-
Changed floppy generation code to chmod gunzip to executable by a better strategic location for the chmod command. The former code failed to do this, meaning gunzip couldn't be run from the floppy. "Ooops". Yes, I actually do use this code! Honest! :-)
Diffstat (limited to 'security')
-rw-r--r--security/tripwire-131/Makefile4
-rw-r--r--security/tripwire/Makefile4
-rw-r--r--security/tripwire12/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/security/tripwire-131/Makefile b/security/tripwire-131/Makefile
index 83ab0b135de9..b9ac9dddf8ad 100644
--- a/security/tripwire-131/Makefile
+++ b/security/tripwire-131/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 Mar 1997
# Whom: Joe Greco <jgreco@ns.sol.net>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/04/01 04:44:00 jdp Exp $
#
DISTNAME= tripwire-1.2
@@ -36,12 +36,12 @@ post-install:
@ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
@ mount /dev/fd0c /mnt
@ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
- @ chmod 555 /mnt/tripwire
@ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
@ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
> /mnt/tw.db_`hostname`.gz
@ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
@ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
+ @ chmod 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
@ umount /mnt
@ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif
diff --git a/security/tripwire/Makefile b/security/tripwire/Makefile
index 83ab0b135de9..b9ac9dddf8ad 100644
--- a/security/tripwire/Makefile
+++ b/security/tripwire/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 Mar 1997
# Whom: Joe Greco <jgreco@ns.sol.net>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/04/01 04:44:00 jdp Exp $
#
DISTNAME= tripwire-1.2
@@ -36,12 +36,12 @@ post-install:
@ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
@ mount /dev/fd0c /mnt
@ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
- @ chmod 555 /mnt/tripwire
@ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
@ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
> /mnt/tw.db_`hostname`.gz
@ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
@ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
+ @ chmod 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
@ umount /mnt
@ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif
diff --git a/security/tripwire12/Makefile b/security/tripwire12/Makefile
index 83ab0b135de9..b9ac9dddf8ad 100644
--- a/security/tripwire12/Makefile
+++ b/security/tripwire12/Makefile
@@ -3,7 +3,7 @@
# Date created: 31 Mar 1997
# Whom: Joe Greco <jgreco@ns.sol.net>
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/04/01 04:44:00 jdp Exp $
#
DISTNAME= tripwire-1.2
@@ -36,12 +36,12 @@ post-install:
@ newfs -u 0 -t 0 -i 196608 -m 0 -T minimum -o space /dev/rfd0c
@ mount /dev/fd0c /mnt
@ ${GZIP_CMD} < ${PREFIX}/bin/tripwire > /mnt/tripwire
- @ chmod 555 /mnt/tripwire
@ ${CP} -p /var/adm/tcheck/tw.config /mnt/tw.config
@ ${GZIP_CMD} < /var/adm/tcheck/databases/tw.db_`hostname` \
> /mnt/tw.db_`hostname`.gz
@ ${CP} -p ${FILESDIR}/twcheck /mnt/twcheck
@ ${GZIP_CMD} < /usr/bin/gunzip > /mnt/gunzip
+ @ chmod 555 /mnt/tripwire /mnt/gunzip /mnt/twcheck
@ umount /mnt
@ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif