aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2002-08-03 02:22:45 +0800
committernectar <nectar@FreeBSD.org>2002-08-03 02:22:45 +0800
commit88bd97121501a81e9f458755e8aa83d7ad0e52f0 (patch)
treeb5d57bb276da8b9b2736b25b8e8f47c430c6b2cf /security
parentee794f49bddfa8174cc8470c4bee05f6826c7b3d (diff)
downloadfreebsd-ports-gnome-88bd97121501a81e9f458755e8aa83d7ad0e52f0.tar.gz
freebsd-ports-gnome-88bd97121501a81e9f458755e8aa83d7ad0e52f0.tar.zst
freebsd-ports-gnome-88bd97121501a81e9f458755e8aa83d7ad0e52f0.zip
Correct Sun RPC buffer overflow.
<URL:http://online.securityfocus.com/archive/1/285308> <URL:http://bvlive01.iss.net/issEn/delivery/xforce/alertdetail.jsp?oid=20823>
Diffstat (limited to 'security')
-rw-r--r--security/krb5-16/Makefile2
-rw-r--r--security/krb5-16/files/patch-lib::rpc::xdr_array.c20
-rw-r--r--security/krb5-17/Makefile2
-rw-r--r--security/krb5-17/files/patch-lib::rpc::xdr_array.c20
-rw-r--r--security/krb5-appl/Makefile2
-rw-r--r--security/krb5-appl/files/patch-lib::rpc::xdr_array.c20
-rw-r--r--security/krb5/Makefile2
-rw-r--r--security/krb5/files/patch-lib::rpc::xdr_array.c20
8 files changed, 84 insertions, 4 deletions
diff --git a/security/krb5-16/Makefile b/security/krb5-16/Makefile
index 2bb196574f7e..5406f50c601c 100644
--- a/security/krb5-16/Makefile
+++ b/security/krb5-16/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == "NO"
MASTER_SITES= http://www.crypto-publish.org/dist/mit-kerberos5/
diff --git a/security/krb5-16/files/patch-lib::rpc::xdr_array.c b/security/krb5-16/files/patch-lib::rpc::xdr_array.c
new file mode 100644
index 000000000000..be9be37eada6
--- /dev/null
+++ b/security/krb5-16/files/patch-lib::rpc::xdr_array.c
@@ -0,0 +1,20 @@
+--- lib/rpc/xdr_array.c.orig Fri Feb 13 20:27:23 1998
++++ lib/rpc/xdr_array.c Fri Aug 2 13:03:55 2002
+@@ -40,6 +40,7 @@
+ * arrays. See xdr.h for more info on the interface to xdr.
+ */
+
++#include <limits.h>
+ #include <stdio.h>
+
+ #include <gssrpc/types.h>
+@@ -75,7 +76,8 @@
+ return (FALSE);
+ }
+ c = *sizep;
+- if ((c > maxsize) && (xdrs->x_op != XDR_FREE)) {
++ if ((c > maxsize || UINT_MAX/elsize < c) &&
++ (xdrs->x_op != XDR_FREE)) {
+ return (FALSE);
+ }
+ nodesize = c * elsize;
diff --git a/security/krb5-17/Makefile b/security/krb5-17/Makefile
index 2bb196574f7e..5406f50c601c 100644
--- a/security/krb5-17/Makefile
+++ b/security/krb5-17/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == "NO"
MASTER_SITES= http://www.crypto-publish.org/dist/mit-kerberos5/
diff --git a/security/krb5-17/files/patch-lib::rpc::xdr_array.c b/security/krb5-17/files/patch-lib::rpc::xdr_array.c
new file mode 100644
index 000000000000..be9be37eada6
--- /dev/null
+++ b/security/krb5-17/files/patch-lib::rpc::xdr_array.c
@@ -0,0 +1,20 @@
+--- lib/rpc/xdr_array.c.orig Fri Feb 13 20:27:23 1998
++++ lib/rpc/xdr_array.c Fri Aug 2 13:03:55 2002
+@@ -40,6 +40,7 @@
+ * arrays. See xdr.h for more info on the interface to xdr.
+ */
+
++#include <limits.h>
+ #include <stdio.h>
+
+ #include <gssrpc/types.h>
+@@ -75,7 +76,8 @@
+ return (FALSE);
+ }
+ c = *sizep;
+- if ((c > maxsize) && (xdrs->x_op != XDR_FREE)) {
++ if ((c > maxsize || UINT_MAX/elsize < c) &&
++ (xdrs->x_op != XDR_FREE)) {
+ return (FALSE);
+ }
+ nodesize = c * elsize;
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 2bb196574f7e..5406f50c601c 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == "NO"
MASTER_SITES= http://www.crypto-publish.org/dist/mit-kerberos5/
diff --git a/security/krb5-appl/files/patch-lib::rpc::xdr_array.c b/security/krb5-appl/files/patch-lib::rpc::xdr_array.c
new file mode 100644
index 000000000000..be9be37eada6
--- /dev/null
+++ b/security/krb5-appl/files/patch-lib::rpc::xdr_array.c
@@ -0,0 +1,20 @@
+--- lib/rpc/xdr_array.c.orig Fri Feb 13 20:27:23 1998
++++ lib/rpc/xdr_array.c Fri Aug 2 13:03:55 2002
+@@ -40,6 +40,7 @@
+ * arrays. See xdr.h for more info on the interface to xdr.
+ */
+
++#include <limits.h>
+ #include <stdio.h>
+
+ #include <gssrpc/types.h>
+@@ -75,7 +76,8 @@
+ return (FALSE);
+ }
+ c = *sizep;
+- if ((c > maxsize) && (xdrs->x_op != XDR_FREE)) {
++ if ((c > maxsize || UINT_MAX/elsize < c) &&
++ (xdrs->x_op != XDR_FREE)) {
+ return (FALSE);
+ }
+ nodesize = c * elsize;
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 2bb196574f7e..5406f50c601c 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -7,7 +7,7 @@
PORTNAME= krb5
PORTVERSION= 1.2.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
.if defined(USA_RESIDENT) && ${USA_RESIDENT} == "NO"
MASTER_SITES= http://www.crypto-publish.org/dist/mit-kerberos5/
diff --git a/security/krb5/files/patch-lib::rpc::xdr_array.c b/security/krb5/files/patch-lib::rpc::xdr_array.c
new file mode 100644
index 000000000000..be9be37eada6
--- /dev/null
+++ b/security/krb5/files/patch-lib::rpc::xdr_array.c
@@ -0,0 +1,20 @@
+--- lib/rpc/xdr_array.c.orig Fri Feb 13 20:27:23 1998
++++ lib/rpc/xdr_array.c Fri Aug 2 13:03:55 2002
+@@ -40,6 +40,7 @@
+ * arrays. See xdr.h for more info on the interface to xdr.
+ */
+
++#include <limits.h>
+ #include <stdio.h>
+
+ #include <gssrpc/types.h>
+@@ -75,7 +76,8 @@
+ return (FALSE);
+ }
+ c = *sizep;
+- if ((c > maxsize) && (xdrs->x_op != XDR_FREE)) {
++ if ((c > maxsize || UINT_MAX/elsize < c) &&
++ (xdrs->x_op != XDR_FREE)) {
+ return (FALSE);
+ }
+ nodesize = c * elsize;