aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoraaron <aaron@FreeBSD.org>2006-05-23 01:15:34 +0800
committeraaron <aaron@FreeBSD.org>2006-05-23 01:15:34 +0800
commit8dcbebad85f6769a95127fa3ad9ca1b32e63e243 (patch)
treef2af9e67c43ff6cecdfa36d1d81fe1687c6d3c7a /security
parent5983388cd862f0efa63fe2ea9c9e7ea941dd899c (diff)
downloadfreebsd-ports-gnome-8dcbebad85f6769a95127fa3ad9ca1b32e63e243.tar.gz
freebsd-ports-gnome-8dcbebad85f6769a95127fa3ad9ca1b32e63e243.tar.zst
freebsd-ports-gnome-8dcbebad85f6769a95127fa3ad9ca1b32e63e243.zip
Adding port security/p5-Authen-Simple-SMB, SMB extension for security/p5-Authen-Simple.
Approved by: tobez (implicit)
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Simple-SMB/Makefile32
-rw-r--r--security/p5-Authen-Simple-SMB/distinfo3
-rw-r--r--security/p5-Authen-Simple-SMB/pkg-descr4
-rw-r--r--security/p5-Authen-Simple-SMB/pkg-plist3
5 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b8d60a5aaa69..cb8519fbf38c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -296,6 +296,7 @@
SUBDIR += p5-Authen-Simple-LDAP
SUBDIR += p5-Authen-Simple-Net
SUBDIR += p5-Authen-Simple-Passwd
+ SUBDIR += p5-Authen-Simple-SMB
SUBDIR += p5-Authen-Simple-SSH
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
diff --git a/security/p5-Authen-Simple-SMB/Makefile b/security/p5-Authen-Simple-SMB/Makefile
new file mode 100644
index 000000000000..c180e4df49c0
--- /dev/null
+++ b/security/p5-Authen-Simple-SMB/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Authen-Simple-SMB
+# Date created: 22 May 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Simple-SMB
+PORTVERSION= 0.1
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Simple SMB authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/Simple.pm:${PORTSDIR}/security/p5-Authen-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/Authen/Smb.pm:${PORTSDIR}/security/p5-Authen-Smb
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Authen::Simple::SMB.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires at least Perl 5.8 due to dependencies. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-Authen-Simple-SMB/distinfo b/security/p5-Authen-Simple-SMB/distinfo
new file mode 100644
index 000000000000..d8eac0319e12
--- /dev/null
+++ b/security/p5-Authen-Simple-SMB/distinfo
@@ -0,0 +1,3 @@
+MD5 (Authen-Simple-SMB-0.1.tar.gz) = 8b87f7af7426ef1ee3898ca48325842a
+SHA256 (Authen-Simple-SMB-0.1.tar.gz) = e0d5b22223517656eab803f5e3ae25bd114661b1136a7065589d8ccd4bbb1fb2
+SIZE (Authen-Simple-SMB-0.1.tar.gz) = 2624
diff --git a/security/p5-Authen-Simple-SMB/pkg-descr b/security/p5-Authen-Simple-SMB/pkg-descr
new file mode 100644
index 000000000000..ec65eaff3dd6
--- /dev/null
+++ b/security/p5-Authen-Simple-SMB/pkg-descr
@@ -0,0 +1,4 @@
+Authentication via SMB protocol.
+
+WWW: http://search.cpan.org/dist/Authen-Simple-Net-SMB
+Author: Christian Hansen <ch@ngmedia.com>
diff --git a/security/p5-Authen-Simple-SMB/pkg-plist b/security/p5-Authen-Simple-SMB/pkg-plist
new file mode 100644
index 000000000000..8fc98143568b
--- /dev/null
+++ b/security/p5-Authen-Simple-SMB/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Authen/Simple/SMB.pm
+@dirrmtry %%SITE_PERL%%/Authen/Simple
+@dirrmtry %%SITE_PERL%%/Authen