aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-02-13 10:47:14 +0800
committerpgj <pgj@FreeBSD.org>2012-02-13 10:47:14 +0800
commit93d2b82208c51fd710e749ed7e6ebd7b7512f379 (patch)
tree78d63bed12d0d8c59eccaefc9b77b36a6cf0a2c8 /security
parent9511fd1eb0149f0a755e340c5726d06b04b7b59b (diff)
downloadfreebsd-ports-gnome-93d2b82208c51fd710e749ed7e6ebd7b7512f379.tar.gz
freebsd-ports-gnome-93d2b82208c51fd710e749ed7e6ebd7b7512f379.tar.zst
freebsd-ports-gnome-93d2b82208c51fd710e749ed7e6ebd7b7512f379.zip
A collection of crypto hashes, with a practical incremental and one-pass,
pure APIs, with performance close to the fastest implementations available in others languages. The implementations are made in C with a haskell FFI wrapper that hide the C implementation. WWW: http://github.com/vincenthz/hs-cryptohash Obtained from: FreeBSD Haskell
Diffstat (limited to 'security')
-rw-r--r--security/hs-cryptohash/Makefile20
-rw-r--r--security/hs-cryptohash/distinfo2
-rw-r--r--security/hs-cryptohash/pkg-descr8
3 files changed, 30 insertions, 0 deletions
diff --git a/security/hs-cryptohash/Makefile b/security/hs-cryptohash/Makefile
new file mode 100644
index 000000000000..9ac4413d1605
--- /dev/null
+++ b/security/hs-cryptohash/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: hs-cryptohash
+# Date created: November 19, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cryptohash
+PORTVERSION= 0.7.4
+CATEGORIES= security haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A collection of crypto hashes, fast, pure, and practical
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/security/hs-cryptohash/distinfo b/security/hs-cryptohash/distinfo
new file mode 100644
index 000000000000..b9cbead84b42
--- /dev/null
+++ b/security/hs-cryptohash/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/cryptohash-0.7.4.tar.gz) = 4be94351f2960bc3a4c28bd6273a476a8c0896f3918f4c9ead12100c23aff4da
+SIZE (cabal/cryptohash-0.7.4.tar.gz) = 38773
diff --git a/security/hs-cryptohash/pkg-descr b/security/hs-cryptohash/pkg-descr
new file mode 100644
index 000000000000..f60c7732bff3
--- /dev/null
+++ b/security/hs-cryptohash/pkg-descr
@@ -0,0 +1,8 @@
+A collection of crypto hashes, with a practical incremental and one-pass,
+pure APIs, with performance close to the fastest implementations available
+in others languages.
+
+The implementations are made in C with a haskell FFI wrapper that hide the
+C implementation.
+
+WWW: http://github.com/vincenthz/hs-cryptohash