aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-02-02 17:36:08 +0800
committertobik <tobik@FreeBSD.org>2019-02-02 17:36:08 +0800
commit958872aaf928a36b0c1c510ed31080d9983b5ff6 (patch)
treede58b877b813efd9bd5b2c63250591486370dc56 /security
parent4ecd74fea5c61c4d8fdabe5a2fc873c42397672a (diff)
downloadfreebsd-ports-gnome-958872aaf928a36b0c1c510ed31080d9983b5ff6.tar.gz
freebsd-ports-gnome-958872aaf928a36b0c1c510ed31080d9983b5ff6.tar.zst
freebsd-ports-gnome-958872aaf928a36b0c1c510ed31080d9983b5ff6.zip
security/*: Use NO_WRKSUBDIR
Diffstat (limited to 'security')
-rw-r--r--security/fprint_demo/Makefile7
-rw-r--r--security/pscan/Makefile2
-rw-r--r--security/pure-sfv/Makefile3
-rw-r--r--security/pvk/Makefile3
4 files changed, 8 insertions, 7 deletions
diff --git a/security/fprint_demo/Makefile b/security/fprint_demo/Makefile
index 867c2efae0af..596498781072 100644
--- a/security/fprint_demo/Makefile
+++ b/security/fprint_demo/Makefile
@@ -13,15 +13,16 @@ COMMENT= Demo and test application for libfprint
LIB_DEPENDS= libfprint.so:security/libfprint
-GNU_CONFIGURE= yes
USES= autoreconf pkgconfig desktop-file-utils
USE_GNOME= atk glib20 gtk20 pango
INSTALLS_ICONS= yes
-WRKSRC= ${WRKDIR}
+NO_WRKSUBDIR= yes
-CONFIGURE_ENV+= CRYPTO_CFLAGS=-I${OPENSSLINC} \
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CRYPTO_CFLAGS=-I${OPENSSLINC} \
CRYPTO_LIBS=-lcrypto
+
CFLAGS+= -DHAVE_MEMMEM
.include <bsd.port.mk>
diff --git a/security/pscan/Makefile b/security/pscan/Makefile
index 9702e269c172..9684c4b19bc3 100644
--- a/security/pscan/Makefile
+++ b/security/pscan/Makefile
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Security C code scanner for misuse of format strings
ALL_TARGET= #empty
-WRKSRC= ${WRKDIR}
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/pscan bin/find_formats
diff --git a/security/pure-sfv/Makefile b/security/pure-sfv/Makefile
index fb92030c629e..0ee0a53936a6 100644
--- a/security/pure-sfv/Makefile
+++ b/security/pure-sfv/Makefile
@@ -14,8 +14,7 @@ LICENSE= GPLv2
USES= gmake
-WRKSRC= ${WRKDIR}
-
+NO_WRKSUBDIR= yes
PLIST_FILES= bin/pure-sfv
PORTDOCS= ReadMe.txt
diff --git a/security/pvk/Makefile b/security/pvk/Makefile
index 301fe418bca8..d3c89da676fb 100644
--- a/security/pvk/Makefile
+++ b/security/pvk/Makefile
@@ -12,10 +12,11 @@ MAINTAINER= sobomax@FreeBSD.org
COMMENT= Tool to convert a RSA key in PEM format into a PVK file and vice versa
USES= ssl
-WRKSRC= ${WRKDIR}
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
+NO_WRKSUBDIR= yes
+
post-patch:
${REINPLACE_CMD} -e 's|\(-lcrypto\)|$$(LDFLAGS) \1|g' \
${WRKSRC}/Makefile