aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-19 05:53:18 +0800
committererwin <erwin@FreeBSD.org>2005-12-19 05:53:18 +0800
commit9682c7f37f3169480dcc1be73431b55ed31a6d55 (patch)
tree2e31696787f45c618298023686490297ffe581a6 /security
parent6ca3aa6177abe2833e2612ac019e1ff735ed6d20 (diff)
downloadfreebsd-ports-gnome-9682c7f37f3169480dcc1be73431b55ed31a6d55.tar.gz
freebsd-ports-gnome-9682c7f37f3169480dcc1be73431b55ed31a6d55.tar.zst
freebsd-ports-gnome-9682c7f37f3169480dcc1be73431b55ed31a6d55.zip
This code appears to have only cursory resemblance to Bruce Schneier's
blowfish and twofish algorithms in that it too has a table-based decoder. Derivation from FairKeys code by Jon Lech Johanson at nanocrew.net. If you don't know what that is, don't bother looking here further. This is a Pure Perl implementation. I doubt there is any need for xs coding for what would mainly be processing 16 bytes at a time. This code is part of an ongoing effort to clone portions of the Apple iTMS in Perl for portability. See www.hymn-project.org for prior efforts by others. WWW: http://search.cpan.org/dist/Crypt-AppleTwoFish PR: ports/90610 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-AppleTwoFish/Makefile24
-rw-r--r--security/p5-Crypt-AppleTwoFish/distinfo3
-rw-r--r--security/p5-Crypt-AppleTwoFish/pkg-descr10
-rw-r--r--security/p5-Crypt-AppleTwoFish/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 6e61362cf558..f5dd240ca28f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -282,6 +282,7 @@
SUBDIR += p5-Business-PayPal-EWP
SUBDIR += p5-CSP
SUBDIR += p5-Crypt-Anubis
+ SUBDIR += p5-Crypt-AppleTwoFish
SUBDIR += p5-Crypt-Blowfish
SUBDIR += p5-Crypt-Blowfish_PP
SUBDIR += p5-Crypt-CAST5_PP
diff --git a/security/p5-Crypt-AppleTwoFish/Makefile b/security/p5-Crypt-AppleTwoFish/Makefile
new file mode 100644
index 000000000000..26f4f6877abd
--- /dev/null
+++ b/security/p5-Crypt-AppleTwoFish/Makefile
@@ -0,0 +1,24 @@
+# New ports collection Makefile for: p5-Crypt-AppleTwoFish
+# Date created: 18 Dec 2006
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Crypt-AppleTwoFish
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Apple iTMS internal key descrambling algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::AppleTwoFish.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-AppleTwoFish/distinfo b/security/p5-Crypt-AppleTwoFish/distinfo
new file mode 100644
index 000000000000..863d7425f4e2
--- /dev/null
+++ b/security/p5-Crypt-AppleTwoFish/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-AppleTwoFish-0.02.tar.gz) = c71ab8199894f399a8c4ec9d6db3ed50
+SHA256 (Crypt-AppleTwoFish-0.02.tar.gz) = c96def5414c172a3b0da47b7543813cdea088ec5a3e914dae1448fe936db71e0
+SIZE (Crypt-AppleTwoFish-0.02.tar.gz) = 23689
diff --git a/security/p5-Crypt-AppleTwoFish/pkg-descr b/security/p5-Crypt-AppleTwoFish/pkg-descr
new file mode 100644
index 000000000000..6e498d944983
--- /dev/null
+++ b/security/p5-Crypt-AppleTwoFish/pkg-descr
@@ -0,0 +1,10 @@
+This code appears to have only cursory resemblance to Bruce Schneier's
+blowfish and twofish algorithms in that it too has a table-based decoder.
+Derivation from FairKeys code by Jon Lech Johanson at nanocrew.net.
+If you don't know what that is, don't bother looking here further. This is
+a Pure Perl implementation. I doubt there is any need for xs coding for
+what would mainly be processing 16 bytes at a time. This code is part of an
+ongoing effort to clone portions of the Apple iTMS in Perl for portability.
+See www.hymn-project.org for prior efforts by others.
+
+WWW: http://search.cpan.org/dist/Crypt-AppleTwoFish
diff --git a/security/p5-Crypt-AppleTwoFish/pkg-plist b/security/p5-Crypt-AppleTwoFish/pkg-plist
new file mode 100644
index 000000000000..9a1ac9209620
--- /dev/null
+++ b/security/p5-Crypt-AppleTwoFish/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/AppleTwoFish.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/AppleTwoFish/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/AppleTwoFish/
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Crypt 2>/dev/null || true