aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-11-15 07:20:56 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-11-15 07:20:56 +0800
commit9a05bc76d26c737254fd78550b8e9d3b3b9ab457 (patch)
treecc9cdddf80f8f28a3a5f3ed720d224f71b056e26 /security
parent4ad9959ff6fea9905a2d0a6fb2459062de68a5c7 (diff)
downloadfreebsd-ports-gnome-9a05bc76d26c737254fd78550b8e9d3b3b9ab457.tar.gz
freebsd-ports-gnome-9a05bc76d26c737254fd78550b8e9d3b3b9ab457.tar.zst
freebsd-ports-gnome-9a05bc76d26c737254fd78550b8e9d3b3b9ab457.zip
- Update MASTER_SITES and WWW
- Switch to options helpers - Switch to new test framework - Silence patching
Diffstat (limited to 'security')
-rw-r--r--security/libtomcrypt/Makefile49
-rw-r--r--security/libtomcrypt/pkg-descr2
2 files changed, 21 insertions, 30 deletions
diff --git a/security/libtomcrypt/Makefile b/security/libtomcrypt/Makefile
index 2dc3f6521d34..e8059d860e88 100644
--- a/security/libtomcrypt/Makefile
+++ b/security/libtomcrypt/Makefile
@@ -5,7 +5,7 @@ PORTNAME= libtomcrypt
PORTVERSION= 1.17
PORTREVISION= 4
CATEGORIES= security
-MASTER_SITES= http://libtom.org/files/
+MASTER_SITES= http://libtom.net/files/
DISTNAME= crypt-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
@@ -26,49 +26,41 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gmake libtool:build tar:bzip2
OPTIONS_DEFINE= DOCS
-OPTIONS_DEFAULT= LIBTOMMATH
OPTIONS_MULTI= MATH
OPTIONS_MULTI_MATH= LIBTOMMATH TOMSFASTMATH GMP
+OPTIONS_DEFAULT= LIBTOMMATH
+
LIBTOMMATH_DESC= Use LibTomMath
TOMSFASTMATH_DESC= Use TomsFastMath
-.include <bsd.port.options.mk>
+LIBTOMMATH_BUILD_DEPENDS= ${LOCALBASE}/include/tommath.h:${PORTSDIR}/math/libtommath
+LIBTOMMATH_CFLAGS= -DLTM_DESC
+LIBTOMMATH_VARS= EXTRALIBS+=-ltommath
-.if ${PORT_OPTIONS:MLIBTOMMATH}
-BUILD_DEPENDS+= ${LOCALBASE}/include/tommath.h:${PORTSDIR}/math/libtommath
-CFLAGS+= -DLTM_DESC
-EXTRALIBS+= -ltommath
-.endif
+LIBTOMSFASTMATH_BUILD_DEPENDS= ${LOCALBASE}/include/tfm.h:${PORTSDIR}/math/tomsfastmath
+LIBTOMSFASTMATH_CFLAGS= -DTFM_DESC
+LIBTOMSFASTMATH_VARS= EXTRALIBS+=-ltfm
-.if ${PORT_OPTIONS:MTOMSFASTMATH}
-BUILD_DEPENDS+= ${LOCALBASE}/include/tfm.h:${PORTSDIR}/math/tomsfastmath
-CFLAGS+= -DTFM_DESC
-EXTRALIBS+= -ltfm
-.endif
+GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
+GMP_CFLAGS= -DGMP_DESC
+GMP_VARS= EXTRALIBS+=-lgmp
-.if ${PORT_OPTIONS:MGMP}
-LIB_DEPENDS+= libgmp.so:${PORTSDIR}/math/gmp
-CFLAGS+= -DGMP_DESC
-EXTRALIBS+= -lgmp
-.endif
-
-.if ! ${PORT_OPTIONS:MDOCS}
-MAKE_ARGS+= NODOCS=yes
-.endif
+DOCS_MAKE_ARGS_OFF= NODOCS=yes
post-patch:
- ${REINPLACE_CMD} -e 's|gcc|${CC}|' -e 's| make | $$(MAKE) |' \
+ @${REINPLACE_CMD} -e 's|gcc|${CC}|' -e 's| make | $$(MAKE) |' \
-e 's|-g $$(GROUP)||' -e 's|-o $$(USER)||' \
${WRKSRC}/makefile.shared ${WRKSRC}/testprof/makefile.shared
post-install:
- ${MKDIR} ${STAGEDIR}${DOCSDIR}/pdf
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtomcrypt_prof.so.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtomcrypt.so.0
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/pdf
${INSTALL_DATA} ${WRKSRC}/doc/crypt.pdf ${STAGEDIR}${DOCSDIR}/pdf
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtomcrypt_prof.so.0
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libtomcrypt.so.0
-.if defined(MAINTAINER_MODE)
-test: build
+do-test:
@${ECHO_MSG} "Testing with -DUSE_TFM..."
(cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_TFM" EXTRALIBS="-L${PREFIX}/lib -ltfm" ${MAKE_CMD} test && ${WRKSRC}/test)
@@ -85,6 +77,5 @@ test: build
@${ECHO_MSG} "Testing with -DUSE_GMP..."
(cd ${WRKSRC} && CFLAGS="${CFLAGS} -DUSE_GMP" EXTRALIBS="-L${PREFIX}/lib -lgmp" ${MAKE_CMD} test && ${WRKSRC}/test)
-.endif
.include <bsd.port.mk>
diff --git a/security/libtomcrypt/pkg-descr b/security/libtomcrypt/pkg-descr
index 52c0462edb26..8c2842e2fd3f 100644
--- a/security/libtomcrypt/pkg-descr
+++ b/security/libtomcrypt/pkg-descr
@@ -2,4 +2,4 @@ LibTomCrypt is a portable ANSI C cryptographic library that supports symmetric
ciphers, one-way hashes, pseudo-random number generators, public key
cryptography (via RSA,DH or ECC/DH) and a plethora of support routines.
-WWW: http://www.libtomcrypt.com
+WWW: http://libtom.net/