aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
committertijl <tijl@FreeBSD.org>2016-03-20 18:53:08 +0800
commit9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca (patch)
treec30aa05ffe4be67ca3bb38317073b7e6603daa7c /security
parent6af0c041428d493f447a328f9e81efe5b6d72273 (diff)
downloadfreebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.gz
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.tar.zst
freebsd-ports-gnome-9bf09f69cf8a3acf95e51a0a1e8d6eedfd31e3ca.zip
Install net/libnet headers and libraries back in the location where other
ports expect it. The files were put in a different location to avoid a conflict with net/libnet10 but this port has been removed a while ago now. PR: 208122 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'security')
-rw-r--r--security/dsniff/Makefile17
-rw-r--r--security/dsniff/files/patch-Makefile.in48
-rw-r--r--security/dsniff/files/patch-configure.in20
-rw-r--r--security/firewalk/Makefile10
-rw-r--r--security/ipguard/files/patch-Makefile14
-rw-r--r--security/sasp/Makefile10
-rw-r--r--security/sasp/files/patch-Makefile11
-rw-r--r--security/scanlogd/Makefile2
-rw-r--r--security/snort/Makefile21
-rw-r--r--security/suricata/Makefile8
-rw-r--r--security/unicornscan/Makefile4
-rw-r--r--security/unicornscan/files/patch-libs__Makefile8
-rw-r--r--security/unicornscan/files/patch-src-scan_progs-Makefile2
-rw-r--r--security/unicornscan/files/patch-src__Makefile17
-rw-r--r--security/unicornscan/files/patch-src__Makefile.inc14
-rw-r--r--security/yersinia/Makefile7
-rw-r--r--security/yersinia/files/patch-configure76
17 files changed, 45 insertions, 244 deletions
diff --git a/security/dsniff/Makefile b/security/dsniff/Makefile
index 89cd1dbaa3e1..d9cc38ef14b0 100644
--- a/security/dsniff/Makefile
+++ b/security/dsniff/Makefile
@@ -16,6 +16,8 @@ LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-libnet=${LOCALBASE}
+DESTDIRNAME= install_prefix
USES= pkgconfig
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:C/(.*)..$/\1/}
@@ -26,22 +28,7 @@ OPTIONS_SUB= yes
X11_USE= xorg=x11,xmu
X11_CONFIGURE_WITH=x
-LIBNET_VERSION= 11
-LIBNET_CONFIG= ${LOCALBASE}/bin/libnet${LIBNET_VERSION}-config
-LIBNET_INC= "`${LIBNET_CONFIG} --defines` `${LIBNET_CONFIG} --cflags`"
-LIBNET_LIB= "`${LIBNET_CONFIG} --libs`"
-
-pre-configure:
- @${REINPLACE_CMD} -e 's|@NIDSLIB@|& `pkg-config --libs gthread-2.0`|' \
- ${WRKSRC}/Makefile.in
-
post-patch:
- @${REINPLACE_CMD} -Ee \
- 's|libnet-config|${LIBNET_CONFIG:T}|; \
- s|test -f \$${prefix}/include/libnet.h|${TRUE}|; \
- s|(LNETINC=).*|\1${LIBNET_INC}|; \
- s|(LNETLIB=).*|\1${LIBNET_LIB}|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's,csin,_csin,g' \
${WRKSRC}/webmitm.c \
${WRKSRC}/sshmitm.c
diff --git a/security/dsniff/files/patch-Makefile.in b/security/dsniff/files/patch-Makefile.in
index 303642658c02..54598da91d19 100644
--- a/security/dsniff/files/patch-Makefile.in
+++ b/security/dsniff/files/patch-Makefile.in
@@ -1,23 +1,15 @@
---- ./Makefile.in.orig 2001-03-15 09:34:42.000000000 +0100
-+++ ./Makefile.in 2014-07-22 13:21:21.000000000 +0200
-@@ -8,7 +8,6 @@
- srcdir = @srcdir@
- VPATH = @srcdir@
-
--install_prefix =
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- libdir = @libdir@
-@@ -26,7 +25,7 @@
+--- Makefile.in.orig 2001-03-15 08:34:42 UTC
++++ Makefile.in
+@@ -26,7 +26,7 @@ LNETINC = @LNETINC@
LNETLIB = @LNETLIB@
NIDSINC = @NIDSINC@
-NIDSLIB = @NIDSLIB@
-+NIDSLIB = @NIDSLIB@ `pkg-config --libs gthread-2.0` `pkg-config --libs gthread-2.0` `pkg-config --libs gthread-2.0` `pkg-config --libs gthread-2.0`
++NIDSLIB = @NIDSLIB@ `pkg-config --libs gthread-2.0`
DBINC = @DBINC@
DBLIB = @DBLIB@
-@@ -37,9 +36,8 @@
+@@ -37,9 +37,8 @@ SSLLIB = @SSLLIB@
X11INC = @X_CFLAGS@
X11LIB = @X_LIBS@ @X_PRE_LIBS@ -lXmu -lX11 @X_EXTRA_LIBS@
@@ -29,7 +21,7 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -76,22 +74,23 @@
+@@ -76,22 +75,23 @@ CONFIGS = dsniff.magic dsniff.services d
.c.o:
$(CC) $(CFLAGS) $(INCS) -c $(srcdir)/$*.c
@@ -64,33 +56,7 @@
dsniff: $(HDRS) $(SRCS) $(OBJS)
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(DBLIB) $(SSLLIB)
-@@ -139,24 +138,24 @@
- $(CC) $(LDFLAGS) -o $@ webspy.o base64.o buf.o remote.o $(LIBS) $(NIDSLIB) $(PCAPLIB) $(LNETLIB) $(X11LIB)
-
- install:
-- test -d $(install_prefix)$(sbindir) || \
-- $(INSTALL) -d $(install_prefix)$(sbindir)
-+ test -d $(DESTDIR)$(sbindir) || \
-+ $(INSTALL) -d $(DESTDIR)$(sbindir)
- for file in $(PROGS); do \
-- $(INSTALL_PROGRAM) -m 755 $$file $(install_prefix)$(sbindir); \
-+ $(INSTALL_PROGRAM) -m 755 $$file $(DESTDIR)$(sbindir); \
- done
-- test -d $(install_prefix)$(libdir) || \
-- $(INSTALL) -d $(install_prefix)$(libdir)
-+ test -d $(DESTDIR)$(libdir) || \
-+ $(INSTALL) -d $(DESTDIR)$(libdir)
- for file in $(CONFIGS); do \
-- $(INSTALL_DATA) $$file $(install_prefix)$(libdir); \
-+ $(INSTALL_DATA) $$file $(DESTDIR)$(libdir); \
- done
-- test -d $(install_prefix)$(mandir)/man8 || \
-- $(INSTALL) -d $(install_prefix)$(mandir)/man8
-+ test -d $(DESTDIR)$(mandir)/man8 || \
-+ $(INSTALL) -d $(DESTDIR)$(mandir)/man8
- for file in *.8; do \
-- $(INSTALL_DATA) $$file $(install_prefix)$(mandir)/man8; \
-+ $(INSTALL_DATA) $$file $(DESTDIR)$(mandir)/man8; \
+@@ -156,7 +156,7 @@ install:
done
clean:
diff --git a/security/dsniff/files/patch-configure.in b/security/dsniff/files/patch-configure.in
deleted file mode 100644
index daa4ea073861..000000000000
--- a/security/dsniff/files/patch-configure.in
+++ /dev/null
@@ -1,20 +0,0 @@
---- ./configure.in.orig 2000-12-20 17:31:21.000000000 +0100
-+++ ./configure.in 2014-07-22 13:20:14.000000000 +0200
-@@ -21,7 +21,7 @@
- dnl Checks for header files.
- AC_PATH_XTRA
- AC_HEADER_STDC
--AC_CHECK_HEADERS(err.h fcntl.h sys/ioctl.h sys/queue.h unistd.h libgen.h net/if_tun.h)
-+AC_CHECK_HEADERS(err.h fcntl.h sys/ioctl.h sys/queue.h unistd.h libgen.h net/if_tun.h net/ethernet.h)
- dnl XXX - Solaris sux.
- AC_MSG_CHECKING(for MIN and MAX in sys/param.h)
- AC_EGREP_CPP(yes, [
-@@ -43,7 +43,7 @@
- AC_CHECK_TYPE(u_int64_t, uint64_t)
- dnl XXX - Linux sux.
- AC_CHECK_TYPE(in_addr_t, u_int32_t)
--CFLAGS="$CFLAGS -D_BSD_SOURCE"
-+CFLAGS="$CFLAGS -D_BSD_SOURCE -DBIND_8_COMPAT"
-
- dnl Checks for library functions.
- AC_PROG_GCC_TRADITIONAL
diff --git a/security/firewalk/Makefile b/security/firewalk/Makefile
index e8192b632827..5b40ead73365 100644
--- a/security/firewalk/Makefile
+++ b/security/firewalk/Makefile
@@ -16,10 +16,8 @@ LIB_DEPENDS= libdnet.so:${PORTSDIR}/net/libdnet \
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include `${LIBNET_CONFIG} --cflags`
-LDFLAGS+= -L${LOCALBASE}/lib
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
PLIST_FILES= bin/firewalk man/man8/firewalk.8.gz
PORTDOCS= BUGS README TODO
@@ -28,10 +26,6 @@ WRKSRC= ${WRKDIR}/Firewalk
OPTIONS_DEFINE= DOCS
-post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/firewalk ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/firewalk.8 ${STAGEDIR}${MANPREFIX}/man/man8
diff --git a/security/ipguard/files/patch-Makefile b/security/ipguard/files/patch-Makefile
index 0a52b5a5f430..5d7e75a6aa77 100644
--- a/security/ipguard/files/patch-Makefile
+++ b/security/ipguard/files/patch-Makefile
@@ -1,15 +1,17 @@
---- Makefile.orig 2014-02-11 16:45:41.000000000 -0200
-+++ Makefile 2014-02-11 16:46:25.000000000 -0200
-@@ -10,7 +10,7 @@
+--- Makefile.orig 2010-07-12 03:46:36 UTC
++++ Makefile
+@@ -10,8 +10,8 @@ PREFIX?=/usr/local
ETHERS?=/etc/ethers
## FreeBSD
-LOCALBASE=/usr/local
+-LIBNET_CONFIG=libnet11-config
+LOCALBASE?=/usr/local
- LIBNET_CONFIG=libnet11-config
++LIBNET_CONFIG=libnet-config
## OpenBSD (tested by irix)
-@@ -26,7 +26,7 @@
+ # LOCALBASE=/usr/local
+@@ -26,7 +26,7 @@ LIBS=`${LIBNET_CONFIG} --libs` -lpcap -L
DEFINES=`${LIBNET_CONFIG} --defines`
STATIC=
@@ -18,7 +20,7 @@
CFLAGS+=-g -Wall -DETHERS='"$(ETHERS)"'
-@@ -58,10 +58,10 @@
+@@ -58,10 +58,10 @@ cleanall: clean
@rm -f $(NAME)
install: all
diff --git a/security/sasp/Makefile b/security/sasp/Makefile
index 08a366cbe4d5..b71afc7d656c 100644
--- a/security/sasp/Makefile
+++ b/security/sasp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sasp
PORTVERSION= 0.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security
MASTER_SITES= LOCAL/ahze \
http://people.freebsd.org/~ahze/distfiles/
@@ -14,9 +14,13 @@ COMMENT= Tool that permits to use a gateway whatever IP we have
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
NO_WRKSUBDIR= yes
-MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
PLIST_FILES= sbin/sasp
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
+do-build:
+ (cd ${WRKSRC} && ${CC} ${CFLAGS} -I${LOCALBASE}/include -o sasp sasp.c \
+ ${LDFLAGS} -L${LOCALBASE}/lib -lpcap -lnet)
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/sasp ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.mk>
diff --git a/security/sasp/files/patch-Makefile b/security/sasp/files/patch-Makefile
deleted file mode 100644
index a15e41f4fe7e..000000000000
--- a/security/sasp/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig Thu Apr 7 06:33:45 2005
-+++ ./Makefile Wed Sep 27 22:46:49 2006
-@@ -1,6 +1,6 @@
- all:
-- cc -o sasp sasp.c -L/usr/local/lib -I/usr/local/include -lpcap -lnet
-+ ${CC} `${LIBNET_CONFIG} --cflags` -o sasp sasp.c -lpcap `${LIBNET_CONFIG} --libs`
- install:
-- install -o root -m 555 sasp /usr/local/sbin
-+ ${BSD_INSTALL_PROGRAM} sasp ${DESTDIR}${PREFIX}/sbin
- clean:
- rm -rf *.o
diff --git a/security/scanlogd/Makefile b/security/scanlogd/Makefile
index 4053a12b2c85..b31591170a65 100644
--- a/security/scanlogd/Makefile
+++ b/security/scanlogd/Makefile
@@ -34,8 +34,6 @@ PCAP_BASE_ALL_TARGET= libpcap
NIDS_ALL_TARGET= libnids
NIDS_BUILD_DEPENDS= ${LOCALBASE}/lib/libnids.a:${PORTSDIR}/net/libnids
NIDS_LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
-NIDS_CFLAGS= -I${LOCALBASE}/include/libnet11
-NIDS_LDFLAGS= -L${LOCALBASE}/lib/libnet11
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/scanlogd ${STAGEDIR}${PREFIX}/bin
diff --git a/security/snort/Makefile b/security/snort/Makefile
index 7e64b373e6b7..1708ba48aae1 100644
--- a/security/snort/Makefile
+++ b/security/snort/Makefile
@@ -3,6 +3,7 @@
PORTNAME= snort
PORTVERSION= 2.9.8.0
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://snort.org/downloads/snort/ \
http://www.talosintel.com/downloads/ \
@@ -17,7 +18,7 @@ LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre \
- libnet.so:${PORTSDIR}/net/libnet
+ libdnet.so:${PORTSDIR}/net/libdnet
BUILD_DEPENDS= daq>=2.0.0:${PORTSDIR}/net/daq
RUN_DEPENDS= daq>=2.0.0:${PORTSDIR}/net/daq
@@ -88,24 +89,10 @@ DOCS= RELEASE.NOTES doc/AUTHORS doc/BUGS doc/CREDITS \
doc/README* doc/USAGE doc/*.pdf
PREPROC_RULES= decoder.rules preprocessor.rules sensitive-data.rules
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
-.if exists(${LIBNET_CONFIG})
-LIBNET_CFLAGS!= ${LIBNET_CONFIG} --cflags
-LIBNET_LIBS!= ${LIBNET_CONFIG} --libs
-.else
-LIBNET_CFLAGS= -I${LOCALBASE}/include/libnet11
-LIBNET_LIBS= -L${LOCALBASE}/lib/libnet11 -lnet
-.endif
-
-LIBNET_INCDIR= ${LIBNET_CFLAGS:M-I*:S/-I//}
-LIBNET_LIBDIR= ${LIBNET_LIBS:M-L*:S/-L//}
-
CFLAGS+= -fstack-protector
CONFIGURE_ARGS+=--enable-reload \
--enable-mpls --enable-targetbased \
- --enable-reload-error-restart \
- --with-dnet-includes=${LIBNET_INCDIR} \
- --with-dnet-libraries=${LIBNET_LIBDIR}
+ --enable-reload-error-restart
post-patch:
@${REINPLACE_CMD} "s,/etc/snort.conf,${ETCDIR}/snort.conf," \
@@ -116,8 +103,6 @@ post-patch:
-e '/^# include .PREPROC_RULE/s/# include/include/' \
${WRKSRC}/etc/snort.conf
- @${REINPLACE_CMD} -e 's|libnet-config|${LIBNET_CONFIG}|g' ${WRKSRC}/configure
-
# IPv6 is no longer a ./configure option!
.if ! ${PORT_OPTIONS:MIPV6}
@${REINPLACE_CMD} -e '/normalize_ip6/s/^preprocessor/#preprocessor/' \
diff --git a/security/suricata/Makefile b/security/suricata/Makefile
index 4e151570794e..a00e8ea158e7 100644
--- a/security/suricata/Makefile
+++ b/security/suricata/Makefile
@@ -106,14 +106,12 @@ CONFIGURE_ARGS+=--enable-gccprotect \
--with-libpcre-libraries=${LOCALBASE}/lib \
--with-libyaml-includes=${LOCALBASE}/include \
--with-libyaml-libraries=${LOCALBASE}/lib \
- --with-libnet-includes=${LOCALBASE}/include/libnet11 \
- --with-libnet-libraries=${LOCALBASE}/lib/libnet11 \
+ --with-libnet-includes=${LOCALBASE}/include \
+ --with-libnet-libraries=${LOCALBASE}/lib \
--with-libhtp-includes=${LOCALBASE}/include/ \
--with-libhtp-libraries=${LOCALBASE}/lib \
- --disable-gccmarch-native \
- --localstatedir=/var/
+ --disable-gccmarch-native
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
CONFIG_DIR?= ${ETCDIR}
CONFIG_FILES= suricata.yaml classification.config reference.config threshold.config
RULES_DIR= ${CONFIG_DIR}/rules
diff --git a/security/unicornscan/Makefile b/security/unicornscan/Makefile
index d9b6f76f448a..aafdf96ece3f 100644
--- a/security/unicornscan/Makefile
+++ b/security/unicornscan/Makefile
@@ -15,15 +15,11 @@ LICENSE= GPLv2
LIB_DEPENDS= libnet.so:${PORTSDIR}/net/libnet
USES= gmake
-MAKE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
CFLAGS+= -DWITH_LONGOPTS
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
SUB_FILES= pkg-message
post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${WRKSRC}/src/scan_progs/Makefile ${WRKSRC}/src/tools/Makefile
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/etc|' \
${WRKSRC}/fconf/unicorn.conf
# Unbreak the build against Clang (it does not like one function being inline)
diff --git a/security/unicornscan/files/patch-libs__Makefile b/security/unicornscan/files/patch-libs__Makefile
index ee72e98bea78..e3df8c0a7b3c 100644
--- a/security/unicornscan/files/patch-libs__Makefile
+++ b/security/unicornscan/files/patch-libs__Makefile
@@ -1,6 +1,6 @@
---- libs/Makefile.orig Thu Sep 30 07:29:05 2004
-+++ libs/Makefile Fri Sep 29 14:32:37 2006
-@@ -6,30 +6,10 @@
+--- libs/Makefile.orig 2004-09-30 10:29:05 UTC
++++ libs/Makefile
+@@ -6,30 +6,10 @@ CFLAGS=$(MYCFLAGS)
default: pcap_test libnet_test
pcap_test: pcap_test.c
@@ -29,7 +29,7 @@
-
-libpcap-$(PCAPVER).tar.gz:
- wget http://tcpdump.org/release/libpcap-$(PCAPVER).tar.gz
-+ $(CC) $(CFLAGS) -o libnet_test libnet_test.c -lpcap `$(LIBNET_CONFIG) --libs` $(LDADD)
++ $(CC) $(CFLAGS) -o libnet_test libnet_test.c -lpcap -lnet $(LDADD)
clean:
- rm -rf fake libnet libpcap-$(PCAPVER) pcap_test libnet_test
diff --git a/security/unicornscan/files/patch-src-scan_progs-Makefile b/security/unicornscan/files/patch-src-scan_progs-Makefile
index 1142697748e3..b82ebdb45ece 100644
--- a/security/unicornscan/files/patch-src-scan_progs-Makefile
+++ b/security/unicornscan/files/patch-src-scan_progs-Makefile
@@ -18,7 +18,7 @@
+ $(CC) -c $(ENTRY) $(CFLAGS) -DBUILD_IDENT_RECV=1 -o $@
+
+$(SENDERNAME): $(S_OBJS) $(G_HDRS) $(S_HDRS) $(C_OBJS) entry_send.o
-+ $(CC) $(CFLAGS) -o $(SENDERNAME) $(S_OBJS) $(C_OBJS) entry_send.o $(G_LDADD) -lpcap `/usr/local/bin/libnet11-config --libs` $(LDADD)
++ $(CC) $(CFLAGS) -o $(SENDERNAME) $(S_OBJS) $(C_OBJS) entry_send.o $(G_LDADD) -lpcap -lnet $(LDADD)
+
+$(LISTENERNAME): $(L_OBJS) $(G_HDRS) $(L_HDRS) $(C_OBJS) entry_recv.o
+ $(CC) $(CFLAGS) -o $(LISTENERNAME) $(L_OBJS) $(C_OBJS) entry_recv.o $(G_LDADD) -lpcap $(LDADD)
diff --git a/security/unicornscan/files/patch-src__Makefile b/security/unicornscan/files/patch-src__Makefile
index 4657bc84d3dc..21eb9916cb34 100644
--- a/security/unicornscan/files/patch-src__Makefile
+++ b/security/unicornscan/files/patch-src__Makefile
@@ -1,17 +1,6 @@
---- src/Makefile.orig Thu Sep 30 07:29:05 2004
-+++ src/Makefile Fri Sep 29 14:32:21 2006
-@@ -4,8 +4,8 @@
- HDRS=$(SRCS:.c=.h) config.h settings.h
- OBJS=$(SRCS:.c=.o)
-
--CFLAGS=$(MYCFLAGS)
--LIBS=-lscan -luni -lparse -lpcap -lnet $(LDADD)
-+CFLAGS+=$(MYCFLAGS)
-+LIBS=-lscan -luni -lparse -lpcap `$(LIBNET_CONFIG) --libs` $(LDADD)
- LIBDIRS=-L./unilib -L./scan_progs -L./parse -L../libs/fake/lib
- TARGETNAME=unicornscan
-
-@@ -19,42 +19,42 @@
+--- src/Makefile.orig 2004-09-30 10:29:05 UTC
++++ src/Makefile
+@@ -19,42 +19,42 @@ compile.h:
./compiledby.sh > compile.h
unilib_d:
diff --git a/security/unicornscan/files/patch-src__Makefile.inc b/security/unicornscan/files/patch-src__Makefile.inc
index f075f850d900..bbd19260fef1 100644
--- a/security/unicornscan/files/patch-src__Makefile.inc
+++ b/security/unicornscan/files/patch-src__Makefile.inc
@@ -1,5 +1,5 @@
---- src/Makefile.inc.orig Thu Sep 30 07:29:05 2004
-+++ src/Makefile.inc Thu Sep 28 14:08:32 2006
+--- src/Makefile.inc.orig 2004-09-30 10:29:05 UTC
++++ src/Makefile.inc
@@ -1,14 +1,13 @@
# gcc only
-CC=gcc
@@ -14,16 +14,12 @@
# its fine to do almost anything here, just dont remove the includes
-MYCFLAGS=-O1 -ggdb -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include -I/usr/local/include -L/usr/local/lib -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
-+MYCFLAGS:=$(CFLAGS) -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include `$(LIBNET_CONFIG) --defines` `$(LIBNET_CONFIG) --cflags` -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
++MYCFLAGS:=$(CFLAGS) -Wall -Wshadow -Wcast-align -Wcast-qual -Wchar-subscripts -Wno-deprecated-declarations -Wformat-security -Wimplicit -Wsign-compare -Wuninitialized -Wunused -Wwrite-strings -I. -rdynamic -I../libs/fake/include -I/usr/local/include -L/usr/local/lib -DPREFIX=\"$(PREFIX)\" -DLOCALSTATEDIR=\"$(LOCALSTATEDIR)\" -DTARGETNAME=\"$(TARGETNAME)\" -DSENDERNAME=\"$(SENDERNAME)\" -DLISTENERNAME=\"$(LISTENERNAME)\"
# sometimes you dont have a link to gmake, if your make _is_ gmake, you can use make then, but we need GNU make (for now)
MAKE=gmake
-@@ -23,10 +22,10 @@
- #LDADD=-lsocket -lnsl -ldl -lposix4 -lresolv
-
- # freebsd, netbsd example
--#LDADD=
-+LDADD=
+@@ -26,7 +25,7 @@ MAKE=gmake
+ #LDADD=
# linux example
-LDADD=-ldl
diff --git a/security/yersinia/Makefile b/security/yersinia/Makefile
index 961122e44107..238679045d84 100644
--- a/security/yersinia/Makefile
+++ b/security/yersinia/Makefile
@@ -27,18 +27,11 @@ CONFIGURE_ARGS+= --disable-gtk
CONFLICTS= yersinia-gtk-[0-9]*
.endif
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBNET_CONFIG="${LIBNET_CONFIG}"
-
-LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
#NOT_FOR_ARCHS= ia64 sparc64
PLIST_FILES= sbin/yersinia \
man/man8/yersinia.8.gz
-post-patch:
- @${REINPLACE_CMD} -e 's|-lnet|`${LIBNET_CONFIG} --libs`|' \
- ${WRKSRC}/src/Makefile.in
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/yersinia ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_MAN} ${WRKSRC}/yersinia.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
diff --git a/security/yersinia/files/patch-configure b/security/yersinia/files/patch-configure
index f4e1547b61f2..0dd24cb602e7 100644
--- a/security/yersinia/files/patch-configure
+++ b/security/yersinia/files/patch-configure
@@ -19,79 +19,3 @@
else
pcap_dir="$dir"
fi
-@@ -4636,64 +4637,8 @@
-
- fi
-
--
--
--{ echo "$as_me:$LINENO: checking for a complete set of libnet headers" >&5
--echo $ECHO_N "checking for a complete set of libnet headers... $ECHO_C" >&6; }
--
--possible_dirs="`eval echo -n ${includedir}` \
-- /usr/include /usr/include/libnet \
-- /usr/local/include /usr/local/include/libnet \
-- /usr/share/include /usr/share/include/libnet"
--
--possible_libnet_config_dirs="/usr /usr/local /opt"
--
--
--# Check whether --with-libnet-includes was given.
--if test "${with_libnet_includes+set}" = set; then
-- withval=$with_libnet_includes; LIBNET_DIR=$withval LIBNET_CONFIG_DIR=$withval
--else
-- LIBNET_DIR=$possible_dirs LIBNET_CONFIG_DIR=$possible_libnet_config_dirs
--fi
--
--
--libnet_dir=""
--for dir in $LIBNET_DIR ; do
-- if test -d $dir -a -r "$dir/libnet.h" ; then
-- if test -n "$libnet_dir" -a "$libnet_dir" != "$dir"; then
-- echo
-- echo; echo more than one set found in:
-- echo $libnet_dir
-- echo $dir
-- echo; echo please wipe out all unused libnet installations
-- exit
-- else
-- libnet_dir="$dir"
-- fi
-- fi
--done
--
--for dir in $LIBNET_CONFIG_DIR ; do
-- if test -d $dir -a -r "$dir/bin/libnet-config" ; then
-- libnet_config_dir="$dir/bin"
-- fi
--done
--
--if test -z "$libnet_dir" ; then
-- echo no; echo !!! couldn\'t find a complete set of libnet headers
-- exit
--else
-- echo found $libnet_dir
--
-- LIBNET_INCLUDE="-I$libnet_dir"
-- LIBNET_LINK="-L`dirname $libnet_dir`/lib"
-- LIBNET_CONFIG="$libnet_config_dir/libnet-config"
--
--
--
--
--
--fi
-+LIBNET_INCLUDE="`$LIBNET_CONFIG --cflags`"
-+LIBNET_LINK=""
-
- if test "$LIBNET_LINK" != "-L/usr/lib" ; then
- LIBS="$LIBS $LIBNET_LINK"
-@@ -4708,7 +4653,7 @@
- echo $ECHO_N "(cached) $ECHO_C" >&6
- else
- ac_check_lib_save_LIBS=$LIBS
--LIBS="-lnet $LIBS"
-+LIBS="`$LIBNET_CONFIG --libs` $LIBS"
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF