aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-03-18 22:07:03 +0800
committerarved <arved@FreeBSD.org>2004-03-18 22:07:03 +0800
commit9ccd6ca5327b94e7aeb81857b0d15096298d8262 (patch)
tree23dd8e3e29c9de84c037207d23d8e868759e9864 /security
parentf7c0e7d644274967146f4af4a1b8d7f988149467 (diff)
downloadfreebsd-ports-gnome-9ccd6ca5327b94e7aeb81857b0d15096298d8262.tar.gz
freebsd-ports-gnome-9ccd6ca5327b94e7aeb81857b0d15096298d8262.tar.zst
freebsd-ports-gnome-9ccd6ca5327b94e7aeb81857b0d15096298d8262.zip
Don't depend on devel/pth
Submitted by: marcus
Diffstat (limited to 'security')
-rw-r--r--security/libgcrypt-devel/Makefile18
-rw-r--r--security/libgcrypt-devel/files/patch-ltmain.sh29
2 files changed, 28 insertions, 19 deletions
diff --git a/security/libgcrypt-devel/Makefile b/security/libgcrypt-devel/Makefile
index b021d44f903b..2cd35ab7d447 100644
--- a/security/libgcrypt-devel/Makefile
+++ b/security/libgcrypt-devel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= libgcrypt
PORTVERSION= 1.1.91
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= alpha/libgcrypt
@@ -15,18 +16,15 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
MAINTAINER= arved@FreeBSD.org
COMMENT= "General purpose crypto library based on code used in GnuPG"
-LIB_DEPENDS= gpg-error.1:${PORTSDIR}/security/libgpg-error \
- pth.20:${PORTSDIR}/devel/pth
+LIB_DEPENDS= gpg-error.1:${PORTSDIR}/security/libgpg-error
CONFLICTS= libgcrypt-1.1*
USE_REINPLACE= yes
USE_PERL5= yes
-USE_GNOME= lthack
-USE_LIBTOOL_VER=13
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split" \
- CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include/pth" \
- LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib/pth"
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --with-pth=no
INSTALLS_SHLIB= yes
INFO= gcrypt
@@ -47,8 +45,10 @@ pre-extract:
.endif
post-patch:
- @${REINPLACE_CMD} -e "s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|" \
- ${WRKSRC}/ltmain.sh
+ @${FIND} ${WRKSRC} -name "configure" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|-lpthread|${PTHREAD_LIBS}|g'
+ @${REINPLACE_CMD} -e s'|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/src/Makefile.in
pre-configure:
@${RM} -f ${WRKSRC}/doc/gcrypt.info*
diff --git a/security/libgcrypt-devel/files/patch-ltmain.sh b/security/libgcrypt-devel/files/patch-ltmain.sh
index 250b983f2f3a..642e3d0bdb06 100644
--- a/security/libgcrypt-devel/files/patch-ltmain.sh
+++ b/security/libgcrypt-devel/files/patch-ltmain.sh
@@ -1,23 +1,32 @@
---- scripts/ltmain.sh.orig Wed Jul 17 15:42:41 2002
-+++ ltmain.sh Wed Jul 17 15:47:36 2002
-@@ -1062,8 +1062,16 @@
+--- ltmain.sh.orig Thu May 22 16:42:22 2003
++++ ltmain.sh Tue May 27 12:12:52 2003
+@@ -1072,7 +1072,7 @@
+ esac
+ elif test "X$arg" = "X-lc_r"; then
+ case $host in
+- *-*-openbsd* | *-*-freebsd*)
++ *-*-openbsd* | *-*-freebsd4*)
+ # Do not include libc_r directly, use -pthread flag.
+ continue
+ ;;
+@@ -1082,8 +1082,16 @@
continue
;;
+ -pthread)
-+ compile_command="$compile_command %%PTHREAD_LIBS%%"
-+ finalize_command="$finalize_command %%PTHREAD_LIBS%%"
-+ compiler_flags="$compiler_flags %%PTHREAD_LIBS%%"
-+ continue;
-+ ;;
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
+
-module)
module=yes
-+ build_old_libs=yes
++ build_old_libs=no
continue
;;
-@@ -4247,10 +4255,12 @@
+@@ -4325,10 +4336,12 @@
fi
# Install the pseudo-library for information purposes.