aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-07-16 11:18:26 +0800
committeradamw <adamw@FreeBSD.org>2014-07-16 11:18:26 +0800
commit9cd1db4fef933674a3b75d6ca4262e0ffe647637 (patch)
tree6cba635ca6a0900686686afe6df65efafe2cb104 /security
parent037277c495c4a69f56029e71eecf6838910561c8 (diff)
downloadfreebsd-ports-gnome-9cd1db4fef933674a3b75d6ca4262e0ffe647637.tar.gz
freebsd-ports-gnome-9cd1db4fef933674a3b75d6ca4262e0ffe647637.tar.zst
freebsd-ports-gnome-9cd1db4fef933674a3b75d6ca4262e0ffe647637.zip
Add DOCS option where PORTDOCS is in plist.
Diffstat (limited to 'security')
-rw-r--r--security/barnyard2/Makefile2
-rw-r--r--security/bdc/Makefile2
-rw-r--r--security/broccoli/Makefile2
-rw-r--r--security/fcheck/Makefile2
-rw-r--r--security/linux-f10-libgpg-error/Makefile2
-rw-r--r--security/monkeysphere/Makefile2
-rw-r--r--security/py-twofish/Makefile2
-rw-r--r--security/ruby-camellia/Makefile2
-rw-r--r--security/sguil-client/Makefile2
-rw-r--r--security/sguil-sensor/Makefile2
-rw-r--r--security/sks/Makefile2
-rw-r--r--security/slush/Makefile2
-rw-r--r--security/sssd/Makefile2
-rw-r--r--security/steghide/Makefile2
-rw-r--r--security/tinyca/Makefile2
-rw-r--r--security/tlswrap/Makefile2
-rw-r--r--security/webfwlog/Makefile2
17 files changed, 29 insertions, 5 deletions
diff --git a/security/barnyard2/Makefile b/security/barnyard2/Makefile
index 2003557879f7..893111737726 100644
--- a/security/barnyard2/Makefile
+++ b/security/barnyard2/Makefile
@@ -14,7 +14,7 @@ GH_ACCOUNT= firnsy
GH_TAGNAME= v2-${PORTVERSION}
GH_COMMIT= 272eaf7
-OPTIONS_DEFINE= 64BIT ARUBA BRO GRE IPV6 MPLS MYSQL MYSQL_SSL ODBC PRELUDE PGSQL PORT_PCAP
+OPTIONS_DEFINE= 64BIT ARUBA BRO GRE IPV6 MPLS MYSQL MYSQL_SSL ODBC PRELUDE PGSQL PORT_PCAP DOCS
NO_OPTIONS_SORT=yes
64BIT_DESC= Enable 64bit compilation (experimental)
diff --git a/security/bdc/Makefile b/security/bdc/Makefile
index 4f270664793e..64b3825ef9ff 100644
--- a/security/bdc/Makefile
+++ b/security/bdc/Makefile
@@ -25,6 +25,8 @@ BDREL= 5
SUB_LIST= bdc pkg-message
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
diff --git a/security/broccoli/Makefile b/security/broccoli/Makefile
index b7be19ce3a4a..35f10f29643b 100644
--- a/security/broccoli/Makefile
+++ b/security/broccoli/Makefile
@@ -36,7 +36,7 @@ PLIST_SUB+= CLEANUP_PREFIX="@comment "
CMAKE_ARGS+= -D CMAKE_INSTALL_PREFIX:PATH=${PREFIX} \
-D BRO_ETC_INSTALL_DIR:PATH=${PREFIX}/etc
-OPTIONS_DEFINE= DEBUG PYTHON RUBY
+OPTIONS_DEFINE= DEBUG PYTHON RUBY DOCS
OPTIONS_SUB=
DEBUG_DESC= Compile in debugging mode
diff --git a/security/fcheck/Makefile b/security/fcheck/Makefile
index fbf43f961751..ec78d3198f0f 100644
--- a/security/fcheck/Makefile
+++ b/security/fcheck/Makefile
@@ -23,6 +23,8 @@ USES= perl5 shebangfix dos2unix
SHEBANG_FILES= ${WRKSRC}/${PORTNAME}
DOS2UNIX_FILES= ${WRKSRC}/${PORTNAME}.cfg
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.pre.mk>
post-patch:
diff --git a/security/linux-f10-libgpg-error/Makefile b/security/linux-f10-libgpg-error/Makefile
index edc20d9da677..fa91b3a1959e 100644
--- a/security/linux-f10-libgpg-error/Makefile
+++ b/security/linux-f10-libgpg-error/Makefile
@@ -19,4 +19,6 @@ BRANDELF_FILES= usr/bin/gpg-error
PLIST_SUB= PORTVERSION="${PORTVERSION}"
DESCR= ${.CURDIR}/../libgpg-error/pkg-descr
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/security/monkeysphere/Makefile b/security/monkeysphere/Makefile
index f7437fc98a79..aceeb71c041e 100644
--- a/security/monkeysphere/Makefile
+++ b/security/monkeysphere/Makefile
@@ -25,6 +25,8 @@ GROUPS= monkeysphere
MAKE_ARGS+= ETCPREFIX=${PREFIX} MANPREFIX=${PREFIX}/man ETCSUFFIX=.sample
+OPTIONS_DEFINE= DOCS
+
# use proper system paths for FreeBSD instead of debian's:
post-patch:
@${REINPLACE_CMD} -e 's|/etc/monkeysphere|${LOCALBASE}/etc/monkeysphere|g' \
diff --git a/security/py-twofish/Makefile b/security/py-twofish/Makefile
index c937af3cf983..934576c05274 100644
--- a/security/py-twofish/Makefile
+++ b/security/py-twofish/Makefile
@@ -16,6 +16,8 @@ USE_PYTHON= 2
GNU_CONFIGURE= yes
CFLAGS+= -fPIC
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/_twofish.so ${STAGEDIR}${PYTHON_SITELIBDIR}
diff --git a/security/ruby-camellia/Makefile b/security/ruby-camellia/Makefile
index e7f5cf99a682..dd54dbefc204 100644
--- a/security/ruby-camellia/Makefile
+++ b/security/ruby-camellia/Makefile
@@ -20,6 +20,8 @@ INSTALL_TARGET= site-install
DOCS= README.txt History.txt License.txt
EXAMPLES= ext/camellia-example.rb
+OPTIONS_DEFINE= DOCS
+
post-install:
${MKDIR} ${STAGEDIR}${RUBY_MODEXAMPLESDIR}
.for f in ${EXAMPLES}
diff --git a/security/sguil-client/Makefile b/security/sguil-client/Makefile
index 83245c7cca96..8a81db99fce6 100644
--- a/security/sguil-client/Makefile
+++ b/security/sguil-client/Makefile
@@ -23,7 +23,7 @@ LICENSE_PERMS= auto-accept
LICENSE_FILE= ${WRKSRC}/client/lib/tablelist4.1/COPYRIGHT.txt
LICENSE_PERMS= auto-accept
-OPTIONS_DEFINE= AUDIO SANCP WIRESHARK
+OPTIONS_DEFINE= AUDIO SANCP WIRESHARK DOCS
AUDIO_DESC= Install Festival Speech Synthesis
SANCP_DESC= Use sancp
WIRESHARK_DESC= Install wireshark
diff --git a/security/sguil-sensor/Makefile b/security/sguil-sensor/Makefile
index 7bebc3d97b96..2e32965fb43f 100644
--- a/security/sguil-sensor/Makefile
+++ b/security/sguil-sensor/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= tcltls>=0:${PORTSDIR}/devel/tcltls \
barnyard2:${PORTSDIR}/security/barnyard2-sguil \
${LOCALBASE}/lib/tclx8.4/tclx.tcl:${PORTSDIR}/lang/tclX
-OPTIONS_DEFINE= PADS SANCP
+OPTIONS_DEFINE= PADS SANCP DOCS
PADS_DESC= Include pads sensor
SANCP_DESC= Include sancp sensor
diff --git a/security/sks/Makefile b/security/sks/Makefile
index 0aac403e1862..74eb05bf55ac 100644
--- a/security/sks/Makefile
+++ b/security/sks/Makefile
@@ -25,6 +25,8 @@ MAKE_ENV= BDBINCLUDE="-I${BDB_INCLUDE_DIR}" \
SUB_FILES= pkg-message
+OPTIONS_DEFINE= DOCS
+
post-extract:
@: > ${WRKSRC}/Makefile.local
@${REINPLACE_CMD} 's/-ccopt -pg //' ${WRKSRC}/Makefile
diff --git a/security/slush/Makefile b/security/slush/Makefile
index 029cfa70630c..cc2532b330e7 100644
--- a/security/slush/Makefile
+++ b/security/slush/Makefile
@@ -14,6 +14,8 @@ COMMENT= A telnet-like application which uses a secure SSL channel
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/control.txt ${STAGEDIR}${DOCSDIR}
diff --git a/security/sssd/Makefile b/security/sssd/Makefile
index 7d22720aebde..89ce471e6ead 100644
--- a/security/sssd/Makefile
+++ b/security/sssd/Makefile
@@ -63,6 +63,8 @@ SHEBANG_FILES= src/tools/sss_obfuscate
USE_RC_SUBR= ${PORTNAME}
PORTDATA= *
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.options.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
diff --git a/security/steghide/Makefile b/security/steghide/Makefile
index a04e680e891b..8dc3e63240cd 100644
--- a/security/steghide/Makefile
+++ b/security/steghide/Makefile
@@ -23,6 +23,8 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include -fpermissive
LIBS+= -L${LOCALBASE}/lib -lintl -lmcrypt
+OPTIONS_DEFINE= DOCS
+
post-patch:
${REINPLACE_CMD} -e 's,SHELL) libtool,SHELL) ${LIBTOOL} --tag=CXX,' \
${WRKSRC}/src/Makefile.in
diff --git a/security/tinyca/Makefile b/security/tinyca/Makefile
index 213f3732cdbb..28eb5876c02f 100644
--- a/security/tinyca/Makefile
+++ b/security/tinyca/Makefile
@@ -26,6 +26,8 @@ DOC_FILES= INSTALL
LIB_FILES= CA.pm CERT.pm GUI.pm HELPERS.pm KEY.pm OpenSSL.pm REQ.pm TCONFIG.pm
LIB2_FILES= CALLBACK.pm HELPERS.pm TCONFIG.pm WORDS.pm X509_browser.pm X509_infobox.pm
+OPTIONS_DEFINE= DOCS
+
do-install:
@${MKDIR} ${STAGEDIR}${SITE_PERL}/${PORTNAME}/GUI
${INSTALL_DATA} ${LIB_FILES:S|^|${WRKSRC}/lib/|} ${STAGEDIR}${SITE_PERL}/${PORTNAME}
diff --git a/security/tlswrap/Makefile b/security/tlswrap/Makefile
index a6a1afba7d4a..2fdcccf0a061 100644
--- a/security/tlswrap/Makefile
+++ b/security/tlswrap/Makefile
@@ -14,6 +14,8 @@ COMMENT= FTP proxy that wraps data and control with TLS/SSL
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+OPTIONS_DEFINE= DOCS
+
post-patch:
@${REINPLACE_CMD} -E 's,^(CC|CFLAGS|LDFLAGS).*=,\1?=,g' \
${WRKSRC}/Makefile.in
diff --git a/security/webfwlog/Makefile b/security/webfwlog/Makefile
index a787487872ee..1fc8a3ca1516 100644
--- a/security/webfwlog/Makefile
+++ b/security/webfwlog/Makefile
@@ -11,7 +11,7 @@ COMMENT= A web-based firewall log analyzer
LICENSE= GPLv2
-OPTIONS_DEFINE= MYSQL MYSQLIPV6 PGSQL
+OPTIONS_DEFINE= MYSQL MYSQLIPV6 PGSQL DOCS
OPTIONS_DEFAULTS= MYSQL MYSQLIPV6
MYSQLIPV6_DESC= Shared library plugin for Mysql IPv6 support