aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2008-02-21 21:19:50 +0800
committergarga <garga@FreeBSD.org>2008-02-21 21:19:50 +0800
commita1e448a0654fbb969c3a78173298a926142f643c (patch)
tree317e8e75c28aac95330d8008947a4335e545dbd8 /security
parentbcdb065b483e6b7d701c5264b74f77e5ad42dfee (diff)
downloadfreebsd-ports-gnome-a1e448a0654fbb969c3a78173298a926142f643c.tar.gz
freebsd-ports-gnome-a1e448a0654fbb969c3a78173298a926142f643c.tar.zst
freebsd-ports-gnome-a1e448a0654fbb969c3a78173298a926142f643c.zip
- Fix a thread problem on FreeBSD 5.x forcing it to use -lpthread [1]
- Fix a problem on pkg-install, when umask is not default, it create dirs with wrong permissions [2] - Bump PORTREVISION PR: ports/120885 [2] Submitted by: dmx@dmx.org.ru [2] Noticed by: havp pointyhat via pav
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile3
-rw-r--r--security/clamav/files/pkg-install.in16
2 files changed, 7 insertions, 12 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 07f322bf2c74..48169cfecdb3 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clamav
PORTVERSION= 0.92.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SF
@@ -107,6 +108,8 @@ CONFIGURE_ARGS+= --enable-gethostbyname_r
# force to use -lthr until it's not fixed.
.if ${OSVERSION} >= 601000
PTHREAD_LIBS= -lthr
+.else
+PTHREAD_LIBS= -lpthread
.endif
.if defined(WITH_ARC)
diff --git a/security/clamav/files/pkg-install.in b/security/clamav/files/pkg-install.in
index b6280ecf8df8..d83287ec16aa 100644
--- a/security/clamav/files/pkg-install.in
+++ b/security/clamav/files/pkg-install.in
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/security/clamav/files/pkg-install.in,v 1.4 2007-02-18 16:12:37 garga Exp $
+# $FreeBSD: /tmp/pcvs/ports/security/clamav/files/pkg-install.in,v 1.5 2008-02-21 13:19:50 garga Exp $
PREFIX=${PKG_PREFIX:-%%PREFIX%%}
@@ -14,7 +14,7 @@ RUNDIR=%%RUNDIR%%
PW="pw"
CHOWN="chown"
-MKDIR="mkdir -p"
+INSTALL_DIR="install -d -o ${CLAMAVUSER} -g ${CLAMAVGROUP} -m 0755"
if [ "$2" = "PRE-INSTALL" ]; then
@@ -41,16 +41,8 @@ if [ "$2" = "PRE-INSTALL" ]; then
fi
elif [ "$2" = "POST-INSTALL" ]; then
-
- [ ! -d "${DBDIR}" ] && (${MKDIR} ${DBDIR} || exit 1)
- ${CHOWN} -R ${CLAMAVUSER}:${CLAMAVGROUP} ${DBDIR} || exit 1
-
- [ ! -d "${LOGDIR}" ] && (${MKDIR} ${LOGDIR} || exit 1)
- ${CHOWN} -R ${CLAMAVUSER}:${CLAMAVGROUP} ${LOGDIR} || exit 1
-
- [ ! -d "${RUNDIR}" ] && (${MKDIR} ${RUNDIR} || exit 1)
- ${CHOWN} -R ${CLAMAVUSER}:${CLAMAVGROUP} ${RUNDIR} || exit 1
-
+ ${INSTALL_DIR} ${DBDIR} ${LOGDIR} ${RUNDIR}
+ ${CHOWN} -R ${CLAMAVUSER}:${CLAMAVGROUP} ${DBDIR} ${LOGDIR} ${RUNDIR}
fi
exit 0