aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-13 22:40:35 +0800
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-13 22:40:35 +0800
commita49b3f075c3eccb0921ba810dc7d5d53cd6b743c (patch)
tree50e79fb71b7d0eafbfc837e2604aaf52b0392aa3 /security
parentcd5e4840a5cd2d67c1cff4b4f6734ed1f06c1387 (diff)
downloadfreebsd-ports-gnome-a49b3f075c3eccb0921ba810dc7d5d53cd6b743c.tar.gz
freebsd-ports-gnome-a49b3f075c3eccb0921ba810dc7d5d53cd6b743c.tar.zst
freebsd-ports-gnome-a49b3f075c3eccb0921ba810dc7d5d53cd6b743c.zip
Add wolfssh 1.4.5
The wolfSSH library is a lightweight SSHv2 client and server library written in ANSI C and targeted for embedded, RTOS, and resource-constrained environments - primarily because of its small size, speed, and feature set. WWW: https://www.wolfssl.com/products/wolfssh/ WWW: https://github.com/wolfSSL/wolfssh
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/wolfssh/Makefile28
-rw-r--r--security/wolfssh/distinfo3
-rw-r--r--security/wolfssh/files/patch-wolfssh-test.h13
-rw-r--r--security/wolfssh/pkg-descr6
-rw-r--r--security/wolfssh/pkg-plist19
6 files changed, 70 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 767173957009..e518eece56d9 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1294,6 +1294,7 @@
SUBDIR += webscarab
SUBDIR += whatweb
SUBDIR += wipe
+ SUBDIR += wolfssh
SUBDIR += wolfssl
SUBDIR += wpa_supplicant
SUBDIR += xca
diff --git a/security/wolfssh/Makefile b/security/wolfssh/Makefile
new file mode 100644
index 000000000000..a735e2fe1718
--- /dev/null
+++ b/security/wolfssh/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= wolfssh
+PORTVERSION= 1.4.5
+CATEGORIES= security
+MASTER_SITES= https://www.wolfssl.com/
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Lightweight SSH Library
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libwolfssl.so:security/wolfssl
+
+USES= autoreconf libtool localbase
+
+CONFIGURE_ARGS= --enable-fwd \
+ --enable-keygen \
+ --enable-scp \
+ --enable-sftp \
+ --enable-shared=yes \
+ --enable-shell \
+ --enable-static=yes
+GNU_CONFIGURE= yes
+TEST_TARGET= check
+
+.include <bsd.port.mk>
diff --git a/security/wolfssh/distinfo b/security/wolfssh/distinfo
new file mode 100644
index 000000000000..9d412591cbb6
--- /dev/null
+++ b/security/wolfssh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607685345
+SHA256 (wolfssh-1.4.5.tar.gz) = 8ed172fd670973b300b0237f0d28127d545a2d21593d1875b1b801a705eb7fb7
+SIZE (wolfssh-1.4.5.tar.gz) = 665491
diff --git a/security/wolfssh/files/patch-wolfssh-test.h b/security/wolfssh/files/patch-wolfssh-test.h
new file mode 100644
index 000000000000..ae688cdc58f8
--- /dev/null
+++ b/security/wolfssh/files/patch-wolfssh-test.h
@@ -0,0 +1,13 @@
+--- wolfssh/test.h.orig 2020-08-31 18:13:34 UTC
++++ wolfssh/test.h
+@@ -436,8 +436,8 @@ static INLINE void build_addr(SOCKADDR_IN_T* addr, con
+ memset(&hints, 0, sizeof(hints));
+
+ hints.ai_family = AF_INET_V;
+- hints.ai_socktype = udp ? SOCK_DGRAM : SOCK_STREAM;
+- hints.ai_protocol = udp ? IPPROTO_UDP : IPPROTO_TCP;
++ hints.ai_socktype = 1 ? SOCK_DGRAM : SOCK_STREAM;
++ hints.ai_protocol = 1 ? IPPROTO_UDP : IPPROTO_TCP;
+
+ WSNPRINTF(strPort, sizeof(strPort), "%d", port);
+ strPort[79] = '\0';
diff --git a/security/wolfssh/pkg-descr b/security/wolfssh/pkg-descr
new file mode 100644
index 000000000000..f965b183f847
--- /dev/null
+++ b/security/wolfssh/pkg-descr
@@ -0,0 +1,6 @@
+The wolfSSH library is a lightweight SSHv2 client and server library written in
+ANSI C and targeted for embedded, RTOS, and resource-constrained environments -
+primarily because of its small size, speed, and feature set.
+
+WWW: https://www.wolfssl.com/products/wolfssh/
+WWW: https://github.com/wolfSSL/wolfssh
diff --git a/security/wolfssh/pkg-plist b/security/wolfssh/pkg-plist
new file mode 100644
index 000000000000..aa90780efee6
--- /dev/null
+++ b/security/wolfssh/pkg-plist
@@ -0,0 +1,19 @@
+bin/wolfssh-config
+include/wolfssh/agent.h
+include/wolfssh/certs_test.h
+include/wolfssh/error.h
+include/wolfssh/keygen.h
+include/wolfssh/log.h
+include/wolfssh/misc.h
+include/wolfssh/port.h
+include/wolfssh/settings.h
+include/wolfssh/ssh.h
+include/wolfssh/test.h
+include/wolfssh/version.h
+include/wolfssh/visibility.h
+include/wolfssh/wolfscp.h
+include/wolfssh/wolfsftp.h
+lib/libwolfssh.a
+lib/libwolfssh.so
+lib/libwolfssh.so.9
+lib/libwolfssh.so.9.3.0