aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-07-31 03:03:06 +0800
committerantoine <antoine@FreeBSD.org>2013-07-31 03:03:06 +0800
commita777855194b9986b211fc0ddb69b065a0c3bb3ce (patch)
treec31718831236ccfd3cb7fa22fafe2f8480de71d2 /security
parent9474cd659695d971d743e6c3c3146d6b9c18e9a4 (diff)
downloadfreebsd-ports-gnome-a777855194b9986b211fc0ddb69b065a0c3bb3ce.tar.gz
freebsd-ports-gnome-a777855194b9986b211fc0ddb69b065a0c3bb3ce.tar.zst
freebsd-ports-gnome-a777855194b9986b211fc0ddb69b065a0c3bb3ce.zip
Update python-registry to 0.2.5.1
Diffstat (limited to 'security')
-rw-r--r--security/py-python-registry/Makefile18
-rw-r--r--security/py-python-registry/distinfo4
-rw-r--r--security/py-python-registry/pkg-plist13
3 files changed, 14 insertions, 21 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
index b287f4d1ee3b..e9ed778693e3 100644
--- a/security/py-python-registry/Makefile
+++ b/security/py-python-registry/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= python-registry
-PORTVERSION= 0.2.5
+PORTVERSION= 0.2.5.1
CATEGORIES= security devel python
-MASTER_SITES= GH
+MASTER_SITES= GH \
+ LOCAL/antoine
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= antoine@FreeBSD.org
@@ -15,16 +16,21 @@ LICENSE= AL2
USE_GITHUB= yes
GH_ACCOUNT= williballenthin
GH_TAGNAME= v${PORTVERSION}
-GH_COMMIT= 8ea7e05
+GH_COMMIT= 1958d37
USE_PYTHON= -2.7
USE_PYDISTUTILS= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+PORTDOCS= *
+PORTEXAMPLES= *
+
.include <bsd.port.options.mk>
post-patch:
- ${REINPLACE_CMD} -e 's|0.2.4.1|${PORTVERSION}|' ${WRKSRC}/Registry/__init__.py
- ${REINPLACE_CMD} -i '' -e 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/samples/*
+ ${REINPLACE_CMD} 's|0.2.4.1|${PORTVERSION}|' ${WRKSRC}/Registry/__init__.py
+ ${REINPLACE_CMD} 's|/usr/bin/python|${PYTHON_CMD}|' ${WRKSRC}/samples/*.py
post-install:
.if ${PORT_OPTIONS:MDOCS}
@@ -33,7 +39,7 @@ post-install:
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_SCRIPT} ${WRKSRC}/samples/* ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/security/py-python-registry/distinfo b/security/py-python-registry/distinfo
index 2bfdab7348ff..fd67eb837cd6 100644
--- a/security/py-python-registry/distinfo
+++ b/security/py-python-registry/distinfo
@@ -1,2 +1,2 @@
-SHA256 (python-registry-0.2.5.tar.gz) = d882fbb5a5608b0ba092362ada3a99753d8b3c184f9811fcbe386a0e708d7faa
-SIZE (python-registry-0.2.5.tar.gz) = 133259
+SHA256 (python-registry-0.2.5.1.tar.gz) = e5da6a48fd7b2bb2a004ffdd395ae256905580d834f7e0b74fb341eca6390d62
+SIZE (python-registry-0.2.5.1.tar.gz) = 134061
diff --git a/security/py-python-registry/pkg-plist b/security/py-python-registry/pkg-plist
index 3412cb6e3e80..7254f93d4da5 100644
--- a/security/py-python-registry/pkg-plist
+++ b/security/py-python-registry/pkg-plist
@@ -8,16 +8,3 @@
%%PYTHON_SITELIBDIR%%/Registry/__init__.pyc
%%PYTHON_SITELIBDIR%%/Registry/__init__.pyo
@dirrm %%PYTHON_SITELIBDIR%%/Registry
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/TheWindowsNTRegistryFileFormat.pdf
-%%PORTDOCS%%%%DOCSDIR%%/WinReg.txt
-%%PORTDOCS%%%%DOCSDIR%%/registry.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/findkey.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/printall.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regfetch.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/regview.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shellbags.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/shelltypes.py
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeline.py
-%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%