aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-02-04 04:57:50 +0800
committerwill <will@FreeBSD.org>2001-02-04 04:57:50 +0800
commita7cd0286d7738f0c878a7583d383dfe40dcd7622 (patch)
tree3bd1c140ed527bbfa2cfc8ce65152b8291020a29 /security
parentb2d6422b0dd6e52a09380cdf56b112407123a27a (diff)
downloadfreebsd-ports-gnome-a7cd0286d7738f0c878a7583d383dfe40dcd7622.tar.gz
freebsd-ports-gnome-a7cd0286d7738f0c878a7583d383dfe40dcd7622.tar.zst
freebsd-ports-gnome-a7cd0286d7738f0c878a7583d383dfe40dcd7622.zip
Add p5-Authen-Krb5 1.2, a perl extension for Kerberos 5.
PR: 24832 Submitted by: Andrew J. Korty <ajk@iu.edu>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-Krb5/Makefile31
-rw-r--r--security/p5-Authen-Krb5/distinfo1
-rw-r--r--security/p5-Authen-Krb5/pkg-comment1
-rw-r--r--security/p5-Authen-Krb5/pkg-descr9
-rw-r--r--security/p5-Authen-Krb5/pkg-plist6
6 files changed, 49 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 5ca57ea234db..355dfe2d4303 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -71,6 +71,7 @@
SUBDIR += openssh-askpass
SUBDIR += openssl
SUBDIR += outguess
+ SUBDIR += p5-Authen-Krb5
SUBDIR += p5-Authen-PAM
SUBDIR += p5-Authen-Radius
SUBDIR += p5-Authen-TacacsPlus
diff --git a/security/p5-Authen-Krb5/Makefile b/security/p5-Authen-Krb5/Makefile
new file mode 100644
index 000000000000..64b11de0aa5f
--- /dev/null
+++ b/security/p5-Authen-Krb5/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Authen-Krb5
+# Date created: 22 January 2001
+# Whom: ajk@iu.edu
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-Krb5
+PORTVERSION= 1.2
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+DISTNAME= Krb5-${PORTVERSION}
+
+MAINTAINER= ajk@iu.edu
+
+LIB_DEPENDS= gssapi_krb5.2:${PORTSDIR}/security/krb5
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::Krb5.3
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+KRB5_HOME?= ${PREFIX}
+
+post-patch:
+ @${PERL} -pi -e 's:/usr/local/krb5:${KRB5_HOME}:g' \
+ ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-Krb5/distinfo b/security/p5-Authen-Krb5/distinfo
new file mode 100644
index 000000000000..b68c123db88c
--- /dev/null
+++ b/security/p5-Authen-Krb5/distinfo
@@ -0,0 +1 @@
+MD5 (Krb5-1.2.tar.gz) = c2b82738eb14bb964ed54a05e2801bf3
diff --git a/security/p5-Authen-Krb5/pkg-comment b/security/p5-Authen-Krb5/pkg-comment
new file mode 100644
index 000000000000..71b960e489c9
--- /dev/null
+++ b/security/p5-Authen-Krb5/pkg-comment
@@ -0,0 +1 @@
+Perl extension for Kerberos 5
diff --git a/security/p5-Authen-Krb5/pkg-descr b/security/p5-Authen-Krb5/pkg-descr
new file mode 100644
index 000000000000..d59f98ab10ee
--- /dev/null
+++ b/security/p5-Authen-Krb5/pkg-descr
@@ -0,0 +1,9 @@
+Authen::Krb5 is an object-oriented interface to the Kerberos 5 API.
+Both the implementation and documentation are nowhere near complete,
+and may require previous experience with Kerberos 5 programming. Most
+of the functions here are documented in detail in the Kerberos 5 API
+documentation.
+
+WWW: http://search.cpan.org/search?module=Authen::Krb5
+
+FreeBSD port by Andrew J. Korty <ajk@iu.edu>
diff --git a/security/p5-Authen-Krb5/pkg-plist b/security/p5-Authen-Krb5/pkg-plist
new file mode 100644
index 000000000000..35fc34195b4d
--- /dev/null
+++ b/security/p5-Authen-Krb5/pkg-plist
@@ -0,0 +1,6 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/Authen/Krb5.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Authen/Krb5/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Authen/Krb5/Krb5.bs
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Authen/Krb5/Krb5.so
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Authen/Krb5/autosplit.ix
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Authen/Krb5