aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2013-02-17 16:43:16 +0800
committerak <ak@FreeBSD.org>2013-02-17 16:43:16 +0800
commitac01b89a7389aea7e80e47a10f2dc7af880ce0da (patch)
treec54d43b7dcd395c63b22999f6d011070eb71960a /security
parent22e028a67eae9371c107844d656acad53c245558 (diff)
downloadfreebsd-ports-gnome-ac01b89a7389aea7e80e47a10f2dc7af880ce0da.tar.gz
freebsd-ports-gnome-ac01b89a7389aea7e80e47a10f2dc7af880ce0da.tar.zst
freebsd-ports-gnome-ac01b89a7389aea7e80e47a10f2dc7af880ce0da.zip
- Install manpages [1]
- Convert Makefile headers to new style - Remove indefinite article from COMMENT PR: ports/176198 (based on) [1] Submitted by: Brett Wynkoop <bsdbugs@wynn.com>
Diffstat (limited to 'security')
-rw-r--r--security/dropbear/Makefile19
1 files changed, 10 insertions, 9 deletions
diff --git a/security/dropbear/Makefile b/security/dropbear/Makefile
index ce4f301b972c..0fa49b1d6428 100644
--- a/security/dropbear/Makefile
+++ b/security/dropbear/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: dropbear
-# Date created: 20 August 2003
-# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
-#
+# Created by: Clement Laforet <sheepkiller@cultdeadsheep.org>
# $FreeBSD$
-#
PORTNAME= dropbear
PORTVERSION= 2012.55
@@ -11,11 +7,11 @@ CATEGORIES= security ipv6
MASTER_SITES= http://matt.ucc.asn.au/dropbear/releases/
MAINTAINER= ak@FreeBSD.org
-COMMENT= An SSH 2 server, designed to be usable in small memory environments
+COMMENT= SSH 2 server, designed to be usable in small memory environments
-GNU_CONFIGURE= YES
-USE_BZIP2= YES
-USE_GMAKE= YES
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
USE_RC_SUBR= ${PORTNAME}
@@ -26,6 +22,9 @@ PLIST_FILES= bin/dbclient \
PLIST_DIRSTRY= etc/dropbear
+MAN1= dbclient.1
+MAN8= dropbear.8 dropbearkey.8
+
OPTIONS_DEFINE= STATIC
.include <bsd.port.options.mk>
@@ -43,5 +42,7 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/dropbear
+ ${INSTALL_MAN} ${MAN1:S|^|${WRKSRC}/|} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${MAN8:S|^|${WRKSRC}/|} ${MAN8PREFIX}/man/man8
.include <bsd.port.mk>