aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2001-06-12 15:49:52 +0800
committerdinoex <dinoex@FreeBSD.org>2001-06-12 15:49:52 +0800
commitad629d57cd66e10180ebb49351ae856c1155b6db (patch)
treebe573570acbab1eddd5f5517295af9017fc8282e /security
parentcfd3c2f7fc84cc19dd2205925221fab06ba4082c (diff)
downloadfreebsd-ports-gnome-ad629d57cd66e10180ebb49351ae856c1155b6db.tar.gz
freebsd-ports-gnome-ad629d57cd66e10180ebb49351ae856c1155b6db.tar.zst
freebsd-ports-gnome-ad629d57cd66e10180ebb49351ae856c1155b6db.zip
- Drop modifier L in makefile, all options have to be set
in lowercase "yes" - Tested build with FreeBSD 4.1 openssl-0.9.6a needs to be installed form ports. "FORBIDDEN" must be removed by hand.
Diffstat (limited to 'security')
-rw-r--r--security/openssh/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/security/openssh/Makefile b/security/openssh/Makefile
index d94273b02fad..a7bd31254136 100644
--- a/security/openssh/Makefile
+++ b/security/openssh/Makefile
@@ -23,9 +23,21 @@ MAN1= scp.1 slogin.1 ssh-add.1 ssh-agent.1 ssh-keygen.1 ssh.1 \
ssh-keyscan.1 sftp.1
MAN8= sshd.8 sftp-server.8
MANCOMPRESSED= yes
+FIXME= lib/Makefile scp/Makefile sftp/Makefile sftp-server/Makefile \
+ ssh/Makefile ssh-add/Makefile ssh-agent/Makefile \
+ ssh-keygen/Makefile ssh-keyscan/Makefile sshd/Makefile
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 430000
+OPENSSLBASE= /usr/local
+OPENSSLDIR= ${OPENSSLBASE}/openssl
+LIB_DEPENDS+= crypto.2:${PORTSDIR}/security/openssl
+OPENSSLLIB= ${OPENSSLBASE}/lib
+OPENSSLINC= ${OPENSSLBASE}/include
+MAKE_ENV+= OPENSSLLIB=${OPENSSLLIB} OPENSSLINC=${OPENSSLINC} \
+ OPENSSLBASE=${OPENSSLBASE} OPENSSLDIR=${OPENSSLDIR}
+.endif
CRYPTOLIBS= -L${OPENSSLLIB} -lcrypto
# Here, MANDIR is concetenated to DESTDIR which all forms the man install dir...
MAKE_ENV+= DESTDIR=${PREFIX} MANDIR=/man/man CRYPTOLIBS="${CRYPTOLIBS}"
@@ -69,6 +81,16 @@ post-patch:
${WRKSRC}/sshd_config ${WRKSRC}/sshd.sh \
${WRKSRC}/pathnames.h
+.if ${OSVERSION} < 430000
+post-configure:
+.for i in ${FIXME}
+ @${PERL5} -pi -e "s=KERBEROS[:]L=KERBEROS=" ${WRKSRC}/${i}
+ @${PERL5} -pi -e "s=AFS[:]L=AFS=" ${WRKSRC}/${i}
+ @${PERL5} -pi -e "s=TCP_WRAPPERS[:]L=TCP_WRAPPERS=" ${WRKSRC}/${i}
+ @${PERL5} -pi -e "s=SKEY[:]L=SKEY=" ${WRKSRC}/${i}
+.endfor
+.endif
+
post-install:
.if !defined(BATCH)
.if !exists(${PREFIX}/etc/ssh_host_key)