aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2015-12-15 22:33:33 +0800
committermiwi <miwi@FreeBSD.org>2015-12-15 22:33:33 +0800
commitadbb0b93e8f68c34f769842c73a092f248b403c5 (patch)
treea574753719a844f1716513268e2e2fde6a60e662 /security
parent8c87064609b825fc38b6a4d07ecc828808668db5 (diff)
downloadfreebsd-ports-gnome-adbb0b93e8f68c34f769842c73a092f248b403c5.tar.gz
freebsd-ports-gnome-adbb0b93e8f68c34f769842c73a092f248b403c5.tar.zst
freebsd-ports-gnome-adbb0b93e8f68c34f769842c73a092f248b403c5.zip
A small command line utility for parsing PKCS#10 certificate signing
requests to perl data structure and provides accessor methods to supported elements. It is based on the generic ASN.1 module by Graham Barr and on the x509decode example by Norbert Klasen. It is also based upon the works of Duncan Segrests Crypt-X509-CRL module. The module parses common fields and extensions. Some fields might be missing. WWW: http://search.cpan.org/dist/Crypt-PKCS10/ PR: 204814 Submitted by: Sergei Vyshenski <svysh.fbsd@gmail.com> Approved by: mat (mentor) Differential Revision: D4574
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-PKCS10/Makefile23
-rw-r--r--security/p5-Crypt-PKCS10/distinfo2
-rw-r--r--security/p5-Crypt-PKCS10/pkg-descr10
-rw-r--r--security/p5-Crypt-PKCS10/pkg-plist2
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 45ca1c1d438a..e1e9875501d2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -526,6 +526,7 @@
SUBDIR += p5-Crypt-Passwd-XS
SUBDIR += p5-Crypt-PasswdMD5
SUBDIR += p5-Crypt-Password-Util
+ SUBDIR += p5-Crypt-PKCS10
SUBDIR += p5-Crypt-Primes
SUBDIR += p5-Crypt-RC4
SUBDIR += p5-Crypt-RC5
diff --git a/security/p5-Crypt-PKCS10/Makefile b/security/p5-Crypt-PKCS10/Makefile
new file mode 100644
index 000000000000..ef055c1db494
--- /dev/null
+++ b/security/p5-Crypt-PKCS10/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sergei Vyshenski <svysh.fbsd@gmail.com>
+# $FreeBSD$
+
+PORTNAME= Crypt-PKCS10
+PORTVERSION= 1.3
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= svysh.fbsd@gmail.com
+COMMENT= Parse PKCS #10 certificate requests
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Convert-ASN1>=0.27:${PORTSDIR}/converters/p5-Convert-ASN1
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USES= perl5
+USE_PERL5= configure
+NO_ARCH=yes
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-PKCS10/distinfo b/security/p5-Crypt-PKCS10/distinfo
new file mode 100644
index 000000000000..58aaa29da937
--- /dev/null
+++ b/security/p5-Crypt-PKCS10/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-PKCS10-1.3.tar.gz) = 5ef231ac72a6b6987f90d5d9007914442a0aa9dd2bdbdba1ba4a9429c7b864ec
+SIZE (Crypt-PKCS10-1.3.tar.gz) = 15436
diff --git a/security/p5-Crypt-PKCS10/pkg-descr b/security/p5-Crypt-PKCS10/pkg-descr
new file mode 100644
index 000000000000..7a3ad33eb81f
--- /dev/null
+++ b/security/p5-Crypt-PKCS10/pkg-descr
@@ -0,0 +1,10 @@
+A small command line utility for parsing PKCS#10 certificate signing
+requests to perl data structure and provides accessor methods to
+supported elements.
+
+It is based on the generic ASN.1 module by Graham Barr and on the
+x509decode example by Norbert Klasen. It is also based upon the
+works of Duncan Segrests Crypt-X509-CRL module. The module parses
+common fields and extensions. Some fields might be missing.
+
+WWW: http://search.cpan.org/dist/Crypt-PKCS10/
diff --git a/security/p5-Crypt-PKCS10/pkg-plist b/security/p5-Crypt-PKCS10/pkg-plist
new file mode 100644
index 000000000000..317c7ea6ab8d
--- /dev/null
+++ b/security/p5-Crypt-PKCS10/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/Crypt/PKCS10.pm
+%%PERL5_MAN3%%/Crypt::PKCS10.3.gz