aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbarner <barner@FreeBSD.org>2008-05-18 03:15:03 +0800
committerbarner <barner@FreeBSD.org>2008-05-18 03:15:03 +0800
commitafa592b3695743cfd7f3fc56e3a6fe21d47613ba (patch)
tree30c2538f7a2ca66b0f313075f20b22fb7cec768b /security
parente5292668bbc23bc6b70f803b16b06ae7a213576f (diff)
downloadfreebsd-ports-gnome-afa592b3695743cfd7f3fc56e3a6fe21d47613ba.tar.gz
freebsd-ports-gnome-afa592b3695743cfd7f3fc56e3a6fe21d47613ba.tar.zst
freebsd-ports-gnome-afa592b3695743cfd7f3fc56e3a6fe21d47613ba.zip
- Fix build on FreeBSD5 by supplying non-existing Linux error code.
Requested by: pointhat via pav
Diffstat (limited to 'security')
-rw-r--r--security/libfprint/Makefile4
-rw-r--r--security/libfprint/files/extra-patch-FreeBSD531
2 files changed, 35 insertions, 0 deletions
diff --git a/security/libfprint/Makefile b/security/libfprint/Makefile
index cf1fc16da8ff..419aba8aa6c9 100644
--- a/security/libfprint/Makefile
+++ b/security/libfprint/Makefile
@@ -25,6 +25,10 @@ USE_GNOME= glib20 pkgconfig
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 600000
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-FreeBSD5
+.endif
+
CONFIGURE_ENV+= CRYPTO_CFLAGS=-I${OPENSSLINC} \
CRYPTO_LIBS=-lcrypto \
CFLAGS="${CFLAGS} -DHAVE_MEMMEM"
diff --git a/security/libfprint/files/extra-patch-FreeBSD5 b/security/libfprint/files/extra-patch-FreeBSD5
new file mode 100644
index 000000000000..f804d8d4643d
--- /dev/null
+++ b/security/libfprint/files/extra-patch-FreeBSD5
@@ -0,0 +1,31 @@
+--- libfprint/drivers/upekts.c.orig 2008-04-29 22:04:53.000000000 +0200
++++ libfprint/drivers/upekts.c 2008-04-29 22:11:18.000000000 +0200
+@@ -35,6 +35,8 @@
+
+ #include <fp_internal.h>
+
++#include "libfprint/errno_compat.h"
++
+ #define EP_IN (1 | USB_ENDPOINT_IN)
+ #define EP_OUT (2 | USB_ENDPOINT_OUT)
+ #define TIMEOUT 5000
+--- libfprint/drivers/uru4000.c.orig 2008-04-29 22:04:44.000000000 +0200
++++ libfprint/drivers/uru4000.c 2008-04-29 22:11:33.000000000 +0200
+@@ -28,6 +28,8 @@
+
+ #include <fp_internal.h>
+
++#include "libfprint/errno_compat.h"
++
+ #define EP_INTR (1 | USB_ENDPOINT_IN)
+ #define EP_DATA (2 | USB_ENDPOINT_IN)
+ #define USB_RQ 0x04
+--- libfprint/errno_compat.h.orig 2008-04-29 22:30:31.550769000 +0200
++++ libfprint/errno_compat.h 2008-04-29 22:30:31.550769000 +0200
+@@ -0,0 +1,6 @@
++#ifndef _ERRNO_COMPAT_H_
++#define _ERRNO_COMPAT_H_
++
++#define EPROTO 92
++
++#endif /* _ERRNO_COMPAT_H_ */