aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcperciva <cperciva@FreeBSD.org>2013-11-04 14:05:12 +0800
committercperciva <cperciva@FreeBSD.org>2013-11-04 14:05:12 +0800
commitb350b4916e5cb0de6617ca21c05b705511019e08 (patch)
treedf0755a1fcaf427e28d59d3d8cb0f4d04f87c882 /security
parentec3498775d18b30026cb6f048847c222ad7306dd (diff)
downloadfreebsd-ports-gnome-b350b4916e5cb0de6617ca21c05b705511019e08.tar.gz
freebsd-ports-gnome-b350b4916e5cb0de6617ca21c05b705511019e08.tar.zst
freebsd-ports-gnome-b350b4916e5cb0de6617ca21c05b705511019e08.zip
pkesh is a Public Key Encryption SHell script. Think GPG with 99.9% less
code and without the web-of-trust mechanism: pkesh encrypts data to a key, and it's up to you to make sure it's the correct key.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/pkesh/Makefile28
-rw-r--r--security/pkesh/distinfo2
-rw-r--r--security/pkesh/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ba94c0fea901..2910eb4dff08 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -713,6 +713,7 @@
SUBDIR += pkcs11-dump
SUBDIR += pkcs11-gateway
SUBDIR += pkcs11-helper
+ SUBDIR += pkesh
SUBDIR += pks
SUBDIR += pktsuckers
SUBDIR += please
diff --git a/security/pkesh/Makefile b/security/pkesh/Makefile
new file mode 100644
index 000000000000..4536d5020429
--- /dev/null
+++ b/security/pkesh/Makefile
@@ -0,0 +1,28 @@
+# Created by: Colin Percival
+# $FreeBSD$
+
+PORTNAME= pkesh
+PORTVERSION= 1.0
+CATEGORIES= security
+MASTER_SITES= http://www.daemonology.net/pkesh/
+
+MAINTAINER= cperciva@FreeBSD.org
+COMMENT= Public Key Encryption SHell script
+
+LICENSE= BSD
+
+NO_BUILD= YES
+NO_INSTALL= YES
+
+PLIST_FILES= bin/pkesh \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+PLIST_DIRS= %%DOCSDIR%%
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/pkesh.sh ${STAGEDIR}${PREFIX}/bin/pkesh
+
+post-install:
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/pkesh/distinfo b/security/pkesh/distinfo
new file mode 100644
index 000000000000..c039af8e532e
--- /dev/null
+++ b/security/pkesh/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pkesh-1.0.tar.gz) = c8f44d4d708c078b514ce748671ef2f1f92f83f07e7140d6bc5f35fad0bb691e
+SIZE (pkesh-1.0.tar.gz) = 2360
diff --git a/security/pkesh/pkg-descr b/security/pkesh/pkg-descr
new file mode 100644
index 000000000000..fd53a396c8ea
--- /dev/null
+++ b/security/pkesh/pkg-descr
@@ -0,0 +1,3 @@
+pkesh is a Public Key Encryption SHell script. Think GPG with 99.9% less
+code and without the web-of-trust mechanism: pkesh encrypts data to a key,
+and it's up to you to make sure it's the correct key.