aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2014-01-08 19:18:44 +0800
committernovel <novel@FreeBSD.org>2014-01-08 19:18:44 +0800
commitb6433c06e1ef9de9d4685b5e422e698f89d1d27f (patch)
treeb482611a58d363660000268d7cb49b3251c4f098 /security
parent710d46cae1dca1bea0ade6433127e3f243030aa1 (diff)
downloadfreebsd-ports-gnome-b6433c06e1ef9de9d4685b5e422e698f89d1d27f.tar.gz
freebsd-ports-gnome-b6433c06e1ef9de9d4685b5e422e698f89d1d27f.tar.zst
freebsd-ports-gnome-b6433c06e1ef9de9d4685b5e422e698f89d1d27f.zip
- Fix possbile DoS in TLS record decoding [1]
- Fix installation without NLS [2] - Require gmake and perl for build because in some occasions it will rebuild the documentation that works in a proper way with gmake only and needs perl - Bump PORTREVISION Security: CVE-2013-2116 Reported by: mat [2]
Diffstat (limited to 'security')
-rw-r--r--security/gnutls/Makefile5
-rw-r--r--security/gnutls/files/patch-lib-gnutls_cipher.c11
-rw-r--r--security/gnutls/pkg-plist8
3 files changed, 18 insertions, 6 deletions
diff --git a/security/gnutls/Makefile b/security/gnutls/Makefile
index 2bd0c44cd71e..9a837ba20347 100644
--- a/security/gnutls/Makefile
+++ b/security/gnutls/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnutls
PORTVERSION= 2.12.23
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security net
MASTER_SITES= \
ftp://ftp.gnutls.org/gcrypt/gnutls/v${PORTVERSION:C/.[0-9]+$//}/
@@ -19,7 +19,8 @@ LIB_DEPENDS= nettle:${PORTSDIR}/security/nettle \
CONFLICTS= gnutls-devel-[0-9]*
-USES= pathfix pkgconfig iconv
+USES= pathfix pkgconfig iconv gmake perl5
+USE_PERL5= build
USE_BZIP2= yes
USE_GNOME= ltverhack
GNU_CONFIGURE= yes
diff --git a/security/gnutls/files/patch-lib-gnutls_cipher.c b/security/gnutls/files/patch-lib-gnutls_cipher.c
new file mode 100644
index 000000000000..700bf4951288
--- /dev/null
+++ b/security/gnutls/files/patch-lib-gnutls_cipher.c
@@ -0,0 +1,11 @@
+--- lib/gnutls_cipher.c.orig 2013-02-04 12:53:03.000000000 +0400
++++ lib/gnutls_cipher.c 2013-02-04 12:53:03.000000000 +0400
+@@ -561,6 +561,8 @@
+ return GNUTLS_E_DECRYPTION_FAILED;
+ }
+ pad = ciphertext.data[ciphertext.size - 1]; /* pad */
++ if (pad+1 > ciphertext.size-hash_size)
++ pad_failed = GNUTLS_E_DECRYPTION_FAILED;
+
+ /* Check the pading bytes (TLS 1.x).
+ * Note that we access all 256 bytes of ciphertext for padding check
diff --git a/security/gnutls/pkg-plist b/security/gnutls/pkg-plist
index 8b18b21db4c9..aef0c1352fde 100644
--- a/security/gnutls/pkg-plist
+++ b/security/gnutls/pkg-plist
@@ -716,8 +716,8 @@ man/man3/gnutls_x509_rdn_get_oid.3.gz
%%NLS%%share/locale/sv/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/vi/LC_MESSAGES/libgnutls.mo
%%NLS%%share/locale/zh_CN/LC_MESSAGES/libgnutls.mo
+%%NLS%%@dirrmtry share/locale/en@quot/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/en@quot
+%%NLS%%@dirrmtry share/locale/en@boldquot/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/en@boldquot
@dirrm include/gnutls
-@dirrmtry share/locale/en@quot/LC_MESSAGES
-@dirrmtry share/locale/en@quot
-@dirrmtry share/locale/en@boldquot/LC_MESSAGES
-@dirrmtry share/locale/en@boldquot