aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2015-06-07 04:27:21 +0800
committercy <cy@FreeBSD.org>2015-06-07 04:27:21 +0800
commitb8288ae76bf6ff6f2c05922f85ad31c42c6f9fb8 (patch)
treeed27c35d392c8a0006030dca6f33687cfc617dc0 /security
parent9124c4877575ac0904ed91849d6185b2565b5e2e (diff)
downloadfreebsd-ports-gnome-b8288ae76bf6ff6f2c05922f85ad31c42c6f9fb8.tar.gz
freebsd-ports-gnome-b8288ae76bf6ff6f2c05922f85ad31c42c6f9fb8.tar.zst
freebsd-ports-gnome-b8288ae76bf6ff6f2c05922f85ad31c42c6f9fb8.zip
MIT KRB5 ports build unusable binaries due to incorrect linking
when build under poudriere. This commit fixes that.
Diffstat (limited to 'security')
-rw-r--r--security/krb5-111/Makefile4
-rw-r--r--security/krb5-112/Makefile4
-rw-r--r--security/krb5-appl/Makefile3
-rw-r--r--security/krb5/Makefile5
4 files changed, 10 insertions, 6 deletions
diff --git a/security/krb5-111/Makefile b/security/krb5-111/Makefile
index cbfc4d94ff14..49228edc313e 100644
--- a/security/krb5-111/Makefile
+++ b/security/krb5-111/Makefile
@@ -3,7 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.11.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/krb5/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PKGNAMESUFFIX= -111
@@ -27,7 +27,7 @@ CONFLICTS= heimdal-[0-9]* srp-[0-9]* krb5-[0-9]* krb5-maint-112-*
LATEST_LINK= ${PORTNAME}-111
KERBEROSV_URL= http://web.mit.edu/kerberos/
-USES= cpe gettext gmake perl5
+USES= cpe gettext gmake perl5 gssapi:bootstrap,mit
USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu99
diff --git a/security/krb5-112/Makefile b/security/krb5-112/Makefile
index c4d49193bc00..ed222b40e111 100644
--- a/security/krb5-112/Makefile
+++ b/security/krb5-112/Makefile
@@ -3,6 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.12.4
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PKGNAMESUFFIX= -112
@@ -27,7 +28,8 @@ USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu99
GNU_CONFIGURE= yes
-USES= cpe gettext gmake perl5 libtool:build
+USES= cpe gettext gmake perl5 libtool:build \
+ gssapi:boostrap,mit
CONFIGURE_ARGS?= --enable-shared --without-system-verto \
--disable-rpath --localstatedir="${PREFIX}/var"
CONFIGURE_ENV= INSTALL="${INSTALL}" INSTALL_LIB="${INSTALL_LIB}" YACC="${YACC}"
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 898ccd7c6edb..f79ac94277f7 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -3,6 +3,7 @@
PORTNAME= krb5-appl
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
PATCH_SITES= http://web.mit.edu/kerberos/advisories/
@@ -20,7 +21,7 @@ CONFLICTS= krb4-[0-9]* krb5-1.[0-7].* heimdal-[0-9]* srp-[0-9]*
LATEST_LINK= ${PORTNAME}-1
KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_OPENSSL= yes
-USES= gmake perl5
+USES= gmake perl5 gssapi:mit
USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu89
diff --git a/security/krb5/Makefile b/security/krb5/Makefile
index 931d39962a43..831bb83ba3ab 100644
--- a/security/krb5/Makefile
+++ b/security/krb5/Makefile
@@ -3,7 +3,7 @@
PORTNAME= krb5
PORTVERSION= 1.13.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= http://web.mit.edu/kerberos/dist/${PORTNAME}/${PORTVERSION:C/^[0-9]*\.[0-9]*/&X/:C/X\.[0-9]*$//:C/X//}/
DISTNAME= ${PORTNAME}-${PORTVERSION}-signed
@@ -26,7 +26,8 @@ USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu99
GNU_CONFIGURE= yes
-USES= cpe gettext gmake perl5 libtool:build
+USES= cpe gettext gmake perl5 libtool:build \
+ gssapi:bootstrap,mit
CONFIGURE_ARGS?= --enable-shared --without-system-verto \
--disable-rpath --localstatedir="${PREFIX}/var"
CONFIGURE_ENV= INSTALL="${INSTALL}" INSTALL_LIB="${INSTALL_LIB}" YACC="${YACC}"