aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2018-01-23 18:48:49 +0800
committerale <ale@FreeBSD.org>2018-01-23 18:48:49 +0800
commitb842302f251170cf1674d115c18a321ec623b27a (patch)
tree2dd3501ef7c86c6d46207959f7838e124ae5da81 /security
parent1baaa3d6de77458c09cadd790a0a3a656f5f3680 (diff)
downloadfreebsd-ports-gnome-b842302f251170cf1674d115c18a321ec623b27a.tar.gz
freebsd-ports-gnome-b842302f251170cf1674d115c18a321ec623b27a.tar.zst
freebsd-ports-gnome-b842302f251170cf1674d115c18a321ec623b27a.zip
Try to fix build on -CURRENT and add LICENSE.
Diffstat (limited to 'security')
-rw-r--r--security/pkcs11-dump/Makefile4
-rw-r--r--security/pkcs11-dump/files/patch-Makefile.in10
-rw-r--r--security/pkcs11-dump/files/patch-pkcs11-dump.cpp11
3 files changed, 19 insertions, 6 deletions
diff --git a/security/pkcs11-dump/Makefile b/security/pkcs11-dump/Makefile
index 65201771a7c7..4072b330ee3f 100644
--- a/security/pkcs11-dump/Makefile
+++ b/security/pkcs11-dump/Makefile
@@ -9,7 +9,9 @@ MASTER_SITES= https://github.com/alonbl/pkcs11-dump/releases/download/pkcs11-dum
MAINTAINER= ale@FreeBSD.org
COMMENT= Allow dumping PKCS\#11 token content
-USES= tar:bzip2 ssl
+LICENSE= GPLv2
+
+USES= tar:bzip2 ssl dos2unix
GNU_CONFIGURE= yes
CONFIGURE_ENV= OPENSSL_CFLAGS="-I${OPENSSLINC}" \
diff --git a/security/pkcs11-dump/files/patch-Makefile.in b/security/pkcs11-dump/files/patch-Makefile.in
index 039376d3edd1..55fbd8c8e328 100644
--- a/security/pkcs11-dump/files/patch-Makefile.in
+++ b/security/pkcs11-dump/files/patch-Makefile.in
@@ -1,6 +1,6 @@
---- Makefile.in.orig 2011-04-04 12:52:22.000000000 +0200
-+++ Makefile.in 2011-04-04 12:54:09.000000000 +0200
-@@ -73,8 +73,7 @@
+--- Makefile.in.orig 2018-01-23 10:46:50 UTC
++++ Makefile.in
+@@ -73,8 +73,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
mkinstalldirs = $(install_sh) -d
CONFIG_HEADER = config.h
CONFIG_CLEAN_FILES = versioninfo.rc
@@ -10,7 +10,7 @@
binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
PROGRAMS = $(bin_PROGRAMS)
am_pkcs11_dump_OBJECTS = pkcs11-dump.$(OBJEXT)
-@@ -665,7 +664,7 @@
+@@ -665,7 +664,7 @@ check-am: all-am
check: check-am
all-am: Makefile $(PROGRAMS) $(MANS) $(DATA) config.h
installdirs:
@@ -19,7 +19,7 @@
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
done
install: install-am
-@@ -715,8 +714,7 @@
+@@ -715,8 +714,7 @@ info: info-am
info-am:
diff --git a/security/pkcs11-dump/files/patch-pkcs11-dump.cpp b/security/pkcs11-dump/files/patch-pkcs11-dump.cpp
new file mode 100644
index 000000000000..fc8fe2ba141b
--- /dev/null
+++ b/security/pkcs11-dump/files/patch-pkcs11-dump.cpp
@@ -0,0 +1,11 @@
+--- pkcs11-dump.cpp.orig 2018-01-23 10:46:55 UTC
++++ pkcs11-dump.cpp
+@@ -1136,7 +1136,7 @@ Dump (
+ for (int j=0;attrdescAttributes[j].nId!=-1;j++) {
+ char Buffer[10*1024];
+ CK_ATTRIBUTE t[] = {
+- {attrdescAttributes[j].nId, Buffer, sizeof (Buffer)}
++ {(CK_ATTRIBUTE_TYPE)attrdescAttributes[j].nId, Buffer, sizeof (Buffer)}
+ };
+
+ if (