aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsmace <smace@FreeBSD.org>1998-09-15 22:49:08 +0800
committersmace <smace@FreeBSD.org>1998-09-15 22:49:08 +0800
commitb9052a8159516ef85d3b1aff80bc6a2eb9d2ea40 (patch)
tree94864968c5e91751d4ae127f1ce9e745a0ec33d9 /security
parent053c7f7655886573639b1ac70af8806713a04099 (diff)
downloadfreebsd-ports-gnome-b9052a8159516ef85d3b1aff80bc6a2eb9d2ea40.tar.gz
freebsd-ports-gnome-b9052a8159516ef85d3b1aff80bc6a2eb9d2ea40.tar.zst
freebsd-ports-gnome-b9052a8159516ef85d3b1aff80bc6a2eb9d2ea40.zip
Support building on non-elf machine
Diffstat (limited to 'security')
-rw-r--r--security/rsaref/files/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/security/rsaref/files/Makefile b/security/rsaref/files/Makefile
index e1b2f25e434b..3cf51fbce8fb 100644
--- a/security/rsaref/files/Makefile
+++ b/security/rsaref/files/Makefile
@@ -21,5 +21,10 @@ $(RSAREFLIB) : desc.$(O) digit.$(O) md2c.$(O) md5c.$(O) nn.$(O) prime.$(O)\
$(SORSAREFLIB) : desc.$(SO) digit.$(SO) md2c.$(SO) md5c.$(SO) nn.$(SO) prime.$(SO)\
rsa.$(SO) r_encode.$(SO) r_dh.$(SO) r_enhanc.$(SO) r_keygen.$(SO) r_random.$(SO)\
r_stdlib.$(SO)
+.if defined(PORTOBJFORMAT) && PORTOBJFORMAT == elf
${CC} -o $@ -shared -Wl,-soname,$@ $>
+.else
+ ld -Bshareable -x -o $@ $>
+.endif
+