aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
committerrene <rene@FreeBSD.org>2013-11-10 03:13:27 +0800
commitbc9eaafddac55414d201b6636e63508ce80779b9 (patch)
tree7436338612f22a81def9ee6c2d2e3826c1504ea4 /security
parent74e9373bcd181bd5e011c695cd6ff38aeea7d44b (diff)
downloadfreebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.gz
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.tar.zst
freebsd-ports-gnome-bc9eaafddac55414d201b6636e63508ce80779b9.zip
Convert to USES=kmod, which removes duplicated code and ensures that all
required steps are followed. There are no user-visible changes. The exception is multimedia/ptx-kmod, which now installs the kernel module into /boot/modules instead of ${PREFIX}/libexec/${PORTNAME}, this was something USES=kmod cannot handle. PR: ports/183625 Submitted by: myself Approved by: portmgr (bdrewery) Exp-run by: bdrewery
Diffstat (limited to 'security')
-rw-r--r--security/quantis-kmod/Makefile14
1 files changed, 3 insertions, 11 deletions
diff --git a/security/quantis-kmod/Makefile b/security/quantis-kmod/Makefile
index be9fd65a503c..a5e190323e2c 100644
--- a/security/quantis-kmod/Makefile
+++ b/security/quantis-kmod/Makefile
@@ -3,7 +3,7 @@
PORTNAME= quantis
DISTVERSION= v13.04.29
-CATEGORIES= security kld
+CATEGORIES= security
MASTER_SITES= http://www.idquantique.com/~download/Quantis/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= ale
@@ -17,27 +17,19 @@ LICENSE= BSD GPLv2
LICENSE_COMB= dual
LICENSE_FILE= ${WRKDIR}/Quantis-${DISTVERSION}/License.txt
-SSP_UNSAFE= kernel module does not support ssp
USE_ZIP= yes
EXTRACT_BEFORE_ARGS= -aqo
WRKSRC= ${WRKDIR}/Quantis-${DISTVERSION}/Drivers/Unix/QuantisPci
-KMODDIR?= /boot/modules
-
-MAKE_ENV+= KMODDIR=${KMODDIR}
-
PLIST_FILES= "@cwd ${KMODDIR}" \
"quantis.ko" \
- "@unexec kldxref ${KMODDIR}" \
"@cwd ${PREFIX}"
NO_STAGE= yes
-.include <bsd.port.pre.mk>
-.if !exists(${SRC_BASE}/sys/Makefile)
-IGNORE= requires kernel source to be installed
-.endif
+USES= kmod
+.include <bsd.port.pre.mk>
post-install:
@${CAT} ${PKGMESSAGE}