aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-04-10 02:50:56 +0800
committergarga <garga@FreeBSD.org>2010-04-10 02:50:56 +0800
commitbcdd2d81af96cf180228b3ccbc666e139983ba9a (patch)
tree8804ca7c7dd9b96b1c6c79c1284cb19c48fa3857 /security
parent68738cc51bc2f021c723982a550b39b149b6c06f (diff)
downloadfreebsd-ports-gnome-bcdd2d81af96cf180228b3ccbc666e139983ba9a.tar.gz
freebsd-ports-gnome-bcdd2d81af96cf180228b3ccbc666e139983ba9a.tar.zst
freebsd-ports-gnome-bcdd2d81af96cf180228b3ccbc666e139983ba9a.zip
Python and gmake are just necessary when LLVM option is set
Diffstat (limited to 'security')
-rw-r--r--security/clamav-devel/Makefile30
1 files changed, 16 insertions, 14 deletions
diff --git a/security/clamav-devel/Makefile b/security/clamav-devel/Makefile
index 2b3c34c2de4f..ff6fb6c606ef 100644
--- a/security/clamav-devel/Makefile
+++ b/security/clamav-devel/Makefile
@@ -28,8 +28,6 @@ OPTIONS= ARC "Enable arch archives support" On \
STDERR "Print logs to stderr instead of stdout" Off
USE_GCC= 4.2+
-USE_PYTHON_BUILD= yes
-USE_GMAKE= yes
GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
@@ -114,18 +112,7 @@ PLIST_SUB+= CLAMAVUSER=${CLAMAVUSER} \
PORTSCOUT= ignore:1
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "i386"
-CFLAGS+= -march=i486
-.endif
-
-.if ${OSVERSION} >= 700000
-BUILD_DEPENDS+= ${LOCALBASE}/include/check.h:${PORTSDIR}/devel/libcheck
-CONFIGURE_ARGS+=--enable-check
-.else
-CONFIGURE_ARGS+=--disable-check
-.endif
+.include <bsd.port.options.mk>
.if defined(WITH_ARC)
RUN_DEPENDS+= arc:${PORTSDIR}/archivers/arc
@@ -154,6 +141,8 @@ CONFIGURE_ARGS+=--without-iconv
.if defined(WITH_LLVM)
CONFIGURE_ARGS+=--enable-llvm
+USE_PYTHON_BUILD= yes
+USE_GMAKE= yes
.else
CONFIGURE_ARGS+=--disable-llvm
.endif
@@ -183,6 +172,19 @@ PLIST_SUB+= CLAMAV-MILTER="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-shared_output.c
.endif
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+CFLAGS+= -march=i486
+.endif
+
+.if ${OSVERSION} >= 700000
+BUILD_DEPENDS+= ${LOCALBASE}/include/check.h:${PORTSDIR}/devel/libcheck
+CONFIGURE_ARGS+=--enable-check
+.else
+CONFIGURE_ARGS+=--disable-check
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}