aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2019-02-10 07:50:18 +0800
committercpm <cpm@FreeBSD.org>2019-02-10 07:50:18 +0800
commitbd1f9bd02c977e1deb90566bf1beae6088977643 (patch)
tree61ed83d36283cbedf9e00b865dc9e72e2ffc2407 /security
parenta4542931dfc023e26f50f29cb58dc530c463919f (diff)
downloadfreebsd-ports-gnome-bd1f9bd02c977e1deb90566bf1beae6088977643.tar.gz
freebsd-ports-gnome-bd1f9bd02c977e1deb90566bf1beae6088977643.tar.zst
freebsd-ports-gnome-bd1f9bd02c977e1deb90566bf1beae6088977643.zip
- Add udev rules for some new devices (BioPass FIDO2, JaCarta2 U2F, Tomu board with chopstx U2F)
- Bump PORTREVISION Approved by: Greg V <greg@unrelenting.technology> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/u2f-devd/Makefile2
-rw-r--r--security/u2f-devd/files/u2f.conf26
2 files changed, 22 insertions, 6 deletions
diff --git a/security/u2f-devd/Makefile b/security/u2f-devd/Makefile
index 1218a815b36d..55a2a56c0e13 100644
--- a/security/u2f-devd/Makefile
+++ b/security/u2f-devd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= u2f-devd
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security
MASTER_SITES= #
DISTFILES= #
diff --git a/security/u2f-devd/files/u2f.conf b/security/u2f-devd/files/u2f.conf
index 8f1321cd900c..cd107908d81f 100644
--- a/security/u2f-devd/files/u2f.conf
+++ b/security/u2f-devd/files/u2f.conf
@@ -66,19 +66,19 @@ attach 100 {
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
-# Feitian ePass FIDO
+# Feitian ePass FIDO, BioPass FIDO2
notify 100 {
match "system" "USB";
match "subsystem" "DEVICE";
match "type" "ATTACH";
match "vendor" "0x096e";
- match "product" "(0x0850|0x0852|0x0853|0x0854|0x0856|0x0858|0x085a|0x085b)";
+ match "product" "(0x0850|0x0852|0x0853|0x0854|0x0856|0x0858|0x085a|0x085b|0x085d)";
action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
};
attach 100 {
match "vendor" "0x096e";
- match "product" "(0x0850|0x0852|0x0853|0x0854|0x0856|0x0858|0x085a|0x085b)";
+ match "product" "(0x0850|0x0852|0x0853|0x0854|0x0856|0x0858|0x085a|0x085b|0x085d)";
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
@@ -88,13 +88,13 @@ notify 100 {
match "subsystem" "DEVICE";
match "type" "ATTACH";
match "vendor" "0x24dc";
- match "product" "0x0101";
+ match "product" "(0x0101|0x0501)";
action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
};
attach 100 {
match "vendor" "0x24dc";
- match "product" "0x0101";
+ match "product" "(0x0101|0x0501)";
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
@@ -193,3 +193,19 @@ attach 100 {
match "product" "0x5026";
action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
};
+
+# Tomu board + chopstx U2F
+notify 100 {
+ match "system" "USB";
+ match "subsystem" "DEVICE";
+ match "type" "ATTACH";
+ match "vendor" "0x0483";
+ match "product" "0xcdab";
+ action "chgrp u2f /dev/$cdev; chmod g+rw /dev/$cdev";
+};
+
+attach 100 {
+ match "vendor" "0x0483";
+ match "product" "0xcdab";
+ action "chgrp u2f /dev/$device-name; chmod g+rw /dev/$device-name";
+};