aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2011-01-30 20:08:25 +0800
committermiwi <miwi@FreeBSD.org>2011-01-30 20:08:25 +0800
commitbd6da148bcecdb9713a45bd054ef70e1ae08181c (patch)
tree92d8d0d70cd60d22a4ec55ad9fc04d9a43f8e6e5 /security
parent4e0b19abd4d1b86caa3a9a4f74c25d813aa113a5 (diff)
downloadfreebsd-ports-gnome-bd6da148bcecdb9713a45bd054ef70e1ae08181c.tar.gz
freebsd-ports-gnome-bd6da148bcecdb9713a45bd054ef70e1ae08181c.tar.zst
freebsd-ports-gnome-bd6da148bcecdb9713a45bd054ef70e1ae08181c.zip
bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD
project for hashing passwords. bcrypt-ruby provides a simple, humane wrapper for safely handling passwords. WWW: http://rubygems.org/gems/bcrypt-ruby PR: ports/153965 Submitted by: Jason Helfman <jhelfman at experts-exchange.com> Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-bcrypt-ruby/Makefile21
-rw-r--r--security/rubygem-bcrypt-ruby/distinfo2
-rw-r--r--security/rubygem-bcrypt-ruby/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a492853b313e..9dd45ab5c858 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -753,6 +753,7 @@
SUBDIR += ruby-pam
SUBDIR += ruby-password
SUBDIR += ruby-tcpwrap
+ SUBDIR += rubygem-bcrypt-ruby
SUBDIR += rubygem-ezcrypto
SUBDIR += rubygem-net-scp
SUBDIR += rubygem-net-sftp
diff --git a/security/rubygem-bcrypt-ruby/Makefile b/security/rubygem-bcrypt-ruby/Makefile
new file mode 100644
index 000000000000..1121cf56d163
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/Makefile
@@ -0,0 +1,21 @@
+# Ports collection makefile for: rubygem-bcrypt-ruby
+# Date created: 13 January 2011
+# Whom: Jason Helfman <jhelfman@experts-exchange.com>
+#
+# $FreeBSD$
+
+PORTNAME= bcrypt-ruby
+PORTVERSION= 2.1.4
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jhelfman@experts-exchange.com
+COMMENT= Sophisticated and secure hash algorithm for passwords
+
+RUN_DEPENDS+= bcrypt:${PORTSDIR}/security/bcrypt
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-bcrypt-ruby/distinfo b/security/rubygem-bcrypt-ruby/distinfo
new file mode 100644
index 000000000000..b54f93374d80
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bcrypt-ruby-2.1.4.gem) = 6198fa6c0c1a2c2fc437e03f956866fa82e2178f4d4006ce5a77823e4643d853
+SIZE (rubygem/bcrypt-ruby-2.1.4.gem) = 39424
diff --git a/security/rubygem-bcrypt-ruby/pkg-descr b/security/rubygem-bcrypt-ruby/pkg-descr
new file mode 100644
index 000000000000..0b6168daf640
--- /dev/null
+++ b/security/rubygem-bcrypt-ruby/pkg-descr
@@ -0,0 +1,5 @@
+bcrypt() is a sophisticated and secure hash algorithm designed by The OpenBSD
+project for hashing passwords. bcrypt-ruby provides a simple, humane wrapper
+for safely handling passwords.
+
+WWW: http://rubygems.org/gems/bcrypt-ruby