aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
committertijl <tijl@FreeBSD.org>2014-09-17 15:38:15 +0800
commitc06f97c7c46a03f3f6bb887aee3534bece5267a1 (patch)
tree320f49e86d38a480aace5bd0e27c34d6c8f75c2c /security
parent682bd0d0ee3984087ff6a9f3bf4b0552db04d013 (diff)
downloadfreebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.gz
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.tar.zst
freebsd-ports-gnome-c06f97c7c46a03f3f6bb887aee3534bece5267a1.zip
Replace USE_AUTOTOOLS=libltdl with an ordinary LIB_DEPENDS in all ports.
There are only 60 such ports so there doesn't need to be a separate keyword or USES for this. Approved by: portmgr (bapt)
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile4
-rw-r--r--security/courier-authlib/Makefile3
-rw-r--r--security/libp11/Makefile3
-rw-r--r--security/libprelude/Makefile4
-rw-r--r--security/libpreludedb/Makefile4
-rw-r--r--security/openct/Makefile3
-rw-r--r--security/xca/Makefile3
-rw-r--r--security/xmlsec1/Makefile3
8 files changed, 16 insertions, 11 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index af3b9a0f3bae..1c745b6a038b 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -12,7 +12,8 @@ COMMENT= Command line virus scanner written entirely in C
LICENSE= GPLv2
-LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libcurl.so:${PORTSDIR}/ftp/curl
OPTIONS_DEFINE= ARC ARJ LHA UNZOO UNRAR LLVM TESTS MILTER LDAP ICONV STDERR \
EXPERIMENTAL DOCS IPV6 DMG_XAR
@@ -64,7 +65,6 @@ PLIST_SUB+= DBDIR=${DBDIR:S/^\///} \
CLAMAVUSER=${CLAMAVUSER} \
CLAMAVGROUP=${CLAMAVGROUP}
PY_NO_THREAD= ${WRKDIR}/.python-has-no-threads
-USE_AUTOTOOLS= libltdl
OPTIONS_SUB= yes
CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
diff --git a/security/courier-authlib/Makefile b/security/courier-authlib/Makefile
index 33edb889a44d..9cb6cf4cd5dd 100644
--- a/security/courier-authlib/Makefile
+++ b/security/courier-authlib/Makefile
@@ -31,8 +31,9 @@ OPTIONS_DEFINE+= GDBM
.else # !defined(PKGNAMESUFFIX)
+LIB_DEPENDS+= libltdl.so:${PORTSDIR}/devel/libltdl
+
USES= iconv gmake libtool perl5 tar:bzip2
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USE_SUBMAKE= yes
diff --git a/security/libp11/Makefile b/security/libp11/Makefile
index b1260369a844..dd3887687f1e 100644
--- a/security/libp11/Makefile
+++ b/security/libp11/Makefile
@@ -12,9 +12,10 @@ COMMENT= Small layer on top of PKCS\#11 API
LICENSE= LGPL21
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
OPTIONS_DEFINE= DOCS EXAMPLES
-USE_AUTOTOOLS= libltdl
USE_OPENSSL= yes
GNU_CONFIGURE= yes
USES= libtool pkgconfig
diff --git a/security/libprelude/Makefile b/security/libprelude/Makefile
index b2ad8d379c1c..e9184041a80e 100644
--- a/security/libprelude/Makefile
+++ b/security/libprelude/Makefile
@@ -13,7 +13,8 @@ COMMENT= Framework library for Prelude NIDS
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE.README
-LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libgmp.so:${PORTSDIR}/math/gmp \
libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgpg-error.so:${PORTSDIR}/security/libgpg-error \
@@ -24,7 +25,6 @@ OPTIONS_DEFINE= DOCS PERL PYTHON
OPTIONS_SUB= yes
USES= charsetfix gettext gmake iconv libtool pathfix pkgconfig
-USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static \
diff --git a/security/libpreludedb/Makefile b/security/libpreludedb/Makefile
index 5221df2c8185..db79eb430b9b 100644
--- a/security/libpreludedb/Makefile
+++ b/security/libpreludedb/Makefile
@@ -12,7 +12,8 @@ COMMENT= Framework library for access to Prelude NIDS database
LICENSE= GPLv2
-LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl \
+ libgmp.so:${PORTSDIR}/math/gmp \
libgnutls.so:${PORTSDIR}/security/gnutls \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgpg-error.so:${PORTSDIR}/security/libgpg-error \
@@ -21,7 +22,6 @@ LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp \
libp11-kit.so:${PORTSDIR}/security/p11-kit
USES= gettext gmake iconv libtool
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-gtk-doc=no \
--with-html-dir=${PREFIX}/share/doc
diff --git a/security/openct/Makefile b/security/openct/Makefile
index 2dc7ceab42df..72a606d2365b 100644
--- a/security/openct/Makefile
+++ b/security/openct/Makefile
@@ -12,10 +12,11 @@ COMMENT= Middleware framework for smart card terminals
LICENSE= LGPL21
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
OPTIONS_DEFINE= PCSC DOCS
PCSC_DESC= Enable PC/SC support
-USE_AUTOTOOLS= libltdl
GNU_CONFIGURE= yes
USES= gmake libtool pkgconfig
USE_LDCONFIG= yes
diff --git a/security/xca/Makefile b/security/xca/Makefile
index a960fce800c0..b0c9e6e169b5 100644
--- a/security/xca/Makefile
+++ b/security/xca/Makefile
@@ -12,9 +12,10 @@ COMMENT= Graphical certification authority
LICENSE= BSD
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
USE_OPENSSL= yes
USE_QT4= gui moc_build uic_build qmake_build rcc_build linguist_build
-USE_AUTOTOOLS= libltdl
USES= desktop-file-utils gmake shared-mime-info
DESTDIRNAME= destdir
diff --git a/security/xmlsec1/Makefile b/security/xmlsec1/Makefile
index 4f9247b8c4ad..eb04e683c792 100644
--- a/security/xmlsec1/Makefile
+++ b/security/xmlsec1/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://www.aleksey.com/xmlsec/download/ \
MAINTAINER= johans@FreeBSD.org
COMMENT= XML Security Library
+LIB_DEPENDS= libltdl.so:${PORTSDIR}/devel/libltdl
+
OPTIONS_DEFINE= DOCS GNUTLS NSS
OPTIONS_SUB= yes
GNUTLS_DESC= Enable GNUTLS support
@@ -27,7 +29,6 @@ INSTALL_TARGET= install-strip
USES= libtool:oldver pathfix pkgconfig
USE_OPENSSL= yes
USE_GNOME= libxml2 libxslt
-USE_AUTOTOOLS= libltdl
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include