aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormnag <mnag@FreeBSD.org>2005-12-14 04:04:01 +0800
committermnag <mnag@FreeBSD.org>2005-12-14 04:04:01 +0800
commitc2b2517991df6c94baad2963598de7cee8a6efb9 (patch)
tree8e4ee140b2472c251b8ee4451f63075d3d9f7df5 /security
parent56498570ca276a332fb16a2c8a15626b65955cb2 (diff)
downloadfreebsd-ports-gnome-c2b2517991df6c94baad2963598de7cee8a6efb9.tar.gz
freebsd-ports-gnome-c2b2517991df6c94baad2963598de7cee8a6efb9.tar.zst
freebsd-ports-gnome-c2b2517991df6c94baad2963598de7cee8a6efb9.zip
Update to 0.6.4
PR: 90326 Submitted by: maintainer
Diffstat (limited to 'security')
-rw-r--r--security/ipsec-tools/Makefile9
-rw-r--r--security/ipsec-tools/distinfo6
-rw-r--r--security/ipsec-tools/files/patch-src__racoon__session.c11
3 files changed, 19 insertions, 7 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index 076a8e1cd705..b6349896d638 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -11,7 +11,7 @@
# - $LOCALBASE/sbin/setkey Vs /usr/sbin/setkey
PORTNAME= ipsec-tools
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= security net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ipsec-tools
@@ -29,11 +29,12 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=--enable-debug --enable-dpd --enable-natt=kernel \
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --enable-debug --enable-dpd --enable-natt=kernel \
--enable-frag --enable-ipv6 --enable-shared \
--sysconfdir=${PREFIX}/etc/racoon \
- --with-pkgversion=freebsd-${PORTVERSION} \
+ --with-pkgversion=freebsd-${PORTVERSION}
MAN3= ipsec_set_policy.3 ipsec_strerror.3
MAN5= racoon.conf.5
diff --git a/security/ipsec-tools/distinfo b/security/ipsec-tools/distinfo
index 1fbc9897649b..30765d521ee5 100644
--- a/security/ipsec-tools/distinfo
+++ b/security/ipsec-tools/distinfo
@@ -1,3 +1,3 @@
-SHA256 (ipsec-tools-0.6.3.tar.bz2) = b5755278226d7ca7fecddc50ecd78ec98b0551d11977c8739466709fea3584da
-MD5 (ipsec-tools-0.6.3.tar.bz2) = 8070f90402919d8d313c32c2ee465b2f
-SIZE (ipsec-tools-0.6.3.tar.bz2) = 664796
+SHA256 (ipsec-tools-0.6.4.tar.bz2) = 8c49044caaef39302968c9288760a58c39139814ba12510b66724f0ce6d17127
+MD5 (ipsec-tools-0.6.4.tar.bz2) = d0242a943c82c0cbf28005966ff35e21
+SIZE (ipsec-tools-0.6.4.tar.bz2) = 661573
diff --git a/security/ipsec-tools/files/patch-src__racoon__session.c b/security/ipsec-tools/files/patch-src__racoon__session.c
new file mode 100644
index 000000000000..32b0ed574d96
--- /dev/null
+++ b/security/ipsec-tools/files/patch-src__racoon__session.c
@@ -0,0 +1,11 @@
+--- src/racoon/session.c.orig Tue Dec 13 09:53:34 2005
++++ src/racoon/session.c Tue Dec 13 09:53:38 2005
+@@ -320,7 +320,7 @@ signal_handler(sig)
+ int sig;
+ {
+ switch (sig) {
+-#if 0
++#if 1
+ /*
+ * Is this code section actually usefull? On some systems, the
+ * wait() called during a signal handler may lead to race