aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcpm <cpm@FreeBSD.org>2018-01-22 23:40:11 +0800
committercpm <cpm@FreeBSD.org>2018-01-22 23:40:11 +0800
commitc2c5b9f426ca741aa4eb200de285ee7d27cdfac4 (patch)
tree0bd526a43b76399c08631f3f440307b535483258 /security
parent1d7c2c0d968bc0e63dffb92a8fa413dcf4466261 (diff)
downloadfreebsd-ports-gnome-c2c5b9f426ca741aa4eb200de285ee7d27cdfac4.tar.gz
freebsd-ports-gnome-c2c5b9f426ca741aa4eb200de285ee7d27cdfac4.tar.zst
freebsd-ports-gnome-c2c5b9f426ca741aa4eb200de285ee7d27cdfac4.zip
security/py-josepy: JOSE protocol implementation in Python
JOSE (Javascript Object Signing and Encryption) is a Python implementation of the standards developed by IETF Javascript Object Signing and Encryption (Active WG), in particular the following RFCs: - JSON Web Algorithms (JWA) - JSON Web Key (JWK) - JSON Web Signature (JWS) Originally developed as part of the ACME protocol implementation. WWW: https://josepy.readthedocs.io/en/latest/ Differential Revision: https://reviews.freebsd.org/D14013
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-josepy/Makefile30
-rw-r--r--security/py-josepy/distinfo3
-rw-r--r--security/py-josepy/pkg-descr11
4 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 694683729290..7777dc069017 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -916,6 +916,7 @@
SUBDIR += py-hkdf
SUBDIR += py-htpasswd
SUBDIR += py-itsdangerous
+ SUBDIR += py-josepy
SUBDIR += py-kerberos
SUBDIR += py-keyczar
SUBDIR += py-keyring
diff --git a/security/py-josepy/Makefile b/security/py-josepy/Makefile
new file mode 100644
index 000000000000..c5e676a674bf
--- /dev/null
+++ b/security/py-josepy/Makefile
@@ -0,0 +1,30 @@
+# Created by: Carlos J Puga Medina <cpm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= josepy
+PORTVERSION= 1.0.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cpm@FreeBSD.org
+COMMENT= JOSE protocol implementation in Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=0.8:security/py-cryptography@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.13:security/py-openssl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}setuptools>=1.0:devel/py-setuptools@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+
+.include <bsd.port.mk>
diff --git a/security/py-josepy/distinfo b/security/py-josepy/distinfo
new file mode 100644
index 000000000000..ce6e04173efa
--- /dev/null
+++ b/security/py-josepy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516619168
+SHA256 (josepy-1.0.1.tar.gz) = 9f48b88ca37f0244238b1cc77723989f7c54f7b90b2eee6294390bacfe870acc
+SIZE (josepy-1.0.1.tar.gz) = 50251
diff --git a/security/py-josepy/pkg-descr b/security/py-josepy/pkg-descr
new file mode 100644
index 000000000000..32939b0d3bd1
--- /dev/null
+++ b/security/py-josepy/pkg-descr
@@ -0,0 +1,11 @@
+JOSE (Javascript Object Signing and Encryption) is a Python implementation
+of the standards developed by IETF Javascript Object Signing and Encryption
+(Active WG), in particular the following RFCs:
+
+- JSON Web Algorithms (JWA)
+- JSON Web Key (JWK)
+- JSON Web Signature (JWS)
+
+Originally developed as part of the ACME protocol implementation.
+
+WWW: https://josepy.readthedocs.io/en/latest/