aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-08-09 07:47:31 +0800
committeryuri <yuri@FreeBSD.org>2018-08-09 07:47:31 +0800
commitc6c688ee95beca97bd550c7ad05b7ecfc5eea3fc (patch)
treedde525754047b8a65b07df0daf8463d8e9452e87 /security
parent3f6c342b4d80aae30d7645c38b3345ae17c3a09b (diff)
downloadfreebsd-ports-gnome-c6c688ee95beca97bd550c7ad05b7ecfc5eea3fc.tar.gz
freebsd-ports-gnome-c6c688ee95beca97bd550c7ad05b7ecfc5eea3fc.tar.zst
freebsd-ports-gnome-c6c688ee95beca97bd550c7ad05b7ecfc5eea3fc.zip
New port: security/vanguards-tor: Tor add-on to protect against guard discovery and related attacks
Reported by: Tor upstream notification
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/vanguards-tor/Makefile26
-rw-r--r--security/vanguards-tor/distinfo3
-rw-r--r--security/vanguards-tor/pkg-descr11
4 files changed, 41 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 71a8b34d43fb..9bcd78ec1fb5 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1316,6 +1316,7 @@
SUBDIR += unicornscan
SUBDIR += unssh
SUBDIR += vault
+ SUBDIR += vanguards-tor
SUBDIR += veracrypt
SUBDIR += vinetto
SUBDIR += vlock
diff --git a/security/vanguards-tor/Makefile b/security/vanguards-tor/Makefile
new file mode 100644
index 000000000000..232da9de7ac4
--- /dev/null
+++ b/security/vanguards-tor/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= vanguards
+DISTVERSION= 0.1.1
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMESUFFIX= -tor
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tor add-on to protect against guard discovery and related attacks
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest-runner>0:devel/py-pytest-runner@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}stem>0:security/py-stem@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist noflavors
+NO_ARCH= yes
+
+do-test: # testcases are known to fail: https://github.com/mikeperry-tor/vanguards/issues/27
+ @cd ${WRKSRC} && ${SETENV} PYTHONPATH=${STAGEDIR}${PYTHONPREFIX_SITELIBDIR} ${PYTHON_CMD} -m pytest -rs tests
+
+.include <bsd.port.mk>
diff --git a/security/vanguards-tor/distinfo b/security/vanguards-tor/distinfo
new file mode 100644
index 000000000000..151aba8de7f8
--- /dev/null
+++ b/security/vanguards-tor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533770682
+SHA256 (vanguards-0.1.1.tar.gz) = 6add6b4336b218fd1aa7819cff73d76374ccccf8f4539a07537d8d26491a3f6b
+SIZE (vanguards-0.1.1.tar.gz) = 302117
diff --git a/security/vanguards-tor/pkg-descr b/security/vanguards-tor/pkg-descr
new file mode 100644
index 000000000000..68785ab07e3b
--- /dev/null
+++ b/security/vanguards-tor/pkg-descr
@@ -0,0 +1,11 @@
+This add-on uses the Stem Tor control port library to connect to a Tor control
+port listening on port 9051 (or on an alternate user-specified port, or UNIX
+file system socket).
+
+This addon protects against guard discovery and related traffic analysis
+attacks. A guard discovery attack enables an adversary to determine the guard
+node(s) that are in use by a Tor client and/or Tor onion service. Once the guard
+node is known, traffic analysis attacks that can deanonymize an onion service
+(or onion service user) become easier.
+
+WWW: https://github.com/mikeperry-tor/vanguards