aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-12-04 18:24:33 +0800
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-12-04 18:24:33 +0800
commitc6f1382e04c2b90bd43c72dc5d147b5eedccdcd6 (patch)
tree0eb013eb0ddef6d71686a5820cd2e607f2381883 /security
parent67a6c6f035e40b62749b948c691302079b578215 (diff)
downloadfreebsd-ports-gnome-c6f1382e04c2b90bd43c72dc5d147b5eedccdcd6.tar.gz
freebsd-ports-gnome-c6f1382e04c2b90bd43c72dc5d147b5eedccdcd6.tar.zst
freebsd-ports-gnome-c6f1382e04c2b90bd43c72dc5d147b5eedccdcd6.zip
- An option to force NATT functionality
- Sneak in master sites beautification and use_ldconfig while I'm here PR: ports/105488 Submitted by: bz Approved by: VANHULLEBUS Yvan <yvan.vanhullebus@netasq.com> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/ipsec-tools/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/ipsec-tools/Makefile b/security/ipsec-tools/Makefile
index feb5910f67cc..8ff067ecc0e9 100644
--- a/security/ipsec-tools/Makefile
+++ b/security/ipsec-tools/Makefile
@@ -12,8 +12,7 @@
PORTNAME= ipsec-tools
PORTVERSION= 0.6.6
CATEGORIES= security
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ipsec-tools
+MASTER_SITES= SF
MAINTAINER= vanhu@netasq.com
COMMENT= KAME racoon IKE daemon, ipsec-tools version
@@ -25,7 +24,7 @@ USE_OPENSSL= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --enable-shared --sysconfdir=${PREFIX}/etc/racoon \
--localstatedir=${STATEDIR:S/\/racoon//} \
@@ -41,6 +40,7 @@ OPTIONS= DEBUG "enable Debug support" on \
STATS "enable Statistics logging function" off \
DPD "enable Dead Peer Detection" on \
NATT "enable NAT-Traversal (kernel-patch required)" on \
+ NATTF "require NAT-Traversal (fail without kernel-patch)" off \
FRAG "enable IKE fragmentation payload support" on \
HYBRID "enable Hybrid Mode-cfg and Xauth support" off \
PAM "enable PAM authentication" off \
@@ -89,7 +89,11 @@ CONFIGURE_ARGS+= --disable-dpd
.endif
.ifdef(WITH_NATT)
+. ifdef(WITH_NATTF)
+CONFIGURE_ARGS+= --enable-natt=yes
+. else
CONFIGURE_ARGS+= --enable-natt=kernel
+. endif
.else
CONFIGURE_ARGS+= --disable-natt
.endif