aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-24 12:44:17 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-24 12:44:17 +0800
commitc763050df812af11e0607dd7d69b31ab067c093c (patch)
treeaa116af2ce179457b332c1e5de24e02d0c179cfa /security
parent06e61ce578bc86c82cd449bb52d230bb3d20e8cc (diff)
downloadfreebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.tar.gz
freebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.tar.zst
freebsd-ports-gnome-c763050df812af11e0607dd7d69b31ab067c093c.zip
${PERL} -> ${REINPLACE_CMD}
PR: 39746 Submitted by: Cyrille Lefevre <cyrille.lefevre@laposte.net> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/op/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/security/op/Makefile b/security/op/Makefile
index 388644a94c21..124ab6a842af 100644
--- a/security/op/Makefile
+++ b/security/op/Makefile
@@ -19,6 +19,7 @@ MAINTAINER= cyrille.lefevre@laposte.net
# Global variables
#
+USE_REINPLACE= yes
BINMODE= 4555
MAKE_ARGS= BASE="${PREFIX}" \
OPTS='-Dbsdi -DOP_ACCESS=\"${CONF_DIR}/${CONF_FILE}\"' \
@@ -57,13 +58,13 @@ checkout-files:
post-patch: patch-makefile patch-conf-file
patch-makefile:
- @${PERL} -pi.fbsd \
- -e 's|(install)|$$1 -c| if (!/:/);s|CFLAGS=|CFLAGS+=|' \
+ @${REINPLACE_CMD} \
+ -e '/:/!s|\(install\)|\1 -c|;s|CFLAGS=|CFLAGS+=|' \
${WRKSRC}/Makefile
patch-conf-file:
- @${PERL} -pi.fbsd \
- -e 's|^|#| if (!/^#|DEFAULT|MAGIC/);s|/usr/ucb:||' \
+ @${REINPLACE_CMD} -E \
+ -e '/^#|DEFAULT|MAGIC/!s|^|#|;s|/usr/ucb:||' \
${WRKSRC}/${CONF_FILE}
# Post-install