aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2021-01-06 18:11:55 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2021-01-06 18:11:55 +0800
commitcb4c052480f7f7edeba328f459bcc40a3d52006f (patch)
tree14769e200e366eb4de92d16ca5786a3593397767 /security
parent1e1984c9b51ccc87eed7aa1cee9e2513d672f634 (diff)
downloadfreebsd-ports-gnome-cb4c052480f7f7edeba328f459bcc40a3d52006f.tar.gz
freebsd-ports-gnome-cb4c052480f7f7edeba328f459bcc40a3d52006f.tar.zst
freebsd-ports-gnome-cb4c052480f7f7edeba328f459bcc40a3d52006f.zip
Remove python 2.7 support from newly added ports
Diffstat (limited to 'security')
-rw-r--r--security/gvm/Makefile4
-rw-r--r--security/py-gvm-tools/Makefile2
-rw-r--r--security/py-ospd-openvas/Makefile2
-rw-r--r--security/py-python-gvm/Makefile2
4 files changed, 5 insertions, 5 deletions
diff --git a/security/gvm/Makefile b/security/gvm/Makefile
index 42bc81336d9f..c88c1f0f985f 100644
--- a/security/gvm/Makefile
+++ b/security/gvm/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= security
MAINTAINER= acm@FreeBSD.org
COMMENT= Greenbone vulnerability management (metaport)
-USES= metaport python
+USES= metaport python:3.6+
# Install GVM libraries
RUN_DEPENDS+= ${LOCALBASE}/lib/libgvm_base.so:security/gvm-libs
@@ -32,7 +32,7 @@ OPTIONS_DEFAULT= PYTHON-GVM GVM-TOOLS
PYTHON-GVM_DESC= Install GVM python API library
GVM-TOOLS_DESC= Install GVM tools
-PYTHON-GVM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gvm>=0:security/py-python-gvm@${PY_FLAVOR}
+PYTHON-GVM_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gvm>=0:security/py-python-gvm@${PY_FLAVOR}
GVM-TOOLS_RUN_DEPENDS= gvm-cli:security/py-gvm-tools@${PY_FLAVOR}
.include <bsd.port.mk>
diff --git a/security/py-gvm-tools/Makefile b/security/py-gvm-tools/Makefile
index 3f32bdd6a475..28764db36823 100644
--- a/security/py-gvm-tools/Makefile
+++ b/security/py-gvm-tools/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-gvm>=0:security/py-python-gvm@${PY_FLAVOR}
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/security/py-ospd-openvas/Makefile b/security/py-ospd-openvas/Makefile
index 84c8dcea3f5e..9420c02b10a7 100644
--- a/security/py-ospd-openvas/Makefile
+++ b/security/py-ospd-openvas/Makefile
@@ -19,7 +19,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ospd>=0:security/py-ospd@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}defusedxml>=0:devel/py-defusedxml@${PY_FLAVOR} \
openvas:security/openvas
-USES= python
+USES= python:3.6+
USE_PYTHON= distutils
NO_ARCH= yes
diff --git a/security/py-python-gvm/Makefile b/security/py-python-gvm/Makefile
index 1f5177eccdc0..ea6337c03c6b 100644
--- a/security/py-python-gvm/Makefile
+++ b/security/py-python-gvm/Makefile
@@ -11,7 +11,7 @@ COMMENT= The Greenbone Vulnerability Management Python API library
LICENSE= GPLv3+
-USES= python
+USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes