aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2010-03-11 15:49:46 +0800
committerbrooks <brooks@FreeBSD.org>2010-03-11 15:49:46 +0800
commitcf7737c8859ab907372751a82a5c2d715941368c (patch)
treed693b36b82c85f89c32334cf762303073fdbd4f6 /security
parent5de3103a06c4c0d27f8283d5ce9f77d391d62a93 (diff)
downloadfreebsd-ports-gnome-cf7737c8859ab907372751a82a5c2d715941368c.tar.gz
freebsd-ports-gnome-cf7737c8859ab907372751a82a5c2d715941368c.tar.zst
freebsd-ports-gnome-cf7737c8859ab907372751a82a5c2d715941368c.zip
Use CMGROUP_MAX instead of NGROUPS and the argument to SOCKCREDSIZE().
This is a NO-OP except on 8/9 where it is a bugfix.
Diffstat (limited to 'security')
-rw-r--r--security/heimdal/Makefile2
-rw-r--r--security/heimdal/files/patch-kcm_connect.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 094938c5594f..b2e8ad12af5a 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,7 +7,7 @@
PORTNAME= heimdal
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ipv6
MASTER_SITES= http://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
diff --git a/security/heimdal/files/patch-kcm_connect.c b/security/heimdal/files/patch-kcm_connect.c
new file mode 100644
index 000000000000..88e3462bbeb3
--- /dev/null
+++ b/security/heimdal/files/patch-kcm_connect.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- kcm/connect.c.orig
++++ kcm/connect.c
+@@ -149,7 +149,7 @@
+ struct sockcred *sc;
+
+ memset(&msg, 0, sizeof(msg));
+- crmsgsize = CMSG_SPACE(SOCKCREDSIZE(NGROUPS));
++ crmsgsize = CMSG_SPACE(SOCKCREDSIZE(CMGROUP_MAX));
+ if (crmsgsize == 0)
+ return 1 ;
+