aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-07-13 02:37:16 +0800
committermiwi <miwi@FreeBSD.org>2007-07-13 02:37:16 +0800
commitd2b504e8a5f1581b099cb53114dd5694c00f910b (patch)
tree8306ba1c65080a3981426d8a69110b3795e1e324 /security
parent092b077c8869dce5279be76e80ea960909aaca9d (diff)
downloadfreebsd-ports-gnome-d2b504e8a5f1581b099cb53114dd5694c00f910b.tar.gz
freebsd-ports-gnome-d2b504e8a5f1581b099cb53114dd5694c00f910b.tar.zst
freebsd-ports-gnome-d2b504e8a5f1581b099cb53114dd5694c00f910b.zip
Crypt::Camellia_PP is a pure perl implementation of Camellia, a 128-bit
symmetrical block cipher with 128-bit, 192-bit, and 256-bit key from NTT and Mitsubishi Electric Corporation. It is one of the approved encryption methods to be used by European Union as well as specified in several Internet RFCs. See also: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html WWW: http://search.cpan.org/dist/Crypt-Camellia_PP/ PR: ports/114525 Submitted by: Yoshisato YANAGISAWA
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Camellia_PP/Makefile20
-rw-r--r--security/p5-Crypt-Camellia_PP/distinfo3
-rw-r--r--security/p5-Crypt-Camellia_PP/pkg-descr8
-rw-r--r--security/p5-Crypt-Camellia_PP/pkg-plist5
5 files changed, 37 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index eb01510d27a3..92b34d293d88 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -356,6 +356,7 @@
SUBDIR += p5-Crypt-CBCeasy
SUBDIR += p5-Crypt-CFB
SUBDIR += p5-Crypt-Caesar
+ SUBDIR += p5-Crypt-Camellia_PP
SUBDIR += p5-Crypt-Chimera
SUBDIR += p5-Crypt-CipherSaber
SUBDIR += p5-Crypt-Cracklib
diff --git a/security/p5-Crypt-Camellia_PP/Makefile b/security/p5-Crypt-Camellia_PP/Makefile
new file mode 100644
index 000000000000..d2012352b5e0
--- /dev/null
+++ b/security/p5-Crypt-Camellia_PP/Makefile
@@ -0,0 +1,20 @@
+# New ports collection Makefile for: p5-Crypt-Camellia_PP
+# Date created: Thu Jul 12 16:35:39 JST 2007
+# Whom: Yoshisato YANAGISAWA
+# $FreeBSD$
+
+PORTNAME= Crypt-Camellia_PP
+PORTVERSION= 0.02
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= yanagisawa@csg.is.titech.ac.jp
+COMMENT= Perl extension for Camellia Encryption Algorithm in pure Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Camellia_PP.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Camellia_PP/distinfo b/security/p5-Crypt-Camellia_PP/distinfo
new file mode 100644
index 000000000000..a094d443f2d0
--- /dev/null
+++ b/security/p5-Crypt-Camellia_PP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Camellia_PP-0.02.tar.gz) = 93db29df8fcc3502d3e37628f283ed68
+SHA256 (Crypt-Camellia_PP-0.02.tar.gz) = 731c5832dd02761ba058dffead18ca0db4bf068367fc378f8239dc19c7e386bc
+SIZE (Crypt-Camellia_PP-0.02.tar.gz) = 112477
diff --git a/security/p5-Crypt-Camellia_PP/pkg-descr b/security/p5-Crypt-Camellia_PP/pkg-descr
new file mode 100644
index 000000000000..272c9b1baf9a
--- /dev/null
+++ b/security/p5-Crypt-Camellia_PP/pkg-descr
@@ -0,0 +1,8 @@
+Crypt::Camellia_PP is a pure perl implementation of Camellia, a 128-bit
+symmetrical block cipher with 128-bit, 192-bit, and 256-bit key from
+NTT and Mitsubishi Electric Corporation. It is one of the approved
+encryption methods to be used by European Union as well as specified
+in several Internet RFCs.
+
+See also: http://info.isl.ntt.co.jp/crypt/eng/camellia/index.html
+WWW: http://search.cpan.org/dist/Crypt-Camellia_PP/
diff --git a/security/p5-Crypt-Camellia_PP/pkg-plist b/security/p5-Crypt-Camellia_PP/pkg-plist
new file mode 100644
index 000000000000..f50549d52ff1
--- /dev/null
+++ b/security/p5-Crypt-Camellia_PP/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Crypt/Camellia_PP.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Camellia_PP/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Camellia_PP/
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/Crypt