aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2015-07-20 20:30:54 +0800
committergarga <garga@FreeBSD.org>2015-07-20 20:30:54 +0800
commitd362185a3ca8a2107bce4de8c185158f7f1618b7 (patch)
treeb26ef23c3a2c8280f4e54768db1270515bf1888a /security
parentdf2c6a68bc8220f246ea52164422f9bca9dc58e4 (diff)
downloadfreebsd-ports-gnome-d362185a3ca8a2107bce4de8c185158f7f1618b7.tar.gz
freebsd-ports-gnome-d362185a3ca8a2107bce4de8c185158f7f1618b7.tar.zst
freebsd-ports-gnome-d362185a3ca8a2107bce4de8c185158f7f1618b7.zip
- Replace DISTVERSION by PORTVERSION otherwise it ends up as 1.8.14.p1,
what is < 1.8.14. [1] - While I'm here silence portlint warnings re-generating patches with make makepatch and removing unnecessary DOCS check Reported by: Robert Burmeister [1]
Diffstat (limited to 'security')
-rw-r--r--security/sudo/Makefile4
-rw-r--r--security/sudo/files/patch-install-sh8
-rw-r--r--security/sudo/files/patch-plugins__sudoers__Makefile.in8
-rw-r--r--security/sudo/files/patch-plugins__sudoers__audit.c6
-rw-r--r--security/sudo/files/patch-plugins__sudoers__sudoers.in6
5 files changed, 15 insertions, 17 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 25cdf1ed168a..cf432578655d 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sudo
-DISTVERSION= 1.8.14p1
+PORTVERSION= 1.8.14p1
CATEGORIES= security
MASTER_SITES= SUDO
@@ -85,13 +85,11 @@ post-patch:
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} -e 's,$$(srcdir)/sudoers2ldif $$(DESTDIR)$$(docdir),$$(srcdir)/sudoers2ldif $$(DESTDIR)$$(bindir),' \
${WRKSRC}/plugins/sudoers/Makefile.in
-.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e 's/mkinstalldirs $$(DESTDIR)$$(docdir)/mkinstalldirs/' \
-e '/for f in $$(OTHER_DOCS); do/d;/@LDAP@for f in $$(OTHER_DOCS_LDAP); do/d' \
${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's/$$(DESTDIR)$$(sudoersdir) $$(DESTDIR)$$(docdir)/$$(DESTDIR)$$(sudoersdir)/' \
${WRKSRC}/plugins/sudoers/Makefile.in
-.endif
post-install:
${INSTALL_DATA} ${FILESDIR}/pam.conf ${STAGEDIR}${PREFIX}/etc/pam.d/sudo.default
diff --git a/security/sudo/files/patch-install-sh b/security/sudo/files/patch-install-sh
index 74b3a6a11c08..935b263be5d2 100644
--- a/security/sudo/files/patch-install-sh
+++ b/security/sudo/files/patch-install-sh
@@ -1,6 +1,6 @@
---- install-sh.orig 2014-09-24 01:40:15.000000000 +0900
-+++ install-sh 2014-10-10 07:26:54.000000000 +0900
-@@ -171,12 +171,6 @@
+--- install-sh.orig 2015-07-15 18:38:05 UTC
++++ install-sh
+@@ -171,12 +171,6 @@ if ${DIRMODE} ; then
if [ ! -d "${DEST}" ] ; then
${MKDIR} "${DEST}" || exit 1
fi
@@ -13,7 +13,7 @@
if ${CHMODIT} ; then
${CHMOD} "${MODE}" "${DEST}" || exit 1
fi
-@@ -227,12 +221,6 @@
+@@ -227,12 +221,6 @@ fi
if ${STRIPIT} ; then
${STRIP} "${DEST}" || exit 1
fi
diff --git a/security/sudo/files/patch-plugins__sudoers__Makefile.in b/security/sudo/files/patch-plugins__sudoers__Makefile.in
index 9584fa81fdf5..6ca8dc23ada6 100644
--- a/security/sudo/files/patch-plugins__sudoers__Makefile.in
+++ b/security/sudo/files/patch-plugins__sudoers__Makefile.in
@@ -1,6 +1,6 @@
---- plugins/sudoers/Makefile.in.orig 2014-10-08 05:26:20.000000000 +0900
-+++ plugins/sudoers/Makefile.in 2014-10-10 07:23:21.000000000 +0900
-@@ -323,8 +323,7 @@
+--- plugins/sudoers/Makefile.in.orig 2015-07-15 18:44:07 UTC
++++ plugins/sudoers/Makefile.in
+@@ -336,8 +336,7 @@ install-plugin: sudoers.la install-dirs
install-sudoers: install-dirs
$(INSTALL) -d $(INSTALL_OWNER) -m 0750 $(DESTDIR)$(sudoersdir)/sudoers.d
@@ -9,4 +9,4 @@
+ $(INSTALL) $(INSTALL_OWNER) -m $(sudoers_mode) sudoers $(DESTDIR)$(sudoersdir)/sudoers
uninstall:
- -$(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(plugindir)/sudoers.la
+ -$(LIBTOOL) $(LTFLAGS) --mode=uninstall rm -f $(DESTDIR)$(plugindir)/sudoers.la
diff --git a/security/sudo/files/patch-plugins__sudoers__audit.c b/security/sudo/files/patch-plugins__sudoers__audit.c
index 8e4bf09a4f10..73821c23ca1d 100644
--- a/security/sudo/files/patch-plugins__sudoers__audit.c
+++ b/security/sudo/files/patch-plugins__sudoers__audit.c
@@ -1,6 +1,6 @@
---- plugins/sudoers/audit.c.orig 2014-09-24 01:40:15.000000000 +0900
-+++ plugins/sudoers/audit.c 2014-10-10 07:24:43.000000000 +0900
-@@ -42,6 +42,7 @@
+--- plugins/sudoers/audit.c.orig 2015-07-15 18:44:07 UTC
++++ plugins/sudoers/audit.c
+@@ -24,6 +24,7 @@
#ifdef HAVE_BSM_AUDIT
# include "bsm_audit.h"
diff --git a/security/sudo/files/patch-plugins__sudoers__sudoers.in b/security/sudo/files/patch-plugins__sudoers__sudoers.in
index d4f6230e7560..cdc4428cb78b 100644
--- a/security/sudo/files/patch-plugins__sudoers__sudoers.in
+++ b/security/sudo/files/patch-plugins__sudoers__sudoers.in
@@ -1,6 +1,6 @@
---- ./plugins/sudoers/sudoers.in.orig 2010-08-18 07:45:38.000000000 -0400
-+++ ./plugins/sudoers/sudoers.in 2011-04-11 12:47:45.440272893 -0400
-@@ -31,6 +31,14 @@
+--- plugins/sudoers/sudoers.in.orig 2015-07-15 18:44:07 UTC
++++ plugins/sudoers/sudoers.in
+@@ -32,6 +32,14 @@
##
## Defaults specification
##