aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-01-18 01:32:49 +0800
committerbapt <bapt@FreeBSD.org>2014-01-18 01:32:49 +0800
commitd428f1f9e031cfc3d812cc5f900816b9fb2edbce (patch)
tree28bfea38ec229639a28c0322e3639111b66a829d /security
parenta3142232da3cc61b50b68038701ca88dfa21dda3 (diff)
downloadfreebsd-ports-gnome-d428f1f9e031cfc3d812cc5f900816b9fb2edbce.tar.gz
freebsd-ports-gnome-d428f1f9e031cfc3d812cc5f900816b9fb2edbce.tar.zst
freebsd-ports-gnome-d428f1f9e031cfc3d812cc5f900816b9fb2edbce.zip
Support stage
Get rid of NOPORTDATA Convert USE_GMAKE ->USES = gmake Do not include the license file for a well known license
Diffstat (limited to 'security')
-rw-r--r--security/truecrack/Makefile16
1 files changed, 5 insertions, 11 deletions
diff --git a/security/truecrack/Makefile b/security/truecrack/Makefile
index 914f72c9ff30..d0cfb488a038 100644
--- a/security/truecrack/Makefile
+++ b/security/truecrack/Makefile
@@ -9,32 +9,26 @@ MASTER_SITES= https://truecrack.googlecode.com/files/ \
DISTNAME= ${PORTNAME}
MAINTAINER= zi@FreeBSD.org
-COMMENT= A password cracker for TrueCrypt volumes
+COMMENT= Password cracker for TrueCrypt volumes
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/license.txt
-USE_GMAKE= yes
+USES= gmake
CFLAGS+= -DTC_BSD
PLIST_FILES= bin/truecrack
-.if !defined(NOPORTDATA)
DICTIONARIES= dictionary_100k.txt dictionary_10k.txt dictionary.txt
PORTDATA= ${DICTIONARIES}
-.endif
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's/CFLAGS =/CFLAGS +=/g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's/return ;/return 0;/g' ${WRKSRC}/Main/Utils.c
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/truecrack ${PREFIX}/bin
-.if !defined(NOPORTDATA)
+ ${INSTALL_PROGRAM} ${WRKSRC}/truecrack ${STAGEDIR}${PREFIX}/bin
.for dict in ${DICTIONARIES}
- @${MKDIR} ${DATADIR}
- @${INSTALL_DATA} ${WRKSRC}/${dict} ${DATADIR}
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/${dict} ${STAGEDIR}${DATADIR}
.endfor
-.endif
.include <bsd.port.mk>