aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-11 13:56:30 +0800
committermarino <marino@FreeBSD.org>2016-09-11 13:56:30 +0800
commitd4e4663a7480b5f70dc84f82e53bc1b019cbb755 (patch)
tree6d4aef622d19537cfbc3e5f81870f79aa69c4d68 /security
parent8c5c2bae6e467c8ca669a04e571b828f0a852874 (diff)
downloadfreebsd-ports-gnome-d4e4663a7480b5f70dc84f82e53bc1b019cbb755.tar.gz
freebsd-ports-gnome-d4e4663a7480b5f70dc84f82e53bc1b019cbb755.tar.zst
freebsd-ports-gnome-d4e4663a7480b5f70dc84f82e53bc1b019cbb755.zip
security/titus; Add SSL flags and fix tab alignment
Approved by: SSL blanket
Diffstat (limited to 'security')
-rw-r--r--security/titus/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/security/titus/Makefile b/security/titus/Makefile
index c1aaa66a9b26..76dd5f83416e 100644
--- a/security/titus/Makefile
+++ b/security/titus/Makefile
@@ -10,22 +10,22 @@ COMMENT= TLS/SSL proxy server
LICENSE= MIT
-USES= compiler:c++11-lang
+USES= compiler:c++11-lang ssl
USE_RC_SUBR= titus
-USE_OPENSSL= yes
-
USE_GITHUB= yes
GH_ACCOUNT= AGWA
-USERS= titus titus-keys
-GROUPS= nogroup
+USERS= titus titus-keys
+GROUPS= nogroup
MAKE_ENV+= MANDIR=${MANPREFIX}/man
+CFLAGS+= -I${OPENSSLINC}
+LDFLAGS+= -L${OPENSSLLIB}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1002000
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1002000
BROKEN= Requires FreeBSD 10.2 or higher
.endif