aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2006-10-09 02:06:54 +0800
committerroam <roam@FreeBSD.org>2006-10-09 02:06:54 +0800
commitd536b933036a441eb2cc1f3cb72f8912d281a265 (patch)
tree38787d983db5b7f00cc1831c52c98cb5f71bc667 /security
parent0e3b1b0f1ae54f1479f9ac2d5cf654144b17cd4a (diff)
downloadfreebsd-ports-gnome-d536b933036a441eb2cc1f3cb72f8912d281a265.tar.gz
freebsd-ports-gnome-d536b933036a441eb2cc1f3cb72f8912d281a265.tar.zst
freebsd-ports-gnome-d536b933036a441eb2cc1f3cb72f8912d281a265.zip
Fix the problem with unattended deinstallation by not even attempting
to remove the stunnel user and group at all - just kill the package deinstall script. PR: 104028 Reported by: jan grant <jan.grant@bristol.ac.uk>, Stephen Hurd <shurd@sasktel.net> (in private mail a while ago), and, I think, many others
Diffstat (limited to 'security')
-rw-r--r--security/stunnel/Makefile1
-rw-r--r--security/stunnel/pkg-deinstall63
2 files changed, 1 insertions, 63 deletions
diff --git a/security/stunnel/Makefile b/security/stunnel/Makefile
index e100f4db80f0..009cac3f9405 100644
--- a/security/stunnel/Makefile
+++ b/security/stunnel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stunnel
PORTVERSION= 4.18
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.stunnel.org/download/stunnel/src/ \
ftp://stunnel.mirt.net/stunnel/ \
diff --git a/security/stunnel/pkg-deinstall b/security/stunnel/pkg-deinstall
deleted file mode 100644
index bef875e0bc34..000000000000
--- a/security/stunnel/pkg-deinstall
+++ /dev/null
@@ -1,63 +0,0 @@
-#! /bin/sh
-#
-# $FreeBSD$
-# taken from net/cvsup-mirror
-
-PATH=/bin:/usr/sbin
-
-STUNNEL_USER=${STUNNEL_USER:-stunnel}
-STUNNEL_GROUP=${STUNNEL_GROUP:-stunnel}
-
-ask() {
- local question default answer
-
- question=$1
- default=$2
- if [ -z "${PACKAGE_BUILDING}" -a -z "${BATCH}" ]; then
- read -p "${question} [${default}]? " answer
- fi
- if [ x${answer} = x ]; then
- answer=${default}
- fi
- echo ${answer}
-}
-
-yesno() {
- local dflt question answer
-
- question=$1
- dflt=$2
- while :; do
- answer=$(ask "${question}" "${dflt}")
- case "${answer}" in
- [Yy]*) return 0;;
- [Nn]*) return 1;;
- esac
- echo "Please answer yes or no."
- done
-}
-
-delete_account() {
- local u g home
-
- u=$1
- g=$2
- if yesno "Do you want me to remove group \"${g}\"" y; then
- pw groupdel -n ${g}
- echo "Done."
- fi
- if yesno "Do you want me to remove user \"${u}\"" y; then
- eval home=~${u}
- pw userdel -n ${u}
- echo "Done."
- if [ -d "${home}" ]; then
- echo "Please remember to remove the home directory \"${home}\""
- fi
- fi
-}
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-
-delete_account ${STUNNEL_USER} ${STUNNEL_GROUP}