aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2010-01-16 19:30:03 +0800
committerolgeni <olgeni@FreeBSD.org>2010-01-16 19:30:03 +0800
commitdb1b6a9e79fbb5c21cba20426f9e8435bb29a023 (patch)
tree6115ac3eec2489243f8c16ae3e82a21413be9c0e /security
parent44caf45b5b0e8facd883a8e9050d5c7d6ca02378 (diff)
downloadfreebsd-ports-gnome-db1b6a9e79fbb5c21cba20426f9e8435bb29a023.tar.gz
freebsd-ports-gnome-db1b6a9e79fbb5c21cba20426f9e8435bb29a023.tar.zst
freebsd-ports-gnome-db1b6a9e79fbb5c21cba20426f9e8435bb29a023.zip
Add cl-md5-sbcl, a native MD5 implementation in Common Lisp (SBCL
binaries).
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/cl-md5-sbcl/Makefile24
-rw-r--r--security/cl-md5-sbcl/pkg-descr5
-rw-r--r--security/cl-md5-sbcl/pkg-plist2
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 10486d19e187..10f32bffc4ba 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -65,6 +65,7 @@
SUBDIR += chrootuid
SUBDIR += cksfv
SUBDIR += cl-md5
+ SUBDIR += cl-md5-sbcl
SUBDIR += clamassassin
SUBDIR += clamav
SUBDIR += clamav-devel
diff --git a/security/cl-md5-sbcl/Makefile b/security/cl-md5-sbcl/Makefile
new file mode 100644
index 000000000000..67df102688fd
--- /dev/null
+++ b/security/cl-md5-sbcl/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: cl-md5-sbcl
+# Date created: 16 January 2010
+# Whom: Giacomo Olgeni
+#
+# $FreeBSD$
+
+PORTNAME= md5
+PORTVERSION= 1.8.5
+CATEGORIES= security lisp
+PKGNAMEPREFIX= cl-
+DISTFILES= # none
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= A native MD5 implementation in Common Lisp
+
+BUILD_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
+RUN_DEPENDS= ${LOCALBASE}/${CL_LIBDIR_REL}/md5/md5.asd:${PORTSDIR}/security/cl-md5
+
+USE_ASDF_FASL= yes
+FASL_TARGET= sbcl
+FASL_BUILD= yes
+
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
+.include <bsd.port.mk>
diff --git a/security/cl-md5-sbcl/pkg-descr b/security/cl-md5-sbcl/pkg-descr
new file mode 100644
index 000000000000..4879bdbd2565
--- /dev/null
+++ b/security/cl-md5-sbcl/pkg-descr
@@ -0,0 +1,5 @@
+A native MD5 implementation in Common Lisp.
+
+This package is compiled with SBCL.
+
+WWW: http://www.cliki.net/MD5
diff --git a/security/cl-md5-sbcl/pkg-plist b/security/cl-md5-sbcl/pkg-plist
new file mode 100644
index 000000000000..874c7b23ac33
--- /dev/null
+++ b/security/cl-md5-sbcl/pkg-plist
@@ -0,0 +1,2 @@
+%%LIB32DIR%%/common-lisp/md5/sbclfasl/md5.fasl
+@dirrm %%LIB32DIR%%/common-lisp/md5/sbclfasl