aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2021-04-13 21:50:59 +0800
committerVinícius Zavam <egypcio@FreeBSD.org>2021-04-13 21:57:29 +0800
commitdb8dbd775cb9484f9b92f0d1348a2b62ce70ef2f (patch)
tree509f8b31903df6687a10feca86bb23674aa95e9b /security
parente91e2f083ae3f2669812458bb253fd08d40814fd (diff)
downloadfreebsd-ports-gnome-db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f.tar.gz
freebsd-ports-gnome-db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f.tar.zst
freebsd-ports-gnome-db8dbd775cb9484f9b92f0d1348a2b62ce70ef2f.zip
REVIVE: security/apg, Automated Password Generator written in Go
apg-go is a simple APG-like password generator written in Go. It tries to replicate the functionality of the "Automated Password Generator", which hasn't been maintained since 2003. Since FIPS-181 (pronouncable passwords) has been withdrawn in 2015, I didn't see any use in replicating that feature. Therfore apg-go does not support pronouncable passwords. WWW: https://github.com/wneessen/apg-go
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/apg/Makefile19
-rw-r--r--security/apg/distinfo3
-rw-r--r--security/apg/pkg-descr11
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index eb3849e0ebe5..2bafb147f36d 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -26,6 +26,7 @@
SUBDIR += amavisd-milter
SUBDIR += amavisd-new
SUBDIR += apache-xml-security-c
+ SUBDIR += apg
SUBDIR += apkid
SUBDIR += arirang
SUBDIR += arpCounterattack
diff --git a/security/apg/Makefile b/security/apg/Makefile
new file mode 100644
index 000000000000..99907864de77
--- /dev/null
+++ b/security/apg/Makefile
@@ -0,0 +1,19 @@
+PORTNAME= apg
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.3.0
+CATEGORIES= security sysutils
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Automated Password Generator written in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+USE_GITHUB= yes
+GH_ACCOUNT= wneessen
+GH_PROJECT= apg-go
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/security/apg/distinfo b/security/apg/distinfo
new file mode 100644
index 000000000000..30368119ffc6
--- /dev/null
+++ b/security/apg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1618314166
+SHA256 (wneessen-apg-go-v0.3.0_GH0.tar.gz) = acb750ac03de7d467ef3b5f576a7b7eea47d0a4f521c2647d80f0ebe641d3c56
+SIZE (wneessen-apg-go-v0.3.0_GH0.tar.gz) = 13392
diff --git a/security/apg/pkg-descr b/security/apg/pkg-descr
new file mode 100644
index 000000000000..f201dc473dd8
--- /dev/null
+++ b/security/apg/pkg-descr
@@ -0,0 +1,11 @@
+apg-go is a simple APG-like password generator written in Go.
+
+It tries to replicate the functionality of the "Automated Password Generator",
+which hasn't been maintained since 2003. Since more and more Unix
+distributions are abondoning the tool, I was looking for an alternative.
+
+Since FIPS-181 (pronouncable passwords) has been withdrawn in 2015, I didn't
+see any use in replicating that feature. Therfore apg.go does not support
+pronouncable passwords.
+
+WWW: https://github.com/wneessen/apg-go