aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2005-12-18 05:50:56 +0800
committererwin <erwin@FreeBSD.org>2005-12-18 05:50:56 +0800
commite3ab34b2d7211c91c9f95e5ce4c7a900eeed4107 (patch)
tree8ef7651e6e119c145282e211b7ff9c8297ced62e /security
parentda82e9fdefee05456dfd2d8c6b76829fe3e8c5c9 (diff)
downloadfreebsd-ports-gnome-e3ab34b2d7211c91c9f95e5ce4c7a900eeed4107.tar.gz
freebsd-ports-gnome-e3ab34b2d7211c91c9f95e5ce4c7a900eeed4107.tar.zst
freebsd-ports-gnome-e3ab34b2d7211c91c9f95e5ce4c7a900eeed4107.zip
Digest::Pearson is an implementation of Peter K. Pearson's hash algorithm
presented in "Fast Hashing of Variable Length Text Strings" - ACM 1990. This hashing technique yields good distribution of hashed results for variable length input strings on the range 0-255, and thus, it is well suited for data load balancing. The implementation is in C, so it is fast. If you prefer a pure Perl version and can tolerate slower speed, you might want to consider Digest::Pearson::PurePerl instead. WWW: http://search.cpan.org/dist/Digest-MD5-Pearson PR: ports/90578 Submitted by: Gabor Kovesdan
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Digest-Pearson/Makefile24
-rw-r--r--security/p5-Digest-Pearson/distinfo3
-rw-r--r--security/p5-Digest-Pearson/pkg-descr10
-rw-r--r--security/p5-Digest-Pearson/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 4ba854f265cb..83cdb7f374cc 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -350,6 +350,7 @@
SUBDIR += p5-Digest-MD5-Reverse
SUBDIR += p5-Digest-ManberHash
SUBDIR += p5-Digest-Nilsimsa
+ SUBDIR += p5-Digest-Pearson
SUBDIR += p5-Digest-SHA
SUBDIR += p5-Digest-SHA1
SUBDIR += p5-Digest-SHA2
diff --git a/security/p5-Digest-Pearson/Makefile b/security/p5-Digest-Pearson/Makefile
new file mode 100644
index 000000000000..5b06fcb5656f
--- /dev/null
+++ b/security/p5-Digest-Pearson/Makefile
@@ -0,0 +1,24 @@
+# Ports collection Makefile for: p5-Digest-Pearson
+# Date created: 17 Dec 2005
+# Whom: Gabor Kovesdan
+# $FreeBSD$
+
+PORTNAME= Digest-Pearson
+PORTVERSION= 1.00
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Digest
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gkovesdan@t-hosting.hu
+COMMENT= Perl extension for Peter K. Pearson's hash algorithm
+
+PERL_CONFIGURE= yes
+
+MAN3= Digest::Pearson.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500503
+IGNORE= requires Perl 5.6. Intall lang/perl5 or lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/security/p5-Digest-Pearson/distinfo b/security/p5-Digest-Pearson/distinfo
new file mode 100644
index 000000000000..89fc036566c2
--- /dev/null
+++ b/security/p5-Digest-Pearson/distinfo
@@ -0,0 +1,3 @@
+MD5 (Digest-Pearson-1.00.tar.gz) = 8f54b796d805a4d164857394ebde83d4
+SHA256 (Digest-Pearson-1.00.tar.gz) = 033179b7b60757fc36f4eb49eb68019bfed0f829e532bfc4a45eea676483e5c8
+SIZE (Digest-Pearson-1.00.tar.gz) = 2952
diff --git a/security/p5-Digest-Pearson/pkg-descr b/security/p5-Digest-Pearson/pkg-descr
new file mode 100644
index 000000000000..a9dcd41d5a5d
--- /dev/null
+++ b/security/p5-Digest-Pearson/pkg-descr
@@ -0,0 +1,10 @@
+Digest::Pearson is an implementation of Peter K. Pearson's hash algorithm
+presented in "Fast Hashing of Variable Length Text Strings" - ACM 1990. This
+hashing technique yields good distribution of hashed results for variable
+length input strings on the range 0-255, and thus, it is well suited for
+data load balancing.
+The implementation is in C, so it is fast. If you prefer a pure Perl version
+and can tolerate slower speed, you might want to consider
+Digest::Pearson::PurePerl instead.
+
+WWW: http://search.cpan.org/dist/Digest-MD5-Pearson
diff --git a/security/p5-Digest-Pearson/pkg-plist b/security/p5-Digest-Pearson/pkg-plist
new file mode 100644
index 000000000000..21df5b8ac42b
--- /dev/null
+++ b/security/p5-Digest-Pearson/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Digest/Pearson.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/Pearson.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson/Pearson.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/Pearson
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Digest/ 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Digest/ 2>/dev/null || true